]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- resurrected R-recommended package, R won't pass make check without recomended
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 # - script for rpm to autoprovides/autorequires R internals
4 #
5
6 %define KernSmooth_version      2.22r19
7 %define VR_version              7.2r30
8 %define boot_version            1.2r27
9 %define cluster_version         1.11.4
10 %define foreign_version         0.8r18
11 %define lattice_version         0.14r16
12 %define mgcv_version            1.3r22
13 %define nlme_version            3.1r78
14 %define rpart_version           3.1r33
15 %define survival_version        2.30
16
17 %include        /usr/lib/rpm/macros.perl
18 Summary:        A language for data analysis and graphics
19 Summary(pl):    Jêzyk do analizy danych oraz grafiki
20 Name:           R
21 Version:        2.4.1
22 Release:        0.1
23 License:        Mixed (distributable), mostly GPL
24 Group:          Development/Languages
25 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
26 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
27 # Source0-md5:  92b33fd2c3e770d595c1a472889230d5
28 Source1:        %{name}.desktop
29 URL:            http://www.r-project.org/
30 BuildRequires:  XFree86-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  blas-devel
34 BuildRequires:  bzip2-devel
35 BuildRequires:  gcc-c++
36 BuildRequires:  gcc-g77
37 BuildRequires:  gettext-devel
38 BuildRequires:  lapack-devel
39 BuildRequires:  libjpeg-devel >= 6b
40 BuildRequires:  libpng-devel >= 1.0.5
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 2.6.26
44 #BuildRequires: lpr
45 BuildRequires:  pcre-devel
46 BuildRequires:  perl-base >= 1:5.6
47 BuildRequires:  readline-devel
48 BuildRequires:  rpm-perlprov
49 BuildRequires:  tcl-devel
50 BuildRequires:  tetex-dvips
51 BuildRequires:  tetex-latex
52 BuildRequires:  tetex-pdftex
53 BuildRequires:  tk-devel
54 BuildRequires:  zip
55 BuildRequires:  zlib-devel >= 1.1.3
56 #Requires:      lpr
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 A system for statistical computation and graphics. R consists of a
61 language plus a run-time environment with graphics, a debugger, access
62 to certain system functions, and the ability to run programs stored in
63 script files.
64
65 The design of R has been heavily influenced by two existing languages:
66 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
67 resulting language is very similar in appearance to S, the underlying
68 implementation and semantics are derived from Scheme.
69
70 %description -l pl
71 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
72 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
73 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
74 zapisanych w skryptach.
75
76 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
77 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
78 implementacja i semantyka wywodzi siê ze Scheme.
79
80 %package base
81 Summary:        The R base distribution
82 Summary(pl):    Podstawowa dystrybucja R
83 License:        GPL v2 / LGPL
84 Group:          Development/Languages
85 Requires(post): perl-base
86 Requires(post): textutils
87 Provides:       R-cran-base
88 Provides:       R-cran-datasets
89 Provides:       R-cran-grDevices
90 Provides:       R-cran-graphics
91 Provides:       R-cran-grid
92 Provides:       R-cran-methods
93 Provides:       R-cran-splines
94 Provides:       R-cran-stats
95 Provides:       R-cran-stats4
96 Provides:       R-cran-tcltk
97 Provides:       R-cran-tools
98 Provides:       R-cran-utils
99
100 %description base
101 R is a language and run-time environment for carrying out interactive
102 statistical data analysis. It is not entirely dissimilar to the S
103 language developed at AT&T Bell Laboratories (and now Lucent
104 Technologies). Indeed, S users will find the environment quite
105 familiar and a good deal of S software will run without change under
106 R.
107
108 %description base -l pl
109 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
110 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
111 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
112 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
113 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
114
115 %package recommended
116 Summary:        Recommended contributed packages for the R language
117 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
118 License:        GPL, free or free for non-commercial use
119 Group:          Development/Languages
120 URL:            http://www.ci.tuwien.ac.at/R/
121 Requires(post,postun):  R-base
122 Requires(post,postun):  perl-base
123 Requires(post,postun):  textutils
124 Requires:       R-base = %{version}-%{release}
125 Obsoletes:      R-cran-KernSmooth
126 Obsoletes:      R-cran-VR
127 Obsoletes:      R-cran-MASS
128 Obsoletes:      R-cran-class
129 Obsoletes:      R-cran-nnet
130 Obsoletes:      R-cran-spatial
131 Obsoletes:      R-cran-boot
132 Obsoletes:      R-cran-cluster
133 Obsoletes:      R-cran-foreign
134 Obsoletes:      R-cran-lattice
135 Obsoletes:      R-cran-mgcv
136 Obsoletes:      R-cran-nlme
137 Obsoletes:      R-cran-rpart
138 Obsoletes:      R-cran-survival
139 Provides:       R-cran-KernSmooth = %{KernSmooth_version}
140 Provides:       R-cran-VR = %{VR_version}
141 Provides:       R-cran-MASS = %{VR_version}
142 Provides:       R-cran-class = %{VR_version}
143 Provides:       R-cran-nnet = %{VR_version}
144 Provides:       R-cran-spatial = %{VR_version}
145 Provides:       R-cran-boot = %{boot_version}
146 Provides:       R-cran-cluster = %{cluster_version}
147 Provides:       R-cran-foreign = %{foreign_version}
148 Provides:       R-cran-lattice = %{lattice_version}
149 Provides:       R-cran-mgcv = %{mgcv_version}
150 Provides:       R-cran-nlme = %{nlme_version}
151 Provides:       R-cran-rpart = %{rpart_version}
152 Provides:       R-cran-survival = %{survival_version}
153 Obsoletes:      R-contrib
154
155 %description recommended
156 Packages which extend the capabilities of the R base distribution and
157 are distributed on the Comprehensive R Archive Network (CRAN).
158
159 %description recommended -l pl
160 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
161 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
162
163 %prep
164 %setup -q
165
166 %build
167 %configure \
168         --enable-R-shlib \
169         --enable-linux-lfs \
170         --with-system-zlib \
171         --with-system-bzlib \
172         --with-system-pcre \
173         --with-libpng \
174         --with-jpeglib \
175         --with-blas \
176         --with-lapack \
177         --with-readline \
178         --with-tcltk \
179         --with-recommended-packages
180
181 %{__make}
182 LANG=C LC_ALL=C %{__make} check
183 %{__make} docs
184 %{__make} help
185 %{__make} html
186 %{__make} info
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
191
192 %{__make} install \
193         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
194         mandir=$RPM_BUILD_ROOT%{_mandir} \
195         bindir=$RPM_BUILD_ROOT%{_bindir} \
196
197
198 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
199
200 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
201 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
202 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
203 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
204 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
205 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
206 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %post
212 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
213  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
214 /sbin/ldconfig
215
216 %postun -p /sbin/ldconfig
217
218 %files base
219 %defattr(644,root,root,755)
220 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
221
222 %{_mandir}/man1/R.1*
223 %attr(755,root,root) %{_bindir}/R
224 %dir %{_libdir}/R
225 %attr(755,root,root) %{_libdir}/R/bin
226 %attr(755,root,root) %{_libdir}/libR*.so
227 %{_libdir}/R/etc
228 %{_libdir}/R/include
229 %{_includedir}/R
230 %{_libdir}/R/share
231 %{_libdir}/R/COPYING
232 %{_libdir}/R/NEWS
233 %{_libdir}/R/SVN-REVISION
234 %dir %{_libdir}/R/library
235 %{_libdir}/%{name}/library/R.css
236 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
237 %dir %{_libdir}/R/doc
238 %{_libdir}/R/doc/[KRm]*
239 %dir %{_libdir}/R/doc/html
240 %{_libdir}/R/doc/html/*.css
241 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
242 %{_libdir}/R/doc/html/packages-head.html
243 %{_libdir}/R/doc/html/*.jpg
244 %dir %{_libdir}/R/doc/html/search
245 %{_libdir}/R/doc/html/search/[A-Z]*
246 %ghost %{_libdir}/R/doc/html/search/index.txt
247 %ghost %{_libdir}/R/doc/html/packages.html
248 %{_desktopdir}/*.desktop
249
250 %attr(755,root,root) %{_libdir}/%{name}/modules
251
252 %{_libdir}/%{name}/library/KernSmooth
253 %{_libdir}/%{name}/library/MASS
254 %{_libdir}/%{name}/library/base
255 %{_libdir}/%{name}/library/boot
256 %{_libdir}/%{name}/library/class
257 %{_libdir}/%{name}/library/cluster
258 %{_libdir}/%{name}/library/datasets
259 %{_libdir}/%{name}/library/foreign
260 %{_libdir}/%{name}/library/grDevices
261 %{_libdir}/%{name}/library/graphics
262 %{_libdir}/%{name}/library/grid
263 %{_libdir}/%{name}/library/lattice
264 %{_libdir}/%{name}/library/methods
265 %{_libdir}/%{name}/library/mgcv
266 %{_libdir}/%{name}/library/nlme
267 %{_libdir}/%{name}/library/nnet
268 %{_libdir}/%{name}/library/rpart
269 %{_libdir}/%{name}/library/spatial
270 %{_libdir}/%{name}/library/survival
271 %{_libdir}/%{name}/library/splines
272 %{_libdir}/%{name}/library/stats
273 %{_libdir}/%{name}/library/stats4
274 %{_libdir}/%{name}/library/tcltk
275 %{_libdir}/%{name}/library/tools
276 %{_libdir}/%{name}/library/utils
277
278 %files recommended
279 %defattr(644,root,root,755)
This page took 0.048106 seconds and 4 git commands to generate.