]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- new-style bcond, s/perl/perl-base/
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 #
4 # Conditional build:
5 %bcond_without  gnome   # without GNOME support
6 #
7 Summary:        A language for data analysis and graphics
8 Summary(pl):    Jêzyk do analizy danych oraz grafiki
9 Name:           R
10 Version:        2.0.0
11 Release:        0.1
12 License:        Mixed (distributable), mostly GPL
13 Group:          Development/Languages
14 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
15 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
16 # Source0-md5:  3900bca37cabb4b76b8d736d51cc9251
17 # Source0-size: 10676072
18 Source1:        %{name}.desktop
19 URL:            http://www.r-project.org/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  blas-devel
24 BuildRequires:  gcc-c++
25 BuildRequires:  gcc-g77
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libpng-devel >= 1.0.5
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool
30 BuildRequires:  libxml-devel
31 BuildRequires:  perl-base >= 1:5.6
32 BuildRequires:  readline-devel
33 BuildRequires:  tetex-latex
34 BuildRequires:  tetex-dvips
35 BuildRequires:  tetex-pdftex
36 BuildRequires:  zip
37 BuildRequires:  zlib >= 1.1.3
38 #BuildRequires: lpr
39 #Requires:      lpr
40 %{?with_gnome:BuildRequires:    gnome-libs-devel}
41 %{?with_gnome:BuildRequires:    ORBit-devel}
42 %{?with_gnome:BuildRequires:    libglade-gnome-devel}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A system for statistical computation and graphics. R consists of a
47 language plus a run-time environment with graphics, a debugger, access
48 to certain system functions, and the ability to run programs stored in
49 script files.
50
51 The design of R has been heavily influenced by two existing languages:
52 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
53 resulting language is very similar in appearance to S, the underlying
54 implementation and semantics are derived from Scheme.
55
56 %description -l pl
57 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
58 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
59 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
60 zapisanych w skryptach.
61
62 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
63 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
64 implementacja i semantyka wywodzi siê ze Scheme.
65
66 %package base
67 Summary:        The R base distribution
68 Summary(pl):    Podstawowa dystrybucja R
69 License:        GPL v2 / LGPL
70 Group:          Development/Languages
71 Requires(post): textutils
72 Requires(post): perl-base
73 Provides:       R-base
74 Provides:       R-datasets
75 Provides:       R-grid
76 Provides:       R-graphics
77 Provides:       R-grDevices
78 Provides:       R-methods
79 Provides:       R-utils
80 Provides:       R-tcltk
81 Provides:       R-splines
82 Provides:       R-stats
83 Provides:       R-stats4
84 Provides:       R-tools
85
86 %description base
87 R is a language and run-time environment for carrying out interactive
88 statistical data analysis. It is not entirely dissimilar to the S
89 language developed at AT&T Bell Laboratories (and now Lucent
90 Technologies). Indeed, S users will find the environment quite
91 familiar and a good deal of S software will run without change under
92 R.
93
94 %description base -l pl
95 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
96 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
97 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
98 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
99 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
100
101 %package recommended
102 Summary:        Recommended contributed packages for the R language
103 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
104 Group:          Development/Languages
105 Provides:       R-KernSmooth
106 Provides:       R-VR
107 Provides:       R-boot
108 Provides:       R-cluster
109 Provides:       R-foreign
110 Provides:       R-lattice
111 Provides:       R-mgcv
112 Provides:       R-nlme
113 Provides:       R-rpart
114 Provides:       R-survival
115 License:        GPL, free or free for non-commercial use
116 URL:            http://www.ci.tuwien.ac.at/R/
117 Requires(post,postun):  R-base
118 Requires(post,postun):  perl-base
119 Requires(post,postun):  textutils
120 Requires:       R-base = %{version}-%{release}
121 Obsoletes:      R-survival4
122 Obsoletes:      R-MASS
123 Obsoletes:      R-clus
124 Obsoletes:      R-class
125 Obsoletes:      R-nnet
126 Obsoletes:      R-spatial
127
128 %description recommended
129 Packages which extend the capabilities of the R base distribution and
130 are distributed on the Comprehensive R Archive Network (CRAN).
131
132 %description recommended -l pl
133 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
134 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
135
136 %package contrib
137 Summary:        Contributed packages for the R language
138 Summary(pl):    Dodatkowe pakiety do jêzyka R
139 License:        Mixed
140 Group:          Development/Languages
141 URL:            http://www.ci.tuwien.ac.at/R/
142 Requires(post,postun):  R-base
143 Requires(post,postun):  perl-base
144 Requires(post,postun):  textutils
145 Requires:       R-base = %{version}-%{release}
146 Requires:       R-VR
147 Provides:       R-acepack
148 Provides:       R-bootstrap
149 Provides:       R-date
150 Provides:       R-e1071
151 Provides:       R-fracdiff
152 Provides:       R-gee
153 Provides:       R-leaps
154 Provides:       R-oz
155 Provides:       R-polynom
156 Provides:       R-princurve
157 Provides:       R-quadprog
158 Provides:       R-xgobi
159 Obsoletes:      R-principal.curve
160
161 %description contrib
162 Packages which extend the capabilities of the R base distribution and
163 are distributed on the Comprehensive R Archive Network (CRAN).
164
165 %description contrib -l pl
166 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
167 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
168
169 %package mlbench
170 Summary:        Machine learning benchmarks
171 Summary(pl):    Testy wydajno¶ci uczenia maszyny
172 Group:          Development/Languages
173 License:        GPL
174 URL:            http://www.ics.uci.edu/~mlearn/MLRepository.html
175 Requires(post,postun):  R-base
176 Requires(post,postun):  perl-base
177 Requires(post,postun):  textutils
178 Requires:       R-base = %{version}-%{release}
179
180 %description mlbench
181 R package which contains a collection of real-world datasets and
182 functions for creating artificial datasets that work as benchmarks for
183 machine learning methods.
184
185 %description mlbench -l pl
186 Ten podpakiet R zawiera zestaw rzeczywistych danych i funkcji do
187 tworzenia sztucznych danych s³u¿±cych jako test wydajno¶ci metod
188 uczenia maszyny.
189
190 %prep
191 %setup -q
192
193 # These files have the path for PERL hard-coded as /usr/local/bin/perl
194 # We need to remove them to avoid dependency problems
195 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
196
197 %build
198 %{__aclocal}
199 %{__autoconf}
200 cp -f /usr/share/automake/config.* .
201 %configure \
202         --with%{!?with_gnome:out}-gnome \
203         --enable-R-shlib \
204         --enable-linux-lfs \
205         --with-zlib \
206         --with-bzlib \
207         --with-pcre \
208         --without-recommended-packages
209
210 %{__make}
211 %{__make} check
212 %{__make} docs
213 %{__make} help
214 %{__make} html
215 %{__make} info
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
220
221 %{__make} install \
222         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
223         mandir=$RPM_BUILD_ROOT%{_mandir} \
224         bindir=$RPM_BUILD_ROOT%{_bindir} \
225         
226
227 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
228
229 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
230 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
231 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
232 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
233 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
234 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
235 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
239
240 %post
241 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
242  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
243 /sbin/ldconfig
244
245 %postun -p /sbin/ldconfig
246
247 %files base
248 %defattr(644,root,root,755)
249 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
250
251 %{_mandir}/man1/R.1*
252 %attr(755,root,root) %{_bindir}/R
253 %dir %{_libdir}/R
254 %{_libdir}/R/afm
255 %attr(755,root,root) %{_libdir}/R/bin
256 %attr(755,root,root) %{_libdir}/libR*.so
257 %{_libdir}/R/etc
258 %{_libdir}/R/include
259 %{_includedir}/R
260 %{_libdir}/R/share
261 %{_libdir}/R/AUTHORS
262 %dir %{_libdir}/R/library
263 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
264 %dir %{_libdir}/R/doc
265 %{_libdir}/R/doc/[KRm]*
266 %dir %{_libdir}/R/doc/html
267 %{_libdir}/R/doc/html/*.css
268 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
269 %{_libdir}/R/doc/html/packages-head.html
270 %{_libdir}/R/doc/html/*.jpg
271 %dir %{_libdir}/R/doc/html/search
272 %{_libdir}/R/doc/html/search/[A-Z]*
273 %ghost %{_libdir}/R/doc/html/search/index.txt
274 %ghost %{_libdir}/R/doc/html/packages.html
275 %{_desktopdir}/*
276
277 %attr(755,root,root) %{_libdir}/%{name}/modules
278
279 %{_libdir}/%{name}/library/base
280 %{_libdir}/%{name}/library/datasets
281 %{_libdir}/%{name}/library/grid
282 %{_libdir}/%{name}/library/graphics
283 %{_libdir}/%{name}/library/grDevices
284 %{_libdir}/%{name}/library/methods
285 %{_libdir}/%{name}/library/utils
286 %{_libdir}/%{name}/library/tcltk
287 %{_libdir}/%{name}/library/splines
288 %{_libdir}/%{name}/library/stats
289 %{_libdir}/%{name}/library/stats4
290 %{_libdir}/%{name}/library/tools
This page took 0.049746 seconds and 4 git commands to generate.