]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- updated BRs
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 # - script for rpm to autoprovides/autorequires R internals
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        A language for data analysis and graphics
7 Summary(pl):    Jêzyk do analizy danych oraz grafiki
8 Name:           R
9 Version:        2.4.1
10 Release:        0.1
11 License:        Mixed (distributable), mostly GPL
12 Group:          Development/Languages
13 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
14 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
15 # Source0-md5:  92b33fd2c3e770d595c1a472889230d5
16 Source1:        %{name}.desktop
17 URL:            http://www.r-project.org/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  blas-devel
22 BuildRequires:  bzip2-devel
23 BuildRequires:  gcc-c++
24 BuildRequires:  gcc-g77
25 BuildRequires:  gettext-devel
26 BuildRequires:  lapack-devel
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel >= 1.0.5
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel >= 2.6.26
32 #BuildRequires: lpr
33 BuildRequires:  pcre-devel
34 BuildRequires:  perl-base >= 1:5.6
35 BuildRequires:  readline-devel
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  tcl-devel
38 BuildRequires:  tetex-dvips
39 BuildRequires:  tetex-latex
40 BuildRequires:  tetex-pdftex
41 BuildRequires:  tk-devel
42 BuildRequires:  zip
43 BuildRequires:  zlib-devel >= 1.1.3
44 #Requires:      lpr
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 A system for statistical computation and graphics. R consists of a
49 language plus a run-time environment with graphics, a debugger, access
50 to certain system functions, and the ability to run programs stored in
51 script files.
52
53 The design of R has been heavily influenced by two existing languages:
54 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
55 resulting language is very similar in appearance to S, the underlying
56 implementation and semantics are derived from Scheme.
57
58 %description -l pl
59 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
60 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
61 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
62 zapisanych w skryptach.
63
64 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
65 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
66 implementacja i semantyka wywodzi siê ze Scheme.
67
68 %package base
69 Summary:        The R base distribution
70 Summary(pl):    Podstawowa dystrybucja R
71 License:        GPL v2 / LGPL
72 Group:          Development/Languages
73 Requires(post): perl-base
74 Requires(post): textutils
75 Provides:       R-cran-base
76 Provides:       R-cran-datasets
77 Provides:       R-cran-grDevices
78 Provides:       R-cran-graphics
79 Provides:       R-cran-grid
80 Provides:       R-cran-methods
81 Provides:       R-cran-splines
82 Provides:       R-cran-stats
83 Provides:       R-cran-stats4
84 Provides:       R-cran-tcltk
85 Provides:       R-cran-tools
86 Provides:       R-cran-utils
87
88 %description base
89 R is a language and run-time environment for carrying out interactive
90 statistical data analysis. It is not entirely dissimilar to the S
91 language developed at AT&T Bell Laboratories (and now Lucent
92 Technologies). Indeed, S users will find the environment quite
93 familiar and a good deal of S software will run without change under
94 R.
95
96 %description base -l pl
97 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
98 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
99 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
100 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
101 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
102
103 %package recommended
104 Summary:        Recommended contributed packages for the R language
105 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
106 License:        GPL, free or free for non-commercial use
107 Group:          Development/Languages
108 URL:            http://www.ci.tuwien.ac.at/R/
109 Requires(post,postun):  R-base
110 Requires(post,postun):  perl-base
111 Requires(post,postun):  textutils
112 Requires:       R-base = %{version}-%{release}
113 Requires:       R-cran-KernSmooth
114 Requires:       R-cran-VR
115 Requires:       R-cran-boot
116 Requires:       R-cran-cluster
117 Requires:       R-cran-foreign
118 Requires:       R-cran-lattice
119 Requires:       R-cran-mgcv
120 Requires:       R-cran-nlme
121 Requires:       R-cran-rpart
122 Requires:       R-cran-survival
123 Obsoletes:      R-contrib
124
125 %description recommended
126 Packages which extend the capabilities of the R base distribution and
127 are distributed on the Comprehensive R Archive Network (CRAN).
128
129 %description recommended -l pl
130 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
131 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
132
133 %prep
134 %setup -q
135
136 # These files have the path for Perl hard-coded as /usr/local/bin/perl
137 # We need to remove them to avoid dependency problems
138 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
139
140 %build
141 %{__aclocal} -I m4
142 %{__autoconf}
143 cp -f /usr/share/automake/config.* .
144 %configure \
145         --enable-R-shlib \
146         --enable-linux-lfs \
147         --with-system-zlib \
148         --with-system-bzlib \
149         --with-system-pcre \
150         --with-libpng \
151         --with-jpeglib \
152         --with-blas \
153         --with-lapack \
154         --with-readline \
155         --with-tcltk \
156         --without-recommended-packages
157
158 %{__make}
159 %{__make} check
160 %{__make} docs
161 %{__make} help
162 %{__make} html
163 %{__make} info
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
168
169 %{__make} install \
170         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
171         mandir=$RPM_BUILD_ROOT%{_mandir} \
172         bindir=$RPM_BUILD_ROOT%{_bindir} \
173
174
175 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
176
177 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
178 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
179 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
180 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
181 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
182 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
183 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post
189 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
190  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
191 /sbin/ldconfig
192
193 %postun -p /sbin/ldconfig
194
195 %files base
196 %defattr(644,root,root,755)
197 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
198
199 %{_mandir}/man1/R.1*
200 %attr(755,root,root) %{_bindir}/R
201 %dir %{_libdir}/R
202 %attr(755,root,root) %{_libdir}/R/bin
203 %attr(755,root,root) %{_libdir}/libR*.so
204 %{_libdir}/R/etc
205 %{_libdir}/R/include
206 %{_includedir}/R
207 %{_libdir}/R/share
208 %{_libdir}/R/AUTHORS
209 %dir %{_libdir}/R/library
210 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
211 %dir %{_libdir}/R/doc
212 %{_libdir}/R/doc/[KRm]*
213 %dir %{_libdir}/R/doc/html
214 %{_libdir}/R/doc/html/*.css
215 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
216 %{_libdir}/R/doc/html/packages-head.html
217 %{_libdir}/R/doc/html/*.jpg
218 %dir %{_libdir}/R/doc/html/search
219 %{_libdir}/R/doc/html/search/[A-Z]*
220 %ghost %{_libdir}/R/doc/html/search/index.txt
221 %ghost %{_libdir}/R/doc/html/packages.html
222 %{_desktopdir}/*.desktop
223
224 %attr(755,root,root) %{_libdir}/%{name}/modules
225
226 %{_libdir}/%{name}/library/base
227 %{_libdir}/%{name}/library/datasets
228 %{_libdir}/%{name}/library/grid
229 %{_libdir}/%{name}/library/graphics
230 %{_libdir}/%{name}/library/grDevices
231 %{_libdir}/%{name}/library/methods
232 %{_libdir}/%{name}/library/utils
233 %{_libdir}/%{name}/library/tcltk
234 %{_libdir}/%{name}/library/splines
235 %{_libdir}/%{name}/library/stats
236 %{_libdir}/%{name}/library/stats4
237 %{_libdir}/%{name}/library/tools
238
239 %files recommended
240 %defattr(644,root,root,755)
This page took 0.050297 seconds and 4 git commands to generate.