]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- updated to 2.4.1
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 # - script for rpm to autoprovides/autorequires R internals
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        A language for data analysis and graphics
7 Summary(pl):    Jêzyk do analizy danych oraz grafiki
8 Name:           R
9 Version:        2.4.1
10 Release:        0.1
11 License:        Mixed (distributable), mostly GPL
12 Group:          Development/Languages
13 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
14 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
15 # Source0-md5:  92b33fd2c3e770d595c1a472889230d5
16 Source1:        %{name}.desktop
17 URL:            http://www.r-project.org/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  blas-devel
22 BuildRequires:  bzip2-devel
23 BuildRequires:  gcc-c++
24 BuildRequires:  gcc-g77
25 BuildRequires:  gettext-devel
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libpng-devel >= 1.0.5
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel >= 2.6.26
31 #BuildRequires: lpr
32 BuildRequires:  perl-base >= 1:5.6
33 BuildRequires:  readline-devel
34 BuildRequires:  rpm-perlprov
35 BuildRequires:  tcl-devel
36 BuildRequires:  tetex-dvips
37 BuildRequires:  tetex-latex
38 BuildRequires:  tetex-pdftex
39 BuildRequires:  tk-devel
40 BuildRequires:  zip
41 BuildRequires:  zlib >= 1.1.3
42 #Requires:      lpr
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A system for statistical computation and graphics. R consists of a
47 language plus a run-time environment with graphics, a debugger, access
48 to certain system functions, and the ability to run programs stored in
49 script files.
50
51 The design of R has been heavily influenced by two existing languages:
52 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
53 resulting language is very similar in appearance to S, the underlying
54 implementation and semantics are derived from Scheme.
55
56 %description -l pl
57 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
58 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
59 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
60 zapisanych w skryptach.
61
62 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
63 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
64 implementacja i semantyka wywodzi siê ze Scheme.
65
66 %package base
67 Summary:        The R base distribution
68 Summary(pl):    Podstawowa dystrybucja R
69 License:        GPL v2 / LGPL
70 Group:          Development/Languages
71 Requires(post): perl-base
72 Requires(post): textutils
73 Provides:       R-cran-base
74 Provides:       R-cran-datasets
75 Provides:       R-cran-grDevices
76 Provides:       R-cran-graphics
77 Provides:       R-cran-grid
78 Provides:       R-cran-methods
79 Provides:       R-cran-splines
80 Provides:       R-cran-stats
81 Provides:       R-cran-stats4
82 Provides:       R-cran-tcltk
83 Provides:       R-cran-tools
84 Provides:       R-cran-utils
85
86 %description base
87 R is a language and run-time environment for carrying out interactive
88 statistical data analysis. It is not entirely dissimilar to the S
89 language developed at AT&T Bell Laboratories (and now Lucent
90 Technologies). Indeed, S users will find the environment quite
91 familiar and a good deal of S software will run without change under
92 R.
93
94 %description base -l pl
95 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
96 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
97 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
98 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
99 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
100
101 %package recommended
102 Summary:        Recommended contributed packages for the R language
103 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
104 License:        GPL, free or free for non-commercial use
105 Group:          Development/Languages
106 URL:            http://www.ci.tuwien.ac.at/R/
107 Requires(post,postun):  R-base
108 Requires(post,postun):  perl-base
109 Requires(post,postun):  textutils
110 Requires:       R-base = %{version}-%{release}
111 Requires:       R-cran-KernSmooth
112 Requires:       R-cran-VR
113 Requires:       R-cran-boot
114 Requires:       R-cran-cluster
115 Requires:       R-cran-foreign
116 Requires:       R-cran-lattice
117 Requires:       R-cran-mgcv
118 Requires:       R-cran-nlme
119 Requires:       R-cran-rpart
120 Requires:       R-cran-survival
121 Obsoletes:      R-contrib
122
123 %description recommended
124 Packages which extend the capabilities of the R base distribution and
125 are distributed on the Comprehensive R Archive Network (CRAN).
126
127 %description recommended -l pl
128 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
129 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
130
131 %prep
132 %setup -q
133
134 # These files have the path for Perl hard-coded as /usr/local/bin/perl
135 # We need to remove them to avoid dependency problems
136 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
137
138 %build
139 %{__aclocal} -I m4
140 %{__autoconf}
141 cp -f /usr/share/automake/config.* .
142 %configure \
143         --enable-R-shlib \
144         --enable-linux-lfs \
145         --with-zlib \
146         --with-bzlib \
147         --with-pcre \
148         --without-recommended-packages
149
150 %{__make}
151 %{__make} check
152 %{__make} docs
153 %{__make} help
154 %{__make} html
155 %{__make} info
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
160
161 %{__make} install \
162         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
163         mandir=$RPM_BUILD_ROOT%{_mandir} \
164         bindir=$RPM_BUILD_ROOT%{_bindir} \
165
166
167 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
168
169 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
170 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
171 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
172 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
173 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
174 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
175 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post
181 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
182  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
183 /sbin/ldconfig
184
185 %postun -p /sbin/ldconfig
186
187 %files base
188 %defattr(644,root,root,755)
189 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
190
191 %{_mandir}/man1/R.1*
192 %attr(755,root,root) %{_bindir}/R
193 %dir %{_libdir}/R
194 %attr(755,root,root) %{_libdir}/R/bin
195 %attr(755,root,root) %{_libdir}/libR*.so
196 %{_libdir}/R/etc
197 %{_libdir}/R/include
198 %{_includedir}/R
199 %{_libdir}/R/share
200 %{_libdir}/R/AUTHORS
201 %dir %{_libdir}/R/library
202 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
203 %dir %{_libdir}/R/doc
204 %{_libdir}/R/doc/[KRm]*
205 %dir %{_libdir}/R/doc/html
206 %{_libdir}/R/doc/html/*.css
207 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
208 %{_libdir}/R/doc/html/packages-head.html
209 %{_libdir}/R/doc/html/*.jpg
210 %dir %{_libdir}/R/doc/html/search
211 %{_libdir}/R/doc/html/search/[A-Z]*
212 %ghost %{_libdir}/R/doc/html/search/index.txt
213 %ghost %{_libdir}/R/doc/html/packages.html
214 %{_desktopdir}/*.desktop
215
216 %attr(755,root,root) %{_libdir}/%{name}/modules
217
218 %{_libdir}/%{name}/library/base
219 %{_libdir}/%{name}/library/datasets
220 %{_libdir}/%{name}/library/grid
221 %{_libdir}/%{name}/library/graphics
222 %{_libdir}/%{name}/library/grDevices
223 %{_libdir}/%{name}/library/methods
224 %{_libdir}/%{name}/library/utils
225 %{_libdir}/%{name}/library/tcltk
226 %{_libdir}/%{name}/library/splines
227 %{_libdir}/%{name}/library/stats
228 %{_libdir}/%{name}/library/stats4
229 %{_libdir}/%{name}/library/tools
230
231 %files recommended
232 %defattr(644,root,root,755)
This page took 0.274783 seconds and 4 git commands to generate.