]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- release 0.2: kill the *.pm properly (symlinks...)
[packages/R.git] / R.spec
1
2 # Conditional build
3 %bcond_without  tcl             # disable tcl support
4 %bcond_without  tests           # do not run "make check"
5
6 # TODO:
7 # - script for rpm to autoprovides/autorequires R internals
8 #
9 %define KernSmooth_version      2.22r19
10 %define VR_version              7.2r30
11 %define boot_version            1.2r27
12 %define cluster_version         1.11.4
13 %define foreign_version         0.8r18
14 %define lattice_version         0.14r16
15 %define mgcv_version            1.3r22
16 %define nlme_version            3.1r78
17 %define rpart_version           3.1r33
18 %define survival_version        2.30
19
20 %include        /usr/lib/rpm/macros.perl
21 Summary:        A language for data analysis and graphics
22 Summary(pl.UTF-8):      Język do analizy danych oraz grafiki
23 Name:           R
24 Version:        2.6.0
25 Release:        0.2
26 License:        Mixed (distributable), mostly GPL
27 Group:          Development/Languages
28 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
29 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
30 # Source0-md5:  97e5d2542349925962b7469456d45731
31 Source1:        %{name}.desktop
32 URL:            http://www.r-project.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  blas-devel
36 BuildRequires:  bzip2-devel
37 BuildRequires:  gcc-c++
38 BuildRequires:  gcc-fortran
39 BuildRequires:  gettext-devel
40 #BuildRequires: lapack-devel >= 3.1.1
41 BuildRequires:  libjpeg-devel >= 6b
42 BuildRequires:  libpng-devel >= 1.0.5
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.6.26
46 BuildRequires:  pcre-devel
47 BuildRequires:  perl-base >= 1:5.6
48 BuildRequires:  readline-devel
49 BuildRequires:  rpm-perlprov
50 %{?with_tcl:BuildRequires:      tcl-devel}
51 BuildRequires:  tetex-dvips
52 BuildRequires:  tetex-latex
53 BuildRequires:  tetex-pdftex
54 %{?with_tcl:BuildRequires:      tk-devel}
55 BuildRequires:  xorg-lib-libX11-devel
56 BuildRequires:  zip
57 BuildRequires:  zlib-devel >= 1.1.3
58 #Requires:      lpr
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 A system for statistical computation and graphics. R consists of a
63 language plus a run-time environment with graphics, a debugger, access
64 to certain system functions, and the ability to run programs stored in
65 script files.
66
67 The design of R has been heavily influenced by two existing languages:
68 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
69 resulting language is very similar in appearance to S, the underlying
70 implementation and semantics are derived from Scheme.
71
72 %description -l pl.UTF-8
73 System do obliczeń statystycznych i grafiki. R składa się z języka
74 oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
75 niektórych funkcji systemowych oraz możliwością uruchamiania programów
76 zapisanych w skryptach.
77
78 Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
79 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
80 implementacja i semantyka wywodzi się ze Scheme.
81
82 %package base
83 Summary:        The R base distribution
84 Summary(pl.UTF-8):      Podstawowa dystrybucja R
85 License:        GPL v2 / LGPL
86 Group:          Development/Languages
87 Requires(post): perl-base
88 Requires(post): textutils
89 Provides:       R-cran-base
90 Provides:       R-cran-datasets
91 Provides:       R-cran-grDevices
92 Provides:       R-cran-graphics
93 Provides:       R-cran-grid
94 Provides:       R-cran-methods
95 Provides:       R-cran-splines
96 Provides:       R-cran-stats
97 Provides:       R-cran-stats4
98 Provides:       R-cran-tcltk
99 Provides:       R-cran-tools
100 Provides:       R-cran-utils
101
102 %description base
103 R is a language and run-time environment for carrying out interactive
104 statistical data analysis. It is not entirely dissimilar to the S
105 language developed at AT&T Bell Laboratories (and now Lucent
106 Technologies). Indeed, S users will find the environment quite
107 familiar and a good deal of S software will run without change under
108 R.
109
110 %description base -l pl.UTF-8
111 R jest językiem i środowiskiem uruchomieniowym do interaktywnej
112 analizy danych statystycznych. R nie jest całkowicie zgodny z językiem
113 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
114 mimo to użytkownicy S zauważą zbliżone środowisko, a duża część
115 oprogramowania w S będzie działała bez zmian w R.
116
117 %package recommended
118 Summary:        Recommended contributed packages for the R language
119 Summary(pl.UTF-8):      Zalecane dodatkowe pakiety do języka R
120 License:        GPL, free or free for non-commercial use
121 Group:          Development/Languages
122 URL:            http://www.ci.tuwien.ac.at/R/
123 Requires(post,postun):  R-base
124 Requires(post,postun):  perl-base
125 Requires(post,postun):  textutils
126 Requires:       R-base = %{version}-%{release}
127 Provides:       R-cran-KernSmooth = %{KernSmooth_version}
128 Provides:       R-cran-MASS = %{VR_version}
129 Provides:       R-cran-VR = %{VR_version}
130 Provides:       R-cran-boot = %{boot_version}
131 Provides:       R-cran-class = %{VR_version}
132 Provides:       R-cran-cluster = %{cluster_version}
133 Provides:       R-cran-foreign = %{foreign_version}
134 Provides:       R-cran-lattice = %{lattice_version}
135 Provides:       R-cran-mgcv = %{mgcv_version}
136 Provides:       R-cran-nlme = %{nlme_version}
137 Provides:       R-cran-nnet = %{VR_version}
138 Provides:       R-cran-rpart = %{rpart_version}
139 Provides:       R-cran-spatial = %{VR_version}
140 Provides:       R-cran-survival = %{survival_version}
141 Obsoletes:      R-contrib
142 Obsoletes:      R-cran-KernSmooth
143 Obsoletes:      R-cran-MASS
144 Obsoletes:      R-cran-VR
145 Obsoletes:      R-cran-boot
146 Obsoletes:      R-cran-class
147 Obsoletes:      R-cran-cluster
148 Obsoletes:      R-cran-foreign
149 Obsoletes:      R-cran-lattice
150 Obsoletes:      R-cran-mgcv
151 Obsoletes:      R-cran-nlme
152 Obsoletes:      R-cran-nnet
153 Obsoletes:      R-cran-rpart
154 Obsoletes:      R-cran-spatial
155 Obsoletes:      R-cran-survival
156
157 %description recommended
158 Packages which extend the capabilities of the R base distribution and
159 are distributed on the Comprehensive R Archive Network (CRAN).
160
161 %description recommended -l pl.UTF-8
162 Pakiety rozszerzające możliwości podstawowej dystrybucji języka R,
163 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
164
165 %prep
166 %setup -q
167
168 %build
169 %configure \
170         --enable-R-shlib \
171         --enable-linux-lfs \
172         --with-system-zlib \
173         --with-system-bzlib \
174         --with-system-pcre \
175         --with-libpng \
176         --with-jpeglib \
177         --with-blas \
178         --with-readline \
179         --with%{!?with_tcl:out}-tcltk \
180         --with-recommended-packages
181
182 # R gets into infinite loop in src/library/grDevices when this is enabled
183 #       --with-lapack \
184
185 %{__make}
186 %{__make} %{?with_tests:check} docs help html info
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
191 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
192
193 %{__make} install \
194         DESTDIR=${RPM_BUILD_ROOT}
195
196 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
197
198 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
199 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
200 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
201 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
202 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
203 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
204 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
205
206 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
207 for f in * ; do
208   ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
209 done)
210 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
211 for f in * ; do
212   ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
213 done)
214
215 rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/{Text,R}
216 rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/{File,Text}
217 mv    $RPM_BUILD_ROOT%{_libdir}/R/share/perl/R $RPM_BUILD_ROOT%{perl_vendorlib}
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %post
223 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
224  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
225 /sbin/ldconfig
226
227 %postun -p /sbin/ldconfig
228
229 %files base
230 %defattr(644,root,root,755)
231 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
232
233 %{_mandir}/man1/R.1*
234 %{_mandir}/man1/Rscript*
235 %attr(755,root,root) %{_bindir}/R
236 %attr(755,root,root) %{_bindir}/Rscript
237 %dir %{_libdir}/R
238 %attr(755,root,root) %{_libdir}/R/bin
239 %attr(755,root,root) %{_libdir}/libR*.so
240 %{_libdir}/R/etc
241 %{_libdir}/R/include
242 %{_includedir}/R
243 %{_libdir}/R/share
244 %{_libdir}/R/COPYING
245 %{_libdir}/R/NEWS
246 %{_libdir}/R/SVN-REVISION
247 %dir %{_libdir}/R/library
248 %{_libdir}/%{name}/library/R.css
249 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
250 %dir %{_libdir}/R/doc
251 %{_libdir}/R/doc/[KRm]*
252 %dir %{_libdir}/R/doc/html
253 %{_libdir}/R/doc/html/*.css
254 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
255 %{_libdir}/R/doc/html/packages-head*.html
256 %{_libdir}/R/doc/html/*.jpg
257 %dir %{_libdir}/R/doc/html/search
258 %{_libdir}/R/doc/html/search/[A-Z]*
259 %ghost %{_libdir}/R/doc/html/search/index.txt
260 %ghost %{_libdir}/R/doc/html/packages.html
261 %{_desktopdir}/*.desktop
262
263 %{perl_vendorlib}/R
264
265 %attr(755,root,root) %{_libdir}/%{name}/modules
266
267 %{_libdir}/%{name}/library/KernSmooth
268 %{_libdir}/%{name}/library/MASS
269 %{_libdir}/%{name}/library/base
270 %{_libdir}/%{name}/library/boot
271 %{_libdir}/%{name}/library/class
272 %{_libdir}/%{name}/library/cluster
273 %{_libdir}/%{name}/library/codetools
274 %{_libdir}/%{name}/library/datasets
275 %{_libdir}/%{name}/library/foreign
276 %{_libdir}/%{name}/library/grDevices
277 %{_libdir}/%{name}/library/graphics
278 %{_libdir}/%{name}/library/grid
279 %{_libdir}/%{name}/library/lattice
280 %{_libdir}/%{name}/library/methods
281 %{_libdir}/%{name}/library/mgcv
282 %{_libdir}/%{name}/library/nlme
283 %{_libdir}/%{name}/library/nnet
284 %{_libdir}/%{name}/library/rcompgen
285 %{_libdir}/%{name}/library/rpart
286 %{_libdir}/%{name}/library/spatial
287 %{_libdir}/%{name}/library/survival
288 %{_libdir}/%{name}/library/splines
289 %{_libdir}/%{name}/library/stats
290 %{_libdir}/%{name}/library/stats4
291 %{_libdir}/%{name}/library/tcltk
292 %{_libdir}/%{name}/library/tools
293 %{_libdir}/%{name}/library/utils
294
295 %{_pkgconfigdir}/*.pc
296
297 %files recommended
298 %defattr(644,root,root,755)
This page took 0.118931 seconds and 3 git commands to generate.