]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- started update to 2.8.1
[packages/R.git] / R.spec
1 #
2 # Conditional build
3 %bcond_without  tcl             # disable tcl support
4 %bcond_without  tests           # do not run "make check"
5 #
6 # TODO:
7 # - WTF is empty -recommended package with P/O which belong to -base ???
8 # - script for rpm to autoprovides/autorequires R internals
9 #
10 %define KernSmooth_version      2.22r22
11 %define VR_version              7.2r45
12 %define boot_version            1.2r34
13 %define cluster_version         1.11.11
14 %define foreign_version         0.8r29
15 %define lattice_version         0.17r17
16 %define mgcv_version            1.4r1.1
17 %define nlme_version            3.1r89
18 %define rpart_version           3.1r42
19 %define survival_version        2.34r1
20
21 %include        /usr/lib/rpm/macros.perl
22 Summary:        A language for data analysis and graphics
23 Summary(pl.UTF-8):      Język do analizy danych oraz grafiki
24 Name:           R
25 Version:        2.8.1
26 Release:        0.1
27 License:        Mixed (distributable), mostly GPL
28 Group:          Development/Languages
29 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
30 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
31 # Source0-md5:  acd40621b8942a2464daa2f9cef3273d
32 Source1:        %{name}.desktop
33 URL:            http://www.r-project.org/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  blas-devel
37 BuildRequires:  bzip2-devel
38 BuildRequires:  cairo-devel
39 BuildRequires:  gcc-c++
40 BuildRequires:  gcc-fortran
41 BuildRequires:  gettext-devel
42 BuildRequires:  lapack-devel >= 3.1.1-4
43 BuildRequires:  libicu-devel
44 BuildRequires:  libjpeg-devel >= 6b
45 BuildRequires:  libpng-devel >= 1.0.5
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 2.6.26
49 BuildRequires:  pango-devel
50 BuildRequires:  pcre-devel
51 BuildRequires:  perl-base >= 1:5.6
52 BuildRequires:  readline-devel
53 BuildRequires:  rpm-perlprov
54 %{?with_tcl:BuildRequires:      tcl-devel}
55 BuildRequires:  tetex-dvips
56 BuildRequires:  tetex-latex
57 BuildRequires:  tetex-pdftex
58 %{?with_tcl:BuildRequires:      tk-devel}
59 BuildRequires:  xorg-lib-libX11-devel
60 BuildRequires:  xorg-lib-libXmu-devel
61 BuildRequires:  xorg-lib-libXt-devel
62 BuildRequires:  zip
63 BuildRequires:  zlib-devel >= 1.1.3
64 #Requires:      lpr
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 A system for statistical computation and graphics. R consists of a
69 language plus a run-time environment with graphics, a debugger, access
70 to certain system functions, and the ability to run programs stored in
71 script files.
72
73 The design of R has been heavily influenced by two existing languages:
74 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
75 resulting language is very similar in appearance to S, the underlying
76 implementation and semantics are derived from Scheme.
77
78 %description -l pl.UTF-8
79 System do obliczeń statystycznych i grafiki. R składa się z języka
80 oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
81 niektórych funkcji systemowych oraz możliwością uruchamiania programów
82 zapisanych w skryptach.
83
84 Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
85 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
86 implementacja i semantyka wywodzi się ze Scheme.
87
88 %package base
89 Summary:        The R base distribution
90 Summary(pl.UTF-8):      Podstawowa dystrybucja R
91 License:        GPL v2 / LGPL
92 Group:          Development/Languages
93 Requires(post): perl-base
94 Requires(post): textutils
95 Provides:       R-cran-base
96 Provides:       R-cran-datasets
97 Provides:       R-cran-grDevices
98 Provides:       R-cran-graphics
99 Provides:       R-cran-grid
100 Provides:       R-cran-methods
101 Provides:       R-cran-splines
102 Provides:       R-cran-stats
103 Provides:       R-cran-stats4
104 Provides:       R-cran-tcltk
105 Provides:       R-cran-tools
106 Provides:       R-cran-utils
107
108 %description base
109 R is a language and run-time environment for carrying out interactive
110 statistical data analysis. It is not entirely dissimilar to the S
111 language developed at AT&T Bell Laboratories (and now Lucent
112 Technologies). Indeed, S users will find the environment quite
113 familiar and a good deal of S software will run without change under
114 R.
115
116 %description base -l pl.UTF-8
117 R jest językiem i środowiskiem uruchomieniowym do interaktywnej
118 analizy danych statystycznych. R nie jest całkowicie zgodny z językiem
119 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
120 mimo to użytkownicy S zauważą zbliżone środowisko, a duża część
121 oprogramowania w S będzie działała bez zmian w R.
122
123 %package recommended
124 Summary:        Recommended contributed packages for the R language
125 Summary(pl.UTF-8):      Zalecane dodatkowe pakiety do języka R
126 License:        GPL, free or free for non-commercial use
127 Group:          Development/Languages
128 URL:            http://www.ci.tuwien.ac.at/R/
129 Requires(post,postun):  R-base = %{version}-%{release}
130 Requires(post,postun):  perl-base
131 Requires(post,postun):  textutils
132 Requires:       R-base = %{version}-%{release}
133 Provides:       R-cran-KernSmooth = %{KernSmooth_version}
134 Provides:       R-cran-MASS = %{VR_version}
135 Provides:       R-cran-VR = %{VR_version}
136 Provides:       R-cran-boot = %{boot_version}
137 Provides:       R-cran-class = %{VR_version}
138 Provides:       R-cran-cluster = %{cluster_version}
139 Provides:       R-cran-foreign = %{foreign_version}
140 Provides:       R-cran-lattice = %{lattice_version}
141 Provides:       R-cran-mgcv = %{mgcv_version}
142 Provides:       R-cran-nlme = %{nlme_version}
143 Provides:       R-cran-nnet = %{VR_version}
144 Provides:       R-cran-rpart = %{rpart_version}
145 Provides:       R-cran-spatial = %{VR_version}
146 Provides:       R-cran-survival = %{survival_version}
147 Obsoletes:      R-contrib
148 Obsoletes:      R-cran-KernSmooth
149 Obsoletes:      R-cran-MASS
150 Obsoletes:      R-cran-VR
151 Obsoletes:      R-cran-boot
152 Obsoletes:      R-cran-class
153 Obsoletes:      R-cran-cluster
154 Obsoletes:      R-cran-foreign
155 Obsoletes:      R-cran-lattice
156 Obsoletes:      R-cran-mgcv
157 Obsoletes:      R-cran-nlme
158 Obsoletes:      R-cran-nnet
159 Obsoletes:      R-cran-rpart
160 Obsoletes:      R-cran-spatial
161 Obsoletes:      R-cran-survival
162
163 %description recommended
164 Packages which extend the capabilities of the R base distribution and
165 are distributed on the Comprehensive R Archive Network (CRAN).
166
167 %description recommended -l pl.UTF-8
168 Pakiety rozszerzające możliwości podstawowej dystrybucji języka R,
169 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
170
171 %prep
172 %setup -q
173
174 %build
175 %configure \
176         --enable-R-shlib \
177         --enable-linux-lfs \
178         --with-system-zlib \
179         --with-system-bzlib \
180         --with-system-pcre \
181         --with-libpng \
182         --with-jpeglib \
183         --with-blas \
184         --with-lapack \
185         --with-readline \
186         --with%{!?with_tcl:out}-tcltk \
187         --with-cairo \
188         --with-libpng \
189         --with-jpeglib \
190         --with-system-zlib \
191         --with-system-bzlib \
192         --with-system-pcre \
193         --with-iconv \
194         --with-ICU \
195         --with-x \
196         --with-recommended-packages
197
198 %{__make}
199 %if %{with tests}
200 %{__make} check
201 %endif
202 %{__make} docs help html info
203
204 %install
205 rm -rf $RPM_BUILD_ROOT
206 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
207 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
208
209 %{__make} install \
210         DESTDIR=$RPM_BUILD_ROOT
211
212 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
213
214 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
215 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
216 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
217 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
218 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
219 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
220 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
221
222 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
223 for f in * ; do
224   ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
225 done)
226 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
227 for f in * ; do
228   ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
229 done)
230
231 rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/{Text,R}
232 rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/{File,Text}
233 mv    $RPM_BUILD_ROOT%{_libdir}/R/share/perl/R $RPM_BUILD_ROOT%{perl_vendorlib}
234
235 %clean
236 rm -rf $RPM_BUILD_ROOT
237
238 %post
239 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
240  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
241 /sbin/ldconfig
242
243 %postun -p /sbin/ldconfig
244
245 %files base
246 %defattr(644,root,root,755)
247 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
248
249 %{_mandir}/man1/R.1*
250 %{_mandir}/man1/Rscript*
251 %attr(755,root,root) %{_bindir}/R
252 %attr(755,root,root) %{_bindir}/Rscript
253 %dir %{_libdir}/R
254 %attr(755,root,root) %{_libdir}/R/bin
255 %attr(755,root,root) %{_libdir}/libR*.so
256 %{_libdir}/R/etc
257 %{_libdir}/R/include
258 %{_includedir}/R
259 %{_libdir}/R/share
260 %{_libdir}/R/COPYING
261 %{_libdir}/R/NEWS
262 %{_libdir}/R/SVN-REVISION
263 %dir %{_libdir}/R/library
264 %{_libdir}/%{name}/library/R.css
265 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
266 %dir %{_libdir}/R/doc
267 %{_libdir}/R/doc/[KRm]*
268 %dir %{_libdir}/R/doc/html
269 %{_libdir}/R/doc/html/*.css
270 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
271 %{_libdir}/R/doc/html/packages-head*.html
272 %{_libdir}/R/doc/html/*.jpg
273 %dir %{_libdir}/R/doc/html/search
274 %{_libdir}/R/doc/html/search/[A-Z]*
275 %ghost %{_libdir}/R/doc/html/search/index.txt
276 %ghost %{_libdir}/R/doc/html/packages.html
277 %{_desktopdir}/*.desktop
278
279 %{perl_vendorlib}/R
280
281 %attr(755,root,root) %{_libdir}/%{name}/modules
282
283 %{_libdir}/%{name}/library/KernSmooth
284 %{_libdir}/%{name}/library/MASS
285 %{_libdir}/%{name}/library/base
286 %{_libdir}/%{name}/library/boot
287 %{_libdir}/%{name}/library/class
288 %{_libdir}/%{name}/library/cluster
289 %{_libdir}/%{name}/library/codetools
290 %{_libdir}/%{name}/library/datasets
291 %{_libdir}/%{name}/library/foreign
292 %{_libdir}/%{name}/library/grDevices
293 %{_libdir}/%{name}/library/graphics
294 %{_libdir}/%{name}/library/grid
295 %{_libdir}/%{name}/library/lattice
296 %{_libdir}/%{name}/library/methods
297 %{_libdir}/%{name}/library/mgcv
298 %{_libdir}/%{name}/library/nlme
299 %{_libdir}/%{name}/library/nnet
300 %{_libdir}/%{name}/library/rcompgen
301 %{_libdir}/%{name}/library/rpart
302 %{_libdir}/%{name}/library/spatial
303 %{_libdir}/%{name}/library/survival
304 %{_libdir}/%{name}/library/splines
305 %{_libdir}/%{name}/library/stats
306 %{_libdir}/%{name}/library/stats4
307 %{_libdir}/%{name}/library/tcltk
308 %{_libdir}/%{name}/library/tools
309 %{_libdir}/%{name}/library/utils
310
311 %{_pkgconfigdir}/*.pc
312
313 %files recommended
314 %defattr(644,root,root,755)
This page took 0.077327 seconds and 3 git commands to generate.