]> git.pld-linux.org Git - packages/ParaView.git/blob - ParaView.spec
- merged useless packages
[packages/ParaView.git] / ParaView.spec
1 Summary:        Parallel visualization application
2 Name:           ParaView
3 Version:        3.12.0
4 Release:        0.2
5 License:        BSD
6 Group:          Applications/Engineering
7 URL:            http://www.paraview.org/
8 Source0:        http://www.paraview.org/files/v3.12/%{name}-%{version}.tar.gz
9 # Source0-md5:  8feabc6261e2060648eaac593d85b1de
10 Source1:        %{name}_22x22.png
11 Source2:        %{name}.xml
12 Patch0:         %{name}-3.8.0-include.patch
13 Patch1:         %{name}-3.12.0-boost-1.48.0-bfs.patch
14 Patch2:         %{name}-gcc47.patch
15 Patch3:         %{name}-3.2.2-hdf5.patch
16 BuildRequires:  Mesa-libOSMesa-devel
17 BuildRequires:  QtDesigner-devel
18 BuildRequires:  QtHelp-devel
19 BuildRequires:  QtSql-devel
20 BuildRequires:  QtSql-sqlite
21 BuildRequires:  QtUiTools-devel
22 BuildRequires:  QtWebKit-devel
23 BuildRequires:  boost-devel
24 BuildRequires:  cmake
25 BuildRequires:  desktop-file-utils
26 BuildRequires:  doxygen
27 BuildRequires:  expat-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  gnuplot
30 BuildRequires:  graphviz
31 BuildRequires:  hdf5-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  libtheora-devel
35 BuildRequires:  libtiff-devel
36 BuildRequires:  openssl-devel
37 BuildRequires:  python-devel
38 BuildRequires:  qt4-build
39 BuildRequires:  readline-devel
40 BuildRequires:  tk-devel
41 BuildRequires:  wget
42 BuildRequires:  zlib-devel
43 Requires(post): desktop-file-utils
44 Requires(postun):       desktop-file-utils
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         skip_post_check_so      lib.*Python.*\.so.*
48
49 %description
50 ParaView is an application designed with the need to visualize large
51 data sets in mind. The goals of the ParaView project include the
52 following:
53
54     - Develop an open-source, multi-platform visualization application.
55     - Support distributed computation models to process large data sets.
56     - Create an open, flexible, and intuitive user interface.
57     - Develop an extensible architecture based on open standards.
58
59 ParaView runs on distributed and shared memory parallel as well as
60 single processor systems and has been successfully tested on Windows,
61 Linux and various Unix workstations and clusters. Under the hood,
62 ParaView uses the Visualization Toolkit as the data processing and
63 rendering engine and has a user interface written using a unique blend
64 of Tcl/Tk and C++.
65
66 NOTE: The version in this package has NOT been compiled with MPI
67 support.
68
69 %package        devel
70 Summary:        Development files for %{name}
71 Group:          Development/Libraries
72 Requires:       %{name}%{?_isa} = %{version}-%{release}
73
74 %description    devel
75 The %{name}-devel package contains libraries and header files for
76 developing applications that use %{name}.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 # We don't have boot 1.48 yet
82 #%patch1 -p1
83 %patch2 -p1
84 %patch3 -p1
85 #Remove included hdf5 just to be sure
86 rm -r VTK/Utilities/vtkhdf5
87
88 %build
89 mkdir build
90 cd build
91 %cmake .. \
92         -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
93         -DPV_INSTALL_LIB_DIR:PATH=%{_lib}/paraview \
94         -DTCL_LIBRARY:PATH=tcl \
95         -DTK_LIBRARY:PATH=tk \
96         -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
97         -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
98         -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
99         -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
100         -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
101         -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
102         -DPARAVIEW_INSTALL_DEVELOPMENT:BOOL=ON \
103         -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
104         -DVTK_USE_BOOST:BOOL=ON \
105         -DVTK_USE_INFOVIS:BOOL=OFF \
106         -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
107         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
108         -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
109         -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
110         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
111         -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
112         -DVTK_USE_SYSTEM_PNG:BOOL=ON \
113         -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
114         -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
115         -DXDMF_WRAP_PYTHON:BOOL=ON \
116         -DBUILD_DOCUMENTATION:BOOL=ON \
117         -DBUILD_EXAMPLES:BOOL=ON
118
119 %{__make} VERBOSE=1
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/mime/packages}
124
125 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
126 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/mime/packages
127
128 cd build
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 #Create desktop file
133 cat > $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop <<EOF
134 [Desktop Entry]
135 Encoding=UTF-8
136 Name=ParaView Viewer
137 GenericName=Data Viewer
138 Comment=ParaView allows viewing of large data sets
139 Type=Application
140 Terminal=false
141 Icon=ParaView_22x22
142 MimeType=application/x-paraview;
143 Categories=Application;Graphics;
144 Exec=paraview
145 EOF
146
147 # Install vtk*Python.so by hand for now
148 cp -p bin/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
149 mv $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
150
151 # Cleanup vtk binaries
152 rm $RPM_BUILD_ROOT%{_bindir}/vtk*
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 /sbin/ldconfig
159 %update_desktop_database
160 %update_mime_database
161
162 %postun
163 /sbin/ldconfig
164 %update_desktop_database
165 %update_mime_database
166
167 %files
168 %defattr(644,root,root,755)
169 %doc License_v1.2.txt
170 %attr(755,root,root) %{_bindir}/paraview
171 %attr(755,root,root) %{_bindir}/pvbatch
172 %attr(755,root,root) %{_bindir}/pvblot
173 %attr(755,root,root) %{_bindir}/pvdataserver
174 %attr(755,root,root) %{_bindir}/pvpython
175 %attr(755,root,root) %{_bindir}/pvrenderserver
176 %attr(755,root,root) %{_bindir}/pvserver
177 %attr(755,root,root) %{_bindir}/smTestDriver
178 %dir %{_libdir}/paraview/
179 %attr(755,root,root) %{_libdir}/paraview/paraview
180 %attr(755,root,root) %{_libdir}/paraview/pvbatch
181 %attr(755,root,root) %{_libdir}/paraview/pvdataserver
182 %attr(755,root,root) %{_libdir}/paraview/pvpython
183 %attr(755,root,root) %{_libdir}/paraview/pvrenderserver
184 %attr(755,root,root) %{_libdir}/paraview/pvserver
185 %attr(755,root,root) %{_libdir}/paraview/smTestDriver
186 %attr(755,root,root) %{_libdir}/paraview/lib*.so*
187 %{_libdir}/paraview/CMake
188 %{_libdir}/paraview/*.cmake
189 %{_libdir}/paraview/doc
190 %{_libdir}/paraview/*.py
191 %{_libdir}/paraview/testing
192 %{_libdir}/paraview/.plugins
193 %{_libdir}/paraview/SESAMEConversions.xml
194 %{_libdir}/paraview/hints
195 %{_libdir}/paraview/ParaViewCore
196 %dir %{_libdir}/paraview/site-packages
197 %dir %{_libdir}/paraview/site-packages/paraview
198 %{_libdir}/paraview/site-packages/paraview/pv_compile_complete
199 %{_libdir}/paraview/site-packages/paraview/*.py*
200 %attr(755,root,root) %{_libdir}/paraview/site-packages/paraview/*.so
201 %{_libdir}/paraview/site-packages/paraview/demos
202 %{_libdir}/paraview/site-packages/paraview/vtk
203 %{_desktopdir}/ParaView.desktop
204 %{_pixmapsdir}/ParaView_22x22.png
205 %{_datadir}/mime/packages/ParaView.xml
206 %{_datadir}/doc/paraview-3.12/paraview.qch
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/kwProcessXML
211 %{_includedir}/paraview/
This page took 0.353026 seconds and 4 git commands to generate.