]> git.pld-linux.org Git - packages/ParaView.git/blob - ParaView.spec
- updated to 4.0.1
[packages/ParaView.git] / ParaView.spec
1 Summary:        Parallel visualization application
2 Name:           ParaView
3 Version:        4.0.1
4 Release:        0.1
5 License:        BSD
6 Group:          Applications/Engineering
7 URL:            http://www.paraview.org/
8 Source0:        http://www.paraview.org/files/v4.0/%{name}-v%{version}-source.tgz
9 # Source0-md5:  6a300744eaf32676a3a7e1b42eb642c7
10 Source1:        %{name}_22x22.png
11 Source2:        %{name}.xml
12 Patch0:         %{name}-vtk-use-system-libs.patch
13 Patch1:         %{name}-install.patch
14 Patch2:         %{name}-system-Protobuf.patch
15 Patch3:         %{name}-system-netcdf.patch
16 Patch4:         disable-broken-tests.patch
17 BuildRequires:  Mesa-libOSMesa-devel
18 BuildRequires:  QtDesigner-devel
19 BuildRequires:  QtHelp-devel
20 BuildRequires:  QtSql-devel
21 BuildRequires:  QtSql-sqlite
22 BuildRequires:  QtUiTools-devel
23 BuildRequires:  QtXmlPatterns-devel
24 BuildRequires:  QtWebKit-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  cmake
27 BuildRequires:  desktop-file-utils
28 BuildRequires:  doxygen
29 BuildRequires:  expat-devel
30 BuildRequires:  freetype-devel
31 BuildRequires:  gnuplot
32 BuildRequires:  graphviz
33 BuildRequires:  hdf5-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libtheora-devel
37 BuildRequires:  libtiff-devel
38 BuildRequires:  netcdf-devel
39 BuildRequires:  netcdf-cxx-devel
40 BuildRequires:  openssl-devel
41 BuildRequires:  protobuf-devel
42 BuildRequires:  python-devel
43 BuildRequires:  qt4-build
44 BuildRequires:  readline-devel
45 BuildRequires:  tk-devel
46 BuildRequires:  wget
47 BuildRequires:  zlib-devel
48 Requires(post): desktop-file-utils
49 Requires(postun):       desktop-file-utils
50 %requires_eq_to hdf5 hdf5-devel
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         skip_post_check_so      lib.*Python.*\.so.*
54
55 %description
56 ParaView is an application designed with the need to visualize large
57 data sets in mind. The goals of the ParaView project include the
58 following:
59
60     - Develop an open-source, multi-platform visualization application.
61     - Support distributed computation models to process large data sets.
62     - Create an open, flexible, and intuitive user interface.
63     - Develop an extensible architecture based on open standards.
64
65 ParaView runs on distributed and shared memory parallel as well as
66 single processor systems and has been successfully tested on Windows,
67 Linux and various Unix workstations and clusters. Under the hood,
68 ParaView uses the Visualization Toolkit as the data processing and
69 rendering engine and has a user interface written using a unique blend
70 of Tcl/Tk and C++.
71
72 NOTE: The version in this package has NOT been compiled with MPI
73 support.
74
75 %package        devel
76 Summary:        Development files for %{name}
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description    devel
81 The %{name}-devel package contains libraries and header files for
82 developing applications that use %{name}.
83
84 %prep
85 %setup -q -n %{name}-v%{version}-source
86 %patch0 -p0
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p0
90 %patch4 -p1
91 #Remove included thirdparty sources just to be sure
92 for x in protobuf ; do
93         rm -r ThirdParty/$x/vtk$x
94 done
95 for x in expat freetype gl2ps hdf5 jpeg libxml2 netcdf oggtheora png sqlite tiff zlib ; do
96         rm -r VTK/ThirdParty/$x/vtk$x
97 done
98
99 %{__rm} -r ParaViewCore/ServerImplementation/Default/Testing
100
101 %build
102 rm -rf build
103 mkdir build
104 cd build
105 %cmake .. \
106         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
107         -DCMAKE_CXX_COMPILER:FILEPATH=%{__cxx} \
108         -DCMAKE_C_COMPILER:FILEPATH=%{__cc} \
109         -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
110         -DPV_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
111         -DTCL_LIBRARY:PATH=tcl \
112         -DTK_LIBRARY:PATH=tk \
113         -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
114         -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
115         -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
116         -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
117         -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
118         -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
119         -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
120         -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/paraview \
121         -DVTK_INSTALL_INCLUDE_DIR:PATH=include/paraview \
122         -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
123         -DVTK_INSTALL_PACKAGE_DIR=share/cmake/paraview \
124         -DVTK_USE_BOOST:BOOL=ON \
125         -DVTK_USE_INFOVIS:BOOL=OFF \
126         -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
127         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
128         -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
129         -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
130         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
131         -DVTK_USE_SYSTEM_HDF5=ON \
132         -DHDF5_HL_LIBRARY:FILEPATH=%{_libdir}/libhdf5_hl.so \
133         -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
134         -DVTK_USE_SYSTEM_LIBPROJ4=OFF \
135         -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
136         -DVTK_USE_SYSTEM_LIBRARIES=ON \
137         -DVTK_USE_SYSTEM_PNG:BOOL=ON \
138         -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
139         -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
140         -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
141         -DVTK_USE_INFOVIS:BOOL=OFF \
142         -DVTK_USE_SYSTEM_ICET=OFF \
143         -DVTK_USE_SYSTEM_NETCDF=ON \
144         -DVTK_USE_SYSTEM_QTTESTING=OFF \
145         -DVTK_USE_SYSTEM_XDMF2=OFF \
146         -DXDMF_WRAP_PYTHON:BOOL=ON \
147         -DBUILD_DOCUMENTATION:BOOL=ON \
148         -DBUILD_EXAMPLES:BOOL=ON
149
150 # -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
151
152 %{__make} VERBOSE=1
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/mime/packages}
157
158 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
159 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/mime/packages
160
161 cd build
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 #Create desktop file
166 cat > $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop <<EOF
167 [Desktop Entry]
168 Encoding=UTF-8
169 Name=ParaView Viewer
170 GenericName=Data Viewer
171 Comment=ParaView allows viewing of large data sets
172 Type=Application
173 Terminal=false
174 Icon=ParaView_22x22
175 MimeType=application/x-paraview;
176 Categories=Application;Graphics;
177 Exec=paraview
178 EOF
179
180 # Move python files by hand for now
181 %{__mv} $RPM_BUILD_ROOT%{_bindir}/Python/vtk $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/
182 %{__rm} -r $RPM_BUILD_ROOT%{_bindir}/Python
183
184 # Install vtk*Python.so by hand for now
185 %{__mv} $RPM_BUILD_ROOT%{_libdir}/paraview/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
186 %{__mv} $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
187
188 # Cleanup vtk binaries
189 rm $RPM_BUILD_ROOT%{_bindir}/vtk*
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post
195 /sbin/ldconfig
196 %update_desktop_database
197 %update_mime_database
198
199 %postun
200 /sbin/ldconfig
201 %update_desktop_database
202 %update_mime_database
203
204 %files
205 %defattr(644,root,root,755)
206 %doc License_v1.2.txt
207 %attr(755,root,root) %{_bindir}/paraview
208 %attr(755,root,root) %{_bindir}/pvbatch
209 %attr(755,root,root) %{_bindir}/pvblot
210 %attr(755,root,root) %{_bindir}/pvdataserver
211 %attr(755,root,root) %{_bindir}/pvpython
212 %attr(755,root,root) %{_bindir}/pvrenderserver
213 %attr(755,root,root) %{_bindir}/pvserver
214 %attr(755,root,root) %{_bindir}/smTestDriver
215 %dir %{_libdir}/paraview/
216 %attr(755,root,root) %{_libdir}/paraview/paraview
217 %attr(755,root,root) %{_libdir}/paraview/pvbatch
218 %attr(755,root,root) %{_libdir}/paraview/pvdataserver
219 %attr(755,root,root) %{_libdir}/paraview/pvpython
220 %attr(755,root,root) %{_libdir}/paraview/pvrenderserver
221 %attr(755,root,root) %{_libdir}/paraview/pvserver
222 %attr(755,root,root) %{_libdir}/paraview/smTestDriver
223 %attr(755,root,root) %{_libdir}/paraview/lib*.so*
224 %{_libdir}/paraview/CMake
225 %{_libdir}/paraview/*.cmake
226 %{_libdir}/paraview/doc
227 %{_libdir}/paraview/*.py
228 %{_libdir}/paraview/testing
229 %{_libdir}/paraview/.plugins
230 %{_libdir}/paraview/hints
231 %{_libdir}/paraview/ParaViewCore
232 %dir %{_libdir}/paraview/site-packages
233 %dir %{_libdir}/paraview/site-packages/paraview
234 %{_libdir}/paraview/site-packages/paraview/pv_compile_complete
235 %{_libdir}/paraview/site-packages/paraview/*.py*
236 %attr(755,root,root) %{_libdir}/paraview/site-packages/paraview/*.so
237 %{_libdir}/paraview/site-packages/paraview/demos
238 %{_libdir}/paraview/site-packages/paraview/vtk
239 %dir %{_libdir}/paraview/site-packages/vtk
240 %{_libdir}/paraview/site-packages/vtk/*.py*
241 %dir %{_libdir}/paraview/site-packages/vtk/gtk
242 %{_libdir}/paraview/site-packages/vtk/gtk/*.py*
243 %dir %{_libdir}/paraview/site-packages/vtk/qt
244 %{_libdir}/paraview/site-packages/vtk/qt/*.py*
245 %dir %{_libdir}/paraview/site-packages/vtk/qt4
246 %{_libdir}/paraview/site-packages/vtk/qt4/*.py*
247 %dir %{_libdir}/paraview/site-packages/vtk/test
248 %{_libdir}/paraview/site-packages/vtk/test/*.py*
249 %dir %{_libdir}/paraview/site-packages/vtk/tk
250 %{_libdir}/paraview/site-packages/vtk/tk/*.py*
251 %dir %{_libdir}/paraview/site-packages/vtk/util
252 %{_libdir}/paraview/site-packages/vtk/util/*.py*
253 %dir %{_libdir}/paraview/site-packages/vtk/wx
254 %{_libdir}/paraview/site-packages/vtk/wx/*.py*
255 %{_desktopdir}/ParaView.desktop
256 %{_pixmapsdir}/ParaView_22x22.png
257 %{_datadir}/mime/packages/ParaView.xml
258 %dir %{_datadir}/doc/paraview-3.14
259 %{_datadir}/doc/paraview-3.14/paraview.qch
260
261 %files devel
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_bindir}/kwProcessXML
264 %attr(755,root,root) %{_libdir}/paraview/kwProcessXML-real
265 %{_includedir}/paraview/
This page took 0.05641 seconds and 4 git commands to generate.