]> git.pld-linux.org Git - packages/ParaView.git/blob - ParaView.spec
- icon
[packages/ParaView.git] / ParaView.spec
1 Summary:        Parallel visualization application
2 Name:           ParaView
3 Version:        3.12.0
4 Release:        0.1
5 License:        BSD
6 Group:          Applications/Engineering
7 URL:            http://www.paraview.org/
8 Source0:        http://www.paraview.org/files/v3.12/%{name}-%{version}.tar.gz
9 # Source0-md5:  8feabc6261e2060648eaac593d85b1de
10 Source1:        %{name}_22x22.png
11 Source2:        %{name}.xml
12 Patch0:         %{name}-3.8.0-include.patch
13 Patch1:         %{name}-3.12.0-boost-1.48.0-bfs.patch
14 Patch2:         %{name}-gcc47.patch
15 Patch3:         %{name}-3.2.2-hdf5.patch
16 BuildRequires:  boost-devel
17 BuildRequires:  cmake
18 BuildRequires:  desktop-file-utils
19 BuildRequires:  doxygen
20 BuildRequires:  expat-devel
21 BuildRequires:  freetype-devel
22 BuildRequires:  gnuplot
23 BuildRequires:  graphviz
24 BuildRequires:  hdf5-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtheora-devel
28 BuildRequires:  libtiff-devel
29 BuildRequires:  Mesa-libOSMesa-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  python-devel
32 BuildRequires:  qt4-build
33 BuildRequires:  QtWebKit-devel
34 BuildRequires:  QtSql-devel
35 BuildRequires:  QtSql-sqlite
36 BuildRequires:  QtUiTools-devel
37 BuildRequires:  QtHelp-devel
38 BuildRequires:  QtDesigner-devel
39 BuildRequires:  readline-devel
40 BuildRequires:  tk-devel
41 BuildRequires:  wget
42 BuildRequires:  zlib-devel
43 Requires:       %{name}-data = %{version}-%{release}
44 Requires:       %{name}-doc = %{version}-%{release}
45 Requires(post): desktop-file-utils
46 Requires(postun):       desktop-file-utils
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 ParaView is an application designed with the need to visualize large
51 data sets in mind. The goals of the ParaView project include the
52 following:
53
54     - Develop an open-source, multi-platform visualization application.
55     - Support distributed computation models to process large data sets.
56     - Create an open, flexible, and intuitive user interface.
57     - Develop an extensible architecture based on open standards.
58
59 ParaView runs on distributed and shared memory parallel as well as
60 single processor systems and has been successfully tested on Windows,
61 Linux and various Unix workstations and clusters. Under the hood,
62 ParaView uses the Visualization Toolkit as the data processing and
63 rendering engine and has a user interface written using a unique blend
64 of Tcl/Tk and C++.
65
66 NOTE: The version in this package has NOT been compiled with MPI
67 support.
68
69 %package        data
70 Summary:        Data files for ParaView
71 Group:          Applications/Engineering
72 Requires:       %{name} = %{version}-%{release}
73 BuildArch:      noarch
74
75 %description    data
76 Data files for ParaView.
77
78 %package        devel
79 Summary:        Development files for %{name}
80 Group:          Development/Libraries
81 Requires:       %{name}%{?_isa} = %{version}-%{release}
82
83 %description    devel
84 The %{name}-devel package contains libraries and header files for
85 developing applications that use %{name}.
86
87 %package        doc
88 Summary:        Documentation files for ParaView
89 Group:          Applications/Engineering
90 Requires:       %{name} = %{version}-%{release}
91 BuildArch:      noarch
92
93 %description    doc
94 Documentation files for ParaView.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102 #Remove included hdf5 just to be sure
103 rm -r VTK/Utilities/vtkhdf5
104
105 %build
106 mkdir build
107 cd build
108 %cmake .. \
109         -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
110         -DPV_INSTALL_LIB_DIR:PATH=%{_lib}/paraview \
111         -DTCL_LIBRARY:PATH=tcl \
112         -DTK_LIBRARY:PATH=tk \
113         -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
114         -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
115         -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
116         -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
117         -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
118         -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
119         -DPARAVIEW_INSTALL_DEVELOPMENT:BOOL=ON \
120         -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
121         -DVTK_USE_BOOST:BOOL=ON \
122         -DVTK_USE_INFOVIS:BOOL=OFF \
123         -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
124         -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
125         -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
126         -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
127         -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
128         -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
129         -DVTK_USE_SYSTEM_PNG:BOOL=ON \
130         -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
131         -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
132         -DXDMF_WRAP_PYTHON:BOOL=ON \
133         -DBUILD_DOCUMENTATION:BOOL=ON \
134         -DBUILD_EXAMPLES:BOOL=ON
135
136 %{__make} VERBOSE=1
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT%{_desktopdir}
141 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
142 install -d $RPM_BUILD_ROOT%{_datadir}/mime/packages
143
144 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}
145 install %SOURCE2 $RPM_BUILD_ROOT%{_datadir}/mime/packages
146
147 cd build
148 %{__make} install DESTDIR=$RPM_BUILD_ROOT
149
150 #Create desktop file
151 cat > $RPM_BUILD_ROOT%{_desktopdir}/paraview.desktop <<EOF
152 [Desktop Entry]
153 Encoding=UTF-8
154 Name=ParaView Viewer
155 GenericName=Data Viewer
156 Comment=ParaView allows viewing of large data sets
157 Type=Application
158 Terminal=false
159 Icon=paraview_22x22
160 MimeType=application/x-paraview;
161 Categories=Application;Graphics;
162 Exec=paraview
163 EOF
164
165 #Install vtk*Python.so by hand for now
166 cp -p bin/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
167 mv $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
168
169 #Cleanup vtk binaries
170 rm $RPM_BUILD_ROOT%{_bindir}/vtk*
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post
176 /sbin/ldconfig
177 %update_desktop_database
178
179 %postun
180 /sbin/ldconfig
181 %update_desktop_database
182
183 %post data
184 %update_mime_database
185
186 %postun data
187 %update_mime_database
188
189 %files
190 %defattr(644,root,root,755)
191 %doc License_v1.2.txt
192 %attr(755,root,root) %{_bindir}/paraview
193 %attr(755,root,root) %{_bindir}/pvbatch
194 %attr(755,root,root) %{_bindir}/pvblot
195 %attr(755,root,root) %{_bindir}/pvdataserver
196 %attr(755,root,root) %{_bindir}/pvpython
197 %attr(755,root,root) %{_bindir}/pvrenderserver
198 %attr(755,root,root) %{_bindir}/pvserver
199 %attr(755,root,root) %{_bindir}/smTestDriver
200 %{_libdir}/paraview/
201
202 %files data
203 %defattr(644,root,root,755)
204 %{_desktopdir}/fedora-paraview.desktop
205 %{_pixmapsdir}/paraview_22x22.png
206 %{_datadir}/mime/packages/paraview.xml
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/kwProcessXML
211 %{_includedir}/paraview/
This page took 0.098755 seconds and 3 git commands to generate.