]> git.pld-linux.org Git - packages/NuSMV.git/blob - NuSMV.spec
- release 4 (by relup.sh)
[packages/NuSMV.git] / NuSMV.spec
1 #
2 # Conditional build:
3 %bcond_with     zchaff  # enable zChaff SAT Solver (zChaff is for non-commercial purposes only)
4 #
5 %define zchaff_ver      2008.10.12
6 %define minisat_ver     070721
7 #
8 Summary:        New Symbolic Model Verifier
9 Summary(pl.UTF-8):      Nowy weryfikator modeli symbolicznych
10 Name:           NuSMV
11 Version:        2.5.4
12 Release:        4
13 License:        LGPL
14 Group:          Applications
15 Source0:        http://nusmv.irst.itc.it/distrib/%{name}-%{version}.tar.gz
16 # Source0-md5:  4d8ae6136fbd916d875cd48f82d5f327
17 Source1:        http://minisat.se/downloads/minisat2-%{minisat_ver}.zip
18 # Source1-md5:  fb12db9a13f86a2133758abfba239546
19 Source2:        http://www.princeton.edu/~chaff/zchaff/zchaff.%{zchaff_ver}.zip
20 # Source2-md5:  7398b3e984a5046755cb3ef6b0e44d2e
21 Patch0:         %{name}-build.patch
22 Patch1:         %{name}-solvers.patch
23 Patch2:         format-security.patch
24 URL:            http://nusmv.irst.itc.it/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  expat-devel
28 BuildRequires:  ghostscript
29 BuildRequires:  lynx
30 # alternative for lynx
31 #BuildRequires: links
32 BuildRequires:  perl-base
33 BuildRequires:  readline-devel
34 BuildRequires:  texlive-dvips
35 BuildRequires:  texlive-latex
36 BuildRequires:  texlive-latex-bibtex
37 BuildRequires:  texlive-latex-carlisle
38 BuildRequires:  texlive-latex-extend
39 BuildRequires:  texlive-latex-psnfss
40 BuildRequires:  texlive-makeindex
41 BuildRequires:  unzip
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # a lot of inter-library deps confusing install_post_check_so
45 %define         no_install_post_check_so        1
46
47 %description
48 NuSMV is a reimplementation and extension of SMV, the first model
49 checker based on BDDs. NuSMV has been designed to be an open
50 architecture for model checking, which can be reliably used for the
51 verification of industrial designs, as a core for custom verification
52 tools, as a testbed for formal verification techniques, and applied
53 to other research areas.
54
55 NuSMV2, combines BDD-based model checking component that exploits the
56 CUDD library developed by Fabio Somenzi at Colorado University and
57 SAT-based model checking component that includes an RBC-based Bounded
58 Model Checker, connected to the SIM SAT library developed by the
59 University of Genova.
60
61 %description -l pl.UTF-8
62 NuSVM to reimplementacja i rozszerzenie SMV - pierwszego weryfikatora
63 modeli opartego na BDD. NuSMV został zaprojektowany w otwartej
64 architekturze sprawdzania modeli, przez co może być niezawodnie
65 używany do weryfikacji projektów przemysłowych, jako podstawa własnych
66 narzędzi weryfikujących, jako poligon dla technik weryfikacji
67 formalnej oraz stosowany w innych obszarach badań.
68
69 NuSMV2 łączy komponent sprawdzający modele oparty na BDD,
70 wykorzystujący bibliotekę CUDD stworzoną przez Fabio Somenziniego w
71 Colorado University i komponent sprawdzający modele oparty na SAT
72 zawierający weryfikator modeli ograniczonych oparty na RBC, połączony
73 z biblioteką SIM SAT stworzoną przez University of Genova.
74
75 %package devel
76 Summary:        Header files for NuSMV
77 Summary(pl.UTF-8):      Pliki nagłówkowe NuSMV
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description devel
82 This is the package containing the header files for NuSMV.
83
84 %description devel -l pl.UTF-8
85 Ten pakiet zawiera pliki nagłówkowe NuSMV.
86
87 %package static
88 Summary:        Static NuSMV library
89 Summary(pl.UTF-8):      Statyczna biblioteka NuSMV
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static NuSMV library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka NuSMV.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 install %{SOURCE1} MiniSat/
104 install %{SOURCE2} zchaff/
105
106 %patch1 -p1
107 %patch2 -p1
108
109 %build
110 ICFLAGS="%{rpmcflags} -fPIC"
111 export ICFLAGS
112
113 cd MiniSat/
114 OPTFLAGS="%{rpmcxxflags} -fPIC" COPTIMIZE="%{rpmcxxflags} -fPIC" ./build.sh
115 %if %{with zchaff}
116 cd ../zchaff
117 OPTFLAGS="%{rpmcxxflags} -fPIC" ./build.sh
118 %endif
119 cd ../cudd-*
120 %ifarch %{x8664}
121 cp -f Makefile Makefile_32bit
122 cp -f Makefile_64bit Makefile
123 %endif
124 %{__make}
125 cd ..
126
127 cd nusmv
128
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__automake}
133 %configure \
134         --enable-shared \
135         %{?with_zchaff:--enable-zchaff} \
136         --enable-minisat
137
138 %{__make}
139
140 %{__make} docs
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
145
146 %{__make} -j1 -C nusmv install \
147         INSTALL_DATA="cp -a" \
148         INSTALL_HEADER="install -p" \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 cp -a nusmv/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
152
153 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/nusmv/{doc,examples,LGPL*,NEWS,README*}
154 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/*.la
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc nusmv/{AUTHORS,ChangeLog,NEWS,README*}
165 %doc nusmv/doc/tutorial/tutorial.p*
166 %doc nusmv/doc/user-man/nusmv.p*
167 %doc nusmv/doc/html
168 %attr(755,root,root) %{_bindir}/*
169 %attr(755,root,root) %{_libdir}/lib*smv*.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/lib*smv*.so.0
171 %attr(755,root,root) %{_libdir}/librbcdag.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/librbcdag.so.0
173 %dir %{_datadir}/nusmv
174 %{_datadir}/nusmv/contrib
175 %{_datadir}/nusmv/help
176 %{_datadir}/nusmv/master.nusmvrc
177 %{_examplesdir}/%{name}-%{version}
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/lib*smv*.so
182 %attr(755,root,root) %{_libdir}/librbcdag.so
183 %{_includedir}/cudd*
184 %{_includedir}/nusmv
185 %{_pkgconfigdir}/*
186
187 %files static
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/lib*smv*.a
190 %attr(755,root,root) %{_libdir}/librbcdag.a
This page took 0.070216 seconds and 4 git commands to generate.