]> git.pld-linux.org Git - packages/NetworkManager.git/blob - NetworkManager.spec
- more BRs, fixed dbus version
[packages/NetworkManager.git] / NetworkManager.spec
1 # TODO:
2 # - add a working(!) pld backend...
3 # - many files are not packaged (including init.d)
4 #
5 Summary:        Network Manager for GNOME
6 Summary(pl):    Zarz±dca sieci dla GNOME
7 Name:           NetworkManager
8 Version:        0.6.2
9 Release:        0.1
10 License:        GPL v2
11 Group:          X11/Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/NetworkManager/0.6/%{name}-%{version}.tar.bz2
13 # Source0-md5:  1254609e7d6a8de72677d63908bb4bd8
14 Source1:        %{name}.init
15 Patch0:         %{name}-pld.patch
16 BuildRequires:  GConf2-devel >= 2.0
17 BuildRequires:  dbus-glib-devel >= 0.60
18 BuildRequires:  gtk+2-devel >= 2.0
19 BuildRequires:  gnome-keyring-devel
20 BuildRequires:  gnome-panel-devel >= 2.0
21 BuildRequires:  hal-devel >= 0.5.2
22 BuildRequires:  libgcrypt-devel
23 BuildRequires:  libglade2-devel >= 2.0
24 BuildRequires:  libiw-devel >= 28
25 BuildRequires:  libnl-devel >= 1.0
26 BuildRequires:  libnotify-devel >= 0.3.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.268
29 Requires(post): /sbin/ldconfig
30 Requires(post,preun):   /sbin/chkconfig
31 Requires:       dhcdbd
32 Requires:       rc-scripts
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Network Manager for GNOME.
37
38 %description -l pl
39 Zarz±dca sieci dla GNOME.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %build
46 autoreconf
47 %configure \
48         --with-distro=pld \
49         --with-dhcdbd=/usr/sbin/dhcdbd \
50         --with-wpa_supplicant=/usr/sbin/wpa_supplicant
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/NetworkManager
61
62 %find_lang %{name} --with-gnome --all-name
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 /sbin/ldconfig
69 %gconf_schema_install
70 /sbin/chkconfig --add NetworkManager
71 %service NetworkManager restart "NetworkManager daemon"
72
73 %preun
74 if [ "$1" = "0" ]; then
75         %service NetworkManager stop
76         /sbin/chkconfig --del NetworkManager
77 fi
78
79 %postun -p /sbin/ldconfig
80
81 %files -f %{name}.lang
82 %defattr(644,root,root,755)
83 %doc AUTHORS ChangeLog NEWS README TODO
84 %attr(755,root,root) %{_bindir}/*
85 %attr(755,root,root) %{_sbindir}/*
86 %attr(755,root,root) %{_datadir}/nm-applet
87 %attr(755,root,root) %{_datadir}/gnome-vpn-properties
88 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
89 %attr(755,root,root) %{_libdir}/nm-crash-logger
90 %attr(754,root,root) /etc/rc.d/init.d/NetworkManager
91 %dir %{_datadir}/%{name}
92 %{_datadir}/%{name}/gdb-cmd
93 %{_datadir}/gnome/autostart/*.desktop
94 %{_mandir}/man1/*
95 %{_sysconfdir}/dbus-1/system.d/*
96 %{_iconsdir}/*/*/apps/*.png
97
98 %if 0
99 # -devel?
100 %attr(755,root,root) %{_libdir}/libnm-util.so
101 %attr(755,root,root) %{_libdir}/libnm_glib.so
102 %{_libdir}/libnm-util.la
103 %{_libdir}/libnm_glib.la
104 %{_includedir}/NetworkManager
105 %{_pkgconfigdir}/NetworkManager.pc
106 %{_pkgconfigdir}/libnm-util.pc
107 %{_pkgconfigdir}/libnm_glib.pc
108
109 # -static?
110 %{_libdir}/libnm-util.a
111 %{_libdir}/libnm_glib.a
112 %endif
This page took 0.093545 seconds and 4 git commands to generate.