]> git.pld-linux.org Git - packages/Lunchbox.git/blob - Lunchbox.spec
boost rebuild
[packages/Lunchbox.git] / Lunchbox.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     mpi             # MPI support
5
6 Summary:        Lunchbox - C++ library for multi-threading programming
7 Summary(pl.UTF-8):      Lunchbox - biblioteka C++ do programowania wielowątkowego
8 Name:           Lunchbox
9 Version:        1.17.0
10 Release:        4
11 License:        LGPL v2.1
12 Group:          Libraries
13 #Source0Download: https://github.com/Eyescale/Lunchbox/releases
14 Source0:        https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  76bcd79003c9b9d58d5f772cfdd812c7
16 Patch2:         cxx.patch
17 URL:            http://pogl.wordpress.com/category/lunchbox/
18 BuildRequires:  Eyescale-CMake >= 2018.02
19 BuildRequires:  Servus-devel >= 1.5.0
20 BuildRequires:  avahi-devel
21 BuildRequires:  boost-devel >= 1.41.0
22 BuildRequires:  cmake >= 3.1
23 %{?with_apidocs:BuildRequires:  doxygen}
24 BuildRequires:  hwloc-devel >= 1.3
25 BuildRequires:  hwloc-devel < 2
26 BuildRequires:  libstdc++-devel
27 %{?with_mpi:BuildRequires:      mpi-devel}
28 BuildRequires:  pkgconfig
29 Requires:       Servus >= 1.5.0
30 Requires:       hwloc-libs >= 1.3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
35 formerly known as eq::base or co::base, the foundation for the
36 Equalizer parallel rendering framework and the Collage network
37 library. It is intended for all application developers creating
38 high-performance multi-threaded programs.
39
40 %description -l pl.UTF-8
41 Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
42 była znana jako eq::base lub co::base - podstawa szkieletu do
43 renderowania wielowątkowego Equalizer lub biblioteki sieciowej
44 Collage. Biblioteka jest przeznaczona dla wszystkich programistów
45 tworzących wysoko wydajne, wielowątkowe aplikacje.
46
47 %package devel
48 Summary:        Header files for Lunchbox library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lunchbox
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       Servus-devel >= 1.5.0
53 Requires:       boost-devel >= 1.41.0
54 Requires:       libstdc++-devel
55
56 %description devel
57 Header files for Lunchbox library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki Lunchbox.
61
62 %package apidocs
63 Summary:        Lunchbox API documentation
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki Lunchbox
65 Group:          Documentation
66 BuildArch:      noarch
67
68 %description apidocs
69 API documentation for Lunchbox library.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API biblioteki Lunchbox.
73
74 %prep
75 %setup -q
76
77 rmdir CMake/common
78 ln -s %{_datadir}/Eyescale-CMake CMake/common
79
80 %patch2 -p1
81
82 %build
83 install -d build
84 cd build
85 %cmake .. \
86         -DCOMMON_DISABLE_WERROR:BOOL=ON \
87         %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
88
89 %{__make}
90
91 %if %{with apidocs}
92 doxygen doc/Doxyfile
93 %endif
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
112 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
114 %dir %{_datadir}/Lunchbox
115 %{_datadir}/Lunchbox/benchmarks
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libLunchbox.so
120 %{_includedir}/lunchbox
121 %{_datadir}/Lunchbox/CMake
122
123 %if %{with apidocs}
124 %files apidocs
125 %defattr(644,root,root,755)
126 %doc build/doc/html/*
127 %endif
This page took 0.044907 seconds and 3 git commands to generate.