]> git.pld-linux.org Git - packages/Glide_VG.git/blob - Glide_VG.spec
- added usr/X11R6/include to CFLAGS
[packages/Glide_VG.git] / Glide_VG.spec
1 Summary:        Glide runtime for 3Dfx Voodoo Banshee and Voodoo3 boards
2 Name:           Glide_VG
3 Version:        2.46
4 Release:        4
5 Group:          Libraries
6 Copyright:      3DFX GLIDE Source Code General Public License
7 URL:            http://www.3dfx.com     
8 Source:         Glide2.46.tar.gz
9 Patch:          Glide_VG-asm.patch
10 Vendor:         3Dfx Interactive Inc.
11 Icon:           3dfx.gif
12 BuildRequires:  XFree86-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 This library allows the user to use a 3dfx Interactive Voodoo Graphics
17 card under Linux.
18
19 %package -n Glide2x_SDK
20 Summary:        Development libraries for Glide 2.x
21 Version:        2.1
22 Group:          Development/Libraries
23
24 %description -n Glide2x_SDK
25 This package includes the headers files, documentation, and test files
26 necessary for developing applications that use the 3Dfx Interactive
27 Voodoo Graphics, Voodoo Rush, or Voodoo2 card.
28
29 %prep
30 %setup -q -c
31 %patch -p1
32 chmod +x swlibs/include/make/ostype
33
34 %build
35 %{__make} -f makefile.unix CNODEBUG="$RPM_OPT_FLAGS -fomit-frame-pointer \
36         -funroll-loops -fexpensive-optimizations -ffast-math -I/usr/X11R6/include"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_includedir}/glide}
41 install -d $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/{tests,texus/{lib,cmd,examples}}
42
43 # Install the glibc 2.1 libraries normally
44 install -s sst1/lib/libglide2x.so $RPM_BUILD_ROOT%{_libdir}/libglide2x_VG.so
45 install -s swlibs/lib/libtexus.so $RPM_BUILD_ROOT%{_libdir}
46 ln -s libglide2x_VG.so $RPM_BUILD_ROOT%{_libdir}/libglide2x.so
47
48 # Install the executables
49 install -s swlibs/bin/texus $RPM_BUILD_ROOT%{_bindir}
50 install -s sst1/glide/tests/test00 $RPM_BUILD_ROOT%{_bindir}/test3Dfx
51
52 # Install the headers
53 install swlibs/include/3dfx.h $RPM_BUILD_ROOT%{_includedir}/glide
54 install sst1/include/glide.h $RPM_BUILD_ROOT%{_includedir}/glide
55 install sst1/include/glidesys.h $RPM_BUILD_ROOT%{_includedir}/glide
56 install sst1/include/glideutl.h $RPM_BUILD_ROOT%{_includedir}/glide
57 install sst1/include/sst1vid.h $RPM_BUILD_ROOT%{_includedir}/glide
58 install sst1/include/gump.h $RPM_BUILD_ROOT%{_includedir}/glide
59 install swlibs/include/linutil.h $RPM_BUILD_ROOT%{_includedir}/glide
60 install swlibs/include/texus.h $RPM_BUILD_ROOT%{_includedir}/glide
61
62 # Install the examples and their source
63 install sst1/glide/tests/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests/makefile
64 install sst1/glide/tests/*.3df $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
65 install sst1/glide/tests/test??.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
66 install sst1/glide/tests/tldata.inc $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
67 install sst1/glide/tests/tlib.[ch] $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/tests
68
69 # Install the texture tools source
70 install swlibs/texus/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/makefile
71 install swlibs/texus/lib/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/lib/makefile
72 install swlibs/texus/cmd/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/cmd/makefile
73 install swlibs/texus/examples/makefile.distrib $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/examples/makefile
74 install swlibs/texus/lib/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/lib
75 install swlibs/texus/lib/texusint.h $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/lib
76 install swlibs/texus/cmd/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/cmd
77 install swlibs/texus/examples/*.c $RPM_BUILD_ROOT%{_prefix}/src/examples/glide/texus/examples
78
79 gzip -9nf glide_license.txt
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc glide_license.txt.gz
90 %attr(755,root,root) %{_bindir}/texus
91 %attr(755,root,root) %{_bindir}/test3Dfx
92 %attr(755,root,root) %{_libdir}/libglide2x.so
93 %attr(755,root,root) %{_libdir}/libglide2x_VG.so
94 %attr(755,root,root) %{_libdir}/libtexus.so
95
96 %files -n Glide2x_SDK
97 %defattr(644,root,root,755)
98 %doc docs/*.pdf
99 %{_prefix}/src/examples/glide
100 %{_includedir}/glide
This page took 0.091755 seconds and 3 git commands to generate.