]> git.pld-linux.org Git - packages/ElectricFence.git/blob - ElectricFence.spec
- release 11,
[packages/ElectricFence.git] / ElectricFence.spec
1 Summary:        A debugger which detects memory allocation violations
2 Summary(de):    Debugger zum Erkennen von Speicherzugriffsverletzungen
3 Summary(es):    Electric Fence biblioteca de depuración de memoria en C
4 Summary(fr):    Bibliothèque C de débuggage mémoire Electric Fence
5 Summary(pl):    Biblioteka do wykrywania b³êdów alokacji pamiêci
6 Summary(pt_BR): Electric Fence biblioteca de depuração de memória em C
7 Summary(tr):    C için bellek hatasý ayýklama kitaplýðý
8 Summary(zh_CN): Ò»ÖÖµ÷ÊÔÆ÷ÓÃÓÚ¼ì²âÄÚ´æ·ÖÅä´íÎó
9 Name:           ElectricFence
10 Version:        2.2.2
11 Release:        11
12 License:        GPL
13 Group:          Development/Debuggers
14 Group(de):      Entwicklung/Debugger
15 Group(pl):      Programowanie/Odpluskwiacze
16 Source0:        ftp://ftp.perens.com/pub/ElectricFence/Beta/%{name}-%{version}.tar.gz
17 Patch0:         %{name}-longjmp.patch
18 Patch1:         %{name}-no_bash.spec
19 Patch2:         %{name}-va_arg.patch
20 Patch3:         %{name}-ac_am.patch
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25 Obsoletes:      libefence0
26
27 %description
28 If you know what malloc() violations are, you'll be interested in
29 ElectricFence. ElectricFence is a tool which can be used for C
30 programming and debugging. It uses the virtual memory hardware of your
31 system to detect when software overruns malloc() buffer boundaries,
32 and/or to detect any accesses of memory released by free().
33 ElectricFence will then stop the program on the first instruction that
34 caused a bounds violation and you can use your favorite debugger to
35 display the offending statement.
36
37 %description -l de
38 Wenn Sie wissen, was malloc()-Verletzungen sind, sind Sie
39 wahrscheinlich an ElectricFence interessiert. ElectricFence ist ein
40 Tool, das zur C- Programmierung und zum Debugging benutzt werden kann.
41 Es benutzt virtuelle Speicherhardware, um zu erkennen, wenn Software
42 malloc()-Buffergrenzen übersteigt, und wenn Speicher mit free()
43 freigegeben wird. ElectricFence beendet das Programm bei der
44 Instruktion, die die Speicherverletzung ausgelöst hat, und Sie können
45 Ihren Lieblingsdebugger benutzen, um den Befehl anzuzeigen.
46
47 %description -l es
48 ElectricFence es una herramienta que puede usarse para programación y
49 depuración en lenguaje C. A través del uso del hardware de memoria
50 virtual del sistema, detecta accesos que sobrepasan los límites de la
51 memoria asignada con malloc(), o acceso a la memoria liberada por
52 free(). En esas situaciones, ElectricFence interrumpe la ejecución del
53 programa en la primera instrucción que causó la violación, y puede
54 usarse un debugger para verificar la causa del problema.
55
56 %description -l fr
57 Electric Fence est une bibliothéque utilisée pour la programmation en
58 C et le débogage. Vous pouvez la lier à la compilation et elle vous
59 avertira des problèmes éventuels de désallocation de mémoire, etc.
60
61 %description -l pl
62 Electric Fence jest bibliotek± pomocn± podczas programowania w jêzyku
63 C i "odpluskwiania". Pakiet zawiera bibliotekê wspó³dzielon±, która
64 mo¿e byæ za³adowana przez zmienn± LD_PRELOAD w trakcie uruchamiania
65 dowolnego programu dziêki temu nie potrzeba linkowaæ z t± bibliotek±
66 ¶ledzonego programu. Pakiet zawiera tak¿e skrypt pow³oki ef, który
67 ³aduje do pamiêci przez LD_PRELOAD bibliotekê libefence i uruchamia
68 program przekazany do tego skryptu jako parametr.
69
70 %description -l pt_BR
71 ElectricFence é uma ferramenta que pode ser usada com programação e
72 depuracao em linguagem C. Através do uso do hardware de memoria
73 virtual do sistema, o ElectricFence detecta acessos além dos limites
74 da memória alocada com malloc(), ou acesso a memória liberada por
75 free(). Nessas situações, o ElectricFence interrompe a execução do
76 programa na primeira instrução que causou a violação, e um debugger
77 pode ser usado para verificar a causa do problema.
78
79 %description -l tr
80 Electric Fence, C'de programlama ve hata ayýklama için kullanýlabilen
81 bir kitaplýktýr. Derleme esnasýnda programýnýza baðlarsanýz, sizi
82 ortaya çýkabilecek sorunlar (var olmayan bir bellek parçasýnýn serbest
83 býrakýlmasý gibi) konusunda uyarýr.
84
85 %package static
86 Summary:        Static Electric Fence library
87 Summary(pl):    Biblioteka statyczna Electric Fence
88 Group:          Development/Debuggers
89 Group(de):      Entwicklung/Debugger
90 Group(pl):      Programowanie/Odpluskwiacze
91 Obsoletes:      libefence0-devel
92
93 %description static
94 Static Electric Fence library.
95
96 %description -l pl static
97 Biblioteka statyczna Electric Fence.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 %build
107 libtoolize --copy --force
108 aclocal
109 autoconf
110 automake -a -c
111 CFLAGS="%{rpmcflags} -DUSE_SEMAPHORE"
112 %configure
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 gzip -9nf README NEWS
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %doc *gz
132 %attr(755,root,root) %{_bindir}/ef
133 %attr(755,root,root) %{_libdir}/lib*.so.*.*
134 %attr(755,root,root) %{_libdir}/lib*.so
135 %{_mandir}/man3/*
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/lib*.a
This page took 0.071396 seconds and 4 git commands to generate.