]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
- updated DFBTutorials to 0.5.0
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 # _without_flash        - don't build FLASH support
4 # _without_mpg          - don't build support for MPG/MPEG3
5 #
6 Summary:        DirectFB - Hardware graphics acceleration
7 Summary(pl):    DirectFB - Wspomaganie grafiki
8 Name:           DirectFB
9 Version:        0.9.13
10 Release:        3
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
14 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
15 Patch0:         %{name}-am.patch
16 URL:            http://www.directfb.org/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{!?_without_flash:BuildRequires:       flash-devel >= 0.4.10-5}
20 BuildRequires:  freetype-devel >= 2.0.2
21 BuildRequires:  libjpeg-devel >= 6b
22 %{!?_without_mpg:BuildRequires: libmpeg3-devel}
23 BuildRequires:  libpng-devel >= 1.0
24 BuildRequires:  libtool
25 BuildRequires:  zlib-devel >= 1.1.3
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         dfbdir  %{_libdir}/directfb-%{version}
29
30 %description
31 DirectFB hardware graphics acceleration - libraries.
32
33 %description -l pl
34 Wspomaganie grafiki DirectFB - biblioteki.
35
36 %package devel
37 Summary:        DirectFB - development package
38 Summary(pl):    DirectFB - pliki nag³ówkowe
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}
41
42 %description devel
43 DirectFB header files.
44
45 %description devel -l pl
46 Pliki nag³ówkowe dla DirectFB.
47
48 %package static
49 Summary:        DirectFB static libraries
50 Summary(pl):    Statyczne biblioteki DirectFB
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}
53
54 %description static
55 DirectFB static libraries.
56
57 %description static -l pl
58 Statyczne biblioteki DirectFB.
59
60 %package doc
61 Summary:        DirectFB - documentation
62 Summary(pl):    DirectFB - dokumantacja
63 Group:          Development/Libraries
64
65 %description doc
66 DirectFB documentation and tutorials.
67
68 %description doc -l pl
69 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
70
71 %package font-ft2
72 Summary:        FreeType2 font provider for DirectFB
73 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
74 Group:          Libraries
75 Requires:       %{name} = %{version}
76
77 %description font-ft2
78 This package contains FreeType2 font provider for DirectFB.
79
80 %description font-ft2 -l pl
81 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
82 bibliotekê FreeType2.
83
84 %package image-jpeg
85 Summary:        JPEG image provider for DirectFB
86 Summary(pl):    DirectFB - wtyczka dostarczajaca grafikê JPEG
87 Group:          Libraries
88 Requires:       %{name} = %{version}
89
90 %description image-jpeg
91 This package contains JPEG image provider for DirectFB.
92
93 %description image-jpeg -l pl
94 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
95
96 %package image-png
97 Summary:        PNG image provider for DirectFB
98 Summary(pl):    DirectFB - wtyczka dostarczajaca grafikê PNG
99 Group:          Libraries
100 Requires:       %{name} = %{version}
101
102 %description image-png
103 This package contains PNG image provider for DirectFB.
104
105 %description image-png -l pl
106 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
107
108 %package video-libmpeg3
109 Summary:        MPEG video provider for DirectFB
110 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
111 Group:          Libraries
112 Requires:       %{name} = %{version}
113
114 %description video-libmpeg3
115 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
116 DirectFB. It uses libmpeg3 library.
117
118 %description video-libmpeg3 -l pl
119 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
120 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3. 
121
122 %package video-swf
123 Summary:        ShockWave Flash video provider for DirectFB
124 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz ShockWave Flash
125 Group:          Libraries
126 Requires:       %{name} = %{version}
127
128 %description video-swf
129 This package contains SWF (ShockWave Flash) video provider for
130 DirectFB. It uses flash library.
131
132 %description video-swf -l pl
133 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± obraz SWF
134 (ShockWave Flash) przy u¿yciu biblioteki flash.
135
136 %prep
137 %setup -q -a1
138 %patch0 -p1
139
140 %build
141 rm -f missing
142 %{__libtoolize}
143 %{__aclocal}
144 %{__autoconf}
145 %{__automake}
146 # paths for libmpeg3 and libflash
147 CPPFLAGS="-I/usr/include/libmpeg3 -I/usr/X11R6/include"
148 LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
149 %configure \
150         --disable-maintainer-mode \
151         --enable-shared \
152         --enable-static \
153         --disable-fast-install \
154         --disable-debug \
155         %{?_without_flash:--disable-flash} \
156         %{?_without_mpg:--disable-libmpeg3} \
157         --disable-avifile \
158 %ifarch i586 i686 athlon
159         --enable-mmx=on
160 %endif
161 # MMX is detected at runtime, so it's safe
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 %{__make} DESTDIR=$RPM_BUILD_ROOT install
168
169 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
170 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/lib*.so.*.*
181 %dir %{dfbdir}
182 %dir %{dfbdir}/gfxdrivers
183 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.??
184 %dir %{dfbdir}/inputdrivers
185 %attr(755,root,root) %{dfbdir}/inputdrivers/*.??
186 %dir %{dfbdir}/interfaces
187 %dir %{dfbdir}/interfaces/IDirectFBFont
188 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.??
189 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
190 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.??
191 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
192 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.??
193 %{_datadir}/directfb-%{version}
194 %{_mandir}/man5/*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/directfb-config
199 %{_includedir}/directfb
200 %{_includedir}/directfb-internal
201 %{_pkgconfigdir}/*
202 %{_libdir}/*.la
203 %{_libdir}/*.so
204
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/lib*.a
208 %{dfbdir}/gfxdrivers/*.a
209 %{dfbdir}/inputdrivers/*.a
210 %{dfbdir}/interfaces/*/*.a
211
212 %files doc
213 %defattr(644,root,root,755)
214 %doc docs/html/*
215 %{_examplesdir}/%{name}-%{version}
216
217 %files font-ft2
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.??
220
221 %files image-jpeg
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.??
224
225 %files image-png
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.??
228
229 %if %{!?_without_mpg:1}%{?_without_mpg:0}
230 %files video-libmpeg3
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.??
233 %endif
234
235 %if %{!?_without_flash:1}%{?_without_flash:0}
236 %files video-swf
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swf.??
239 %endif
This page took 0.594488 seconds and 3 git commands to generate.