]> git.pld-linux.org Git - packages/CharLS.git/blob - CharLS.spec
- added missing header file, release 2
[packages/CharLS.git] / CharLS.spec
1 # NOTE: for >= 2.0.0 (C++14 based) see DEVEL branch
2 Summary:        An optimized implementation of the JPEG-LS standard
3 Summary(pl.UTF-8):      Zoptymalizowana implementacja standardu JPEG-LS
4 Name:           CharLS
5 Version:        1.1.0
6 Release:        2
7 License:        BSD
8 Group:          Libraries
9 #Source0Download: https://github.com/team-charls/charls/releases
10 Source0:        https://github.com/team-charls/charls/archive/%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  ea02f65abd33aa46830dedec8f4c52f5
12 URL:            https://github.com/team-charls/charls
13 BuildRequires:  cmake >= 2.6
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  rpmbuild(macros) >= 1.566
16 BuildRequires:  sed >= 4.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 An optimized implementation of the JPEG-LS standard for loss less and
21 near loss less image compression. JPEG-LS is a low-complexity standard
22 that matches JPEG 2000 compression ratios. In terms of speed, CharLS
23 outperforms open source and commercial JPEG LS implementations.
24
25 %description -l pl.UTF-8
26 Zoptymalizowana implementacja standardu JPEG-LS bezstratnej i prawie
27 bezstratnej kompresji obrazu. JPEG-LS to mało skomplikowany standard
28 osiągający współczynniki kompresji standardu JPEG 2000. Pod względem
29 szybkości CharLS jest wydajniejszy niż inne implementacje JPEG LS o
30 otwartych źródłach, a także komercyjne.
31
32 %package devel
33 Summary:        Header files for CharLS library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CharLS
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38
39 %description devel
40 Header files for CharLS library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki CharLS.
44
45 %prep
46 %setup -q -n charls-%{version}
47
48 %build
49 %cmake . \
50         -DBUILD_TESTING=ON
51
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 # the most important header file is missing from make install...
61 test ! -f $RPM_BUILD_ROOT%{_includedir}/CharLS/interface.h
62 cp -p src/interface.h $RPM_BUILD_ROOT%{_includedir}/CharLS
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post   -p /sbin/ldconfig
68 %postun -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README.md src/License.txt
73 %attr(755,root,root) %{_libdir}/libCharLS.so.*.*
74 %attr(755,root,root) %ghost %{_libdir}/libCharLS.so.1
75
76 %files devel
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_libdir}/libCharLS.so
79 %{_includedir}/CharLS
This page took 0.071408 seconds and 4 git commands to generate.