]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- added python-CEGUI-Renderer-Ogre package
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - separate packages for plugins
3 #
4 # Conditional build:
5 %bcond_without  xercesc         # build XercesParser
6 %bcond_without  ogre            # build without Ogre renderer
7 %bcond_without  opengl          # build without OpenGL renderer
8 %bcond_with     samples         # build samples
9 #
10 Summary:        CEGUI - a free library providing windowing and widgets
11 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
12 Name:           CEGUI
13 Version:        0.7.7
14 Release:        0.1
15 License:        LGPL v2.1+ (with MIT parts)
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
18 # Source0-md5:  8b83577f86eaa1581765dd155c7c8f24
19 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
20 # Source1-md5:  4d011b7e262222a4c0129ccb19014686
21 URL:            http://www.cegui.org.uk/
22 BuildRequires:  DevIL-devel
23 BuildRequires:  DirectFB-devel >= 1.2.0
24 BuildRequires:  FreeImage-devel
25 BuildRequires:  SILLY-devel >= 0.1.0
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake
28 BuildRequires:  corona-devel
29 BuildRequires:  expat-devel
30 BuildRequires:  freetype-devel >= 2.0
31 BuildRequires:  gtk+2-devel >= 2:2.4
32 BuildRequires:  irrlicht-devel >= 1.4
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool >= 2:1.5
35 BuildRequires:  libxml2-devel >= 1:2.6
36 BuildRequires:  lua51-devel >= 5.1
37 %if %{with ogre}
38 BuildRequires:  ogre-devel >= 1.6.0
39 BuildRequires:  ois-devel >= 1.0.0
40 %endif
41 BuildRequires:  pcre-devel >= 5.0
42 BuildRequires:  pkgconfig
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tinyxml-devel
45 BuildRequires:  tolua++-devel
46 # for irrlicht renderer
47 BuildRequires:  xorg-lib-libXxf86vm-devel
48 %if %{with opengl}
49 BuildRequires:  OpenGL-GLU-devel
50 BuildRequires:  OpenGL-glut-devel
51 BuildRequires:  glew-devel
52 %endif
53 %if %{with xercesc}
54 BuildRequires:  xerces-c-devel
55 %endif
56 Requires:       irrlicht >= 1.4
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 CEGUI stands for Crazy Eddie's Gui System; a free library providing
61 windowing and widgets for graphics APIs / engines where such
62 functionality is not natively available, or severely lacking. The
63 library is object orientated, written in C++, and targeted at games
64 developers who should be spending their time creating great games, not
65 building GUI sub-systems!
66
67 %description -l pl.UTF-8
68 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
69 zapewniającą okienka i widgety dla graficznych API i silników tam,
70 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
71 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
72 skierowana dla programistów gier, którzy powinni spędzać czas na
73 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
74
75 %package devel
76 Summary:        Development files for CEGUI
77 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       freetype-devel >= 2.0
81 Requires:       libstdc++-devel
82 Requires:       pcre-devel >= 5.0
83
84 %description devel
85 CEGUI headers.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe CEGUI.
89
90 %package docs
91 Summary:        Documentation files for CEGUI
92 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
93 Group:          Documentation
94 Requires:       %{name} = %{version}-%{release}
95
96 %description docs
97 CEGUI documentation.
98
99 %description docs -l pl.UTF-8
100 Dokumentacja CEGUI.
101
102 %package ImageCodec-Corona
103 Summary:        CoronaImageCodec library for CEGUI
104 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description ImageCodec-Corona
109 CoronaImageCodec library for CEGUI.
110
111 %description ImageCodec-Corona -l pl.UTF-8
112 Biblioteka CoronaImageCodec dla CEGUI
113
114 %package ImageCodec-Corona-devel
115 Summary:        Header files for CEGUI CoronaImageCodec library
116 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
117 Group:          Development/Libraries
118 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
119 Requires:       %{name}-devel = %{version}-%{release}
120 Requires:       corona-devel
121
122 %description ImageCodec-Corona-devel
123 Header files for CEGUI CoronaImageCodec library.
124
125 %description ImageCodec-Corona-devel -l pl.UTF-8
126 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
127
128 %package ImageCodec-DevIL
129 Summary:        DevILImageCodec library for CEGUI
130 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
131 Group:          Libraries
132 Requires:       %{name} = %{version}-%{release}
133
134 %description ImageCodec-DevIL
135 DevILImageCodec library for CEGUI.
136
137 %description ImageCodec-DevIL -l pl.UTF-8
138 Biblioteka DevILImageCodec dla CEGUI
139
140 %package ImageCodec-DevIL-devel
141 Summary:        Header files for CEGUI DevILImageCodec library
142 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
143 Group:          Development/Libraries
144 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
145 Requires:       %{name}-devel = %{version}-%{release}
146 Requires:       DevIL-devel
147
148 %description ImageCodec-DevIL-devel
149 Header files for CEGUI DevILImageCodec library.
150
151 %description ImageCodec-DevIL-devel -l pl.UTF-8
152 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
153
154 %package ImageCodec-FreeImage
155 Summary:        FreeImageImageCodec library for CEGUI
156 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
157 Group:          Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description ImageCodec-FreeImage
161 FreeImageImageCodec library for CEGUI.
162
163 %description ImageCodec-FreeImage -l pl.UTF-8
164 Biblioteka FreeImageImageCodec dla CEGUI
165
166 %package ImageCodec-FreeImage-devel
167 Summary:        Header files for CEGUI FreeImageImageCodec library
168 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
169 Group:          Development/Libraries
170 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
171 Requires:       %{name}-devel = %{version}-%{release}
172 Requires:       FreeImage-devel
173
174 %description ImageCodec-FreeImage-devel
175 Header files for CEGUI FreeImageImageCodec library.
176
177 %description ImageCodec-FreeImage-devel -l pl.UTF-8
178 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
179
180 %package ImageCodec-SILLY
181 Summary:        SILLYImageCodec library for CEGUI
182 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       SILLY >= 0.1.0
186
187 %description ImageCodec-SILLY
188 SILLYImageCodec library for CEGUI.
189
190 %description ImageCodec-SILLY -l pl.UTF-8
191 Biblioteka SILLYImageCodec dla CEGUI
192
193 %package ImageCodec-SILLY-devel
194 Summary:        Header files for CEGUI SILLYImageCodec library
195 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
196 Group:          Development/Libraries
197 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
198 Requires:       %{name}-devel = %{version}-%{release}
199 Requires:       SILLY-devel >= 0.1.0
200
201 %description ImageCodec-SILLY-devel
202 Header files for CEGUI SILLYImageCodec library.
203
204 %description ImageCodec-SILLY-devel -l pl.UTF-8
205 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
206
207 %package Renderer-Irrlicht
208 Summary:        IrrlichtRenderer library for CEGUI
209 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       irrlicht >= 1.4
213
214 %description Renderer-Irrlicht
215 IrrlichtRenderer library for CEGUI.
216
217 %description Renderer-Irrlicht -l pl.UTF-8
218 Biblioteka IrrlichtRenderer dla CEGUI
219
220 %package Renderer-Irrlicht-devel
221 Summary:        Header files for CEGUI IrrlichtRenderer library
222 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
223 Group:          Development/Libraries
224 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
225 Requires:       %{name}-devel = %{version}-%{release}
226 Requires:       irrlicht-devel >= 1.4
227
228 %description Renderer-Irrlicht-devel
229 Header files for CEGUI IrrlichtRenderer library.
230
231 %description Renderer-Irrlicht-devel -l pl.UTF-8
232 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
233
234 %package Renderer-Ogre
235 Summary:        OgreRenderer library for CEGUI
236 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239 Obsoletes:      CEGUI-Ogre
240
241 %description Renderer-Ogre
242 OgreRenderer library for CEGUI.
243
244 %description Renderer-Ogre -l pl.UTF-8
245 Biblioteka OgreRenderer dla CEGUI
246
247 %package Renderer-Ogre-devel
248 Summary:        Header files for CEGUI OgreRenderer library
249 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
250 Group:          Development/Libraries
251 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
252 Requires:       %{name}-devel = %{version}-%{release}
253 Requires:       ogre-devel >= 1.6.0
254 Obsoletes:      CEGUI-Ogre-devel
255
256 %description Renderer-Ogre-devel
257 Header files for CEGUI OgreRenderer library.
258
259 %description Renderer-Ogre-devel -l pl.UTF-8
260 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
261
262 %package Renderer-OpenGL
263 Summary:        OpenGLRenderer library for CEGUI
264 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
265 Group:          Libraries
266 Requires:       %{name} = %{version}-%{release}
267 Obsoletes:      CEGUI-OpenGL
268
269 %description Renderer-OpenGL
270 OpenGLRenderer library for CEGUI.
271
272 %description Renderer-OpenGL -l pl.UTF-8
273 Biblioteka OpenGLRenderer dla CEGUI.
274
275 %package Renderer-OpenGL-devel
276 Summary:        Header files for CEGUI OpenGLRenderer library
277 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
278 Group:          Development/Libraries
279 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
280 Requires:       %{name}-devel = %{version}-%{release}
281 Requires:       OpenGL-GLU-devel
282 Requires:       OpenGL-glut-devel
283 Requires:       glew-devel
284 Obsoletes:      CEGUI-OpenGL-devel
285
286 %description Renderer-OpenGL-devel
287 Header files for CEGUI OpenGLRenderer library.
288
289 %description Renderer-OpenGL-devel -l pl.UTF-8
290 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
291
292 %package -n python-CEGUI
293 Summary:        Python binding for CEGUI
294 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
295 Group:          Libraries/Python
296 Requires:       %{name} = %{version}-%{release}
297
298 %description -n python-CEGUI
299 Python binding for CEGUI.
300
301 %description -n python-CEGUI -l pl.UTF-8
302 Wiązania Pythona do CEGUI.
303
304 %package -n python-CEGUI-Renderer-Ogre
305 Summary:        Python binding for CEGUI OgreRenderer library
306 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
307 Group:          Libraries/Python
308 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
309 Requires:       python-CEGUI = %{version}-%{release}
310
311 %description -n python-CEGUI-Renderer-Ogre
312 Python binding for CEGUI OgreRenderer library.
313
314 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
315 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
316
317 %package -n python-CEGUI-Renderer-OpenGL
318 Summary:        Python binding for CEGUI OpenGLRenderer library
319 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
320 Group:          Libraries/Python
321 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
322 Requires:       python-CEGUI = %{version}-%{release}
323
324 %description -n python-CEGUI-Renderer-OpenGL
325 Python binding for CEGUI OpenGLRenderer library.
326
327 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
328 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
329
330 %prep
331 %setup -q -a 1
332
333 sed -i -e 's/lua5\.1/lua51/' acinclude.m4
334
335 %build
336 %{__libtoolize}
337 %{__aclocal}
338 %{__autoconf}
339 %{__autoheader}
340 %{__automake}
341 %configure \
342         cegui_corona_config=/usr/bin/corona-config \
343         --with-default-image-codec=FreeImageImageCodec \
344         --with-default-xml-parser=LibxmlParser \
345         %{!?with_samples:--disable-samples} \
346         --enable-ogre-renderer%{!?with_ogre:=no} \
347         --enable-opengl-renderer%{!?with_opengl:=no} \
348         --enable-xerces-c%{!?with_xercesc:=no}
349
350 %{__make}
351
352 %install
353 rm -rf $RPM_BUILD_ROOT
354
355 %{__make} install \
356         DESTDIR=$RPM_BUILD_ROOT
357
358 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
359
360 %if %{without samples}
361 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/CEGUI/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
362 %endif
363
364 %clean
365 rm -rf $RPM_BUILD_ROOT
366
367 %post   -p /sbin/ldconfig
368 %postun -p /sbin/ldconfig
369
370 %post   ImageCodec-Corona -p /sbin/ldconfig
371 %postun ImageCodec-Corona -p /sbin/ldconfig
372 %post   ImageCodec-DevIL -p /sbin/ldconfig
373 %postun ImageCodec-DevIL -p /sbin/ldconfig
374 %post   ImageCodec-FreeImage -p /sbin/ldconfig
375 %postun ImageCodec-FreeImage -p /sbin/ldconfig
376 %post   ImageCodec-SILLY -p /sbin/ldconfig
377 %postun ImageCodec-SILLY -p /sbin/ldconfig
378
379 %post   Renderer-Irrlicht -p /sbin/ldconfig
380 %postun Renderer-Irrlicht -p /sbin/ldconfig
381 %post   Renderer-Ogre -p /sbin/ldconfig
382 %postun Renderer-Ogre -p /sbin/ldconfig
383 %post   Renderer-OpenGL -p /sbin/ldconfig
384 %postun Renderer-OpenGL -p /sbin/ldconfig
385
386 %files
387 %defattr(644,root,root,755)
388 %doc doc/README
389 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
390 # plugins
391 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
392 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
393 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
394 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
395 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
396 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
397 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
398 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
399 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec-%{version}.so
400 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec.so
401 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
402 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
403 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
404 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
405 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
406 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
407
408 %files docs
409 %defattr(644,root,root,755)
410 %doc docs
411
412 %files devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
415 %{_libdir}/libCEGUIBase.la
416 # plugins - but as their headers are included...
417 %{_libdir}/libCEGUIExpatParser.la
418 %{_libdir}/libCEGUIFalagardWRBase.la
419 %{_libdir}/libCEGUIFreeImageImageCodec.la
420 %{_libdir}/libCEGUILibxmlParser.la
421 %{_libdir}/libCEGUILuaScriptModule.la
422 %{_libdir}/libCEGUISTBImageCodec.la
423 %{_libdir}/libCEGUITGAImageCodec.la
424 %{_libdir}/libCEGUITinyXMLParser.la
425 %{_libdir}/libCEGUIXercesParser.la
426 %dir %{_includedir}/%{name}
427 %{_includedir}/%{name}/CEGUI*.h
428 %dir %{_includedir}/%{name}/ImageCodecModules
429 %{_includedir}/%{name}/ImageCodecModules/STBImageCodec
430 %{_includedir}/%{name}/ImageCodecModules/TGAImageCodec
431 %dir %{_includedir}/%{name}/RendererModules
432 %{_includedir}/%{name}/ScriptingModules
433 %{_includedir}/%{name}/WindowRendererSets
434 %{_includedir}/%{name}/XMLParserModules
435 %{_includedir}/%{name}/elements
436 %{_includedir}/%{name}/falagard
437 %{_pkgconfigdir}/CEGUI.pc
438
439 %files ImageCodec-Corona
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
442 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
443
444 %files ImageCodec-Corona-devel
445 %defattr(644,root,root,755)
446 %{_libdir}/libCEGUICoronaImageCodec.la
447 %{_includedir}/%{name}/ImageCodecModules/CoronaImageCodec
448
449 %files ImageCodec-DevIL
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
452 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
453
454 %files ImageCodec-DevIL-devel
455 %defattr(644,root,root,755)
456 %{_libdir}/libCEGUIDevILImageCodec.la
457 %{_includedir}/%{name}/ImageCodecModules/DevILImageCodec
458
459 %files ImageCodec-FreeImage
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
462 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
463
464 %files ImageCodec-FreeImage-devel
465 %defattr(644,root,root,755)
466 %{_libdir}/libCEGUIFreeImageImageCodec.la
467 %{_includedir}/%{name}/ImageCodecModules/FreeImageImageCodec
468
469 %files ImageCodec-SILLY
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
472 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
473
474 %files ImageCodec-SILLY-devel
475 %defattr(644,root,root,755)
476 %{_libdir}/libCEGUISILLYImageCodec.la
477 %{_includedir}/%{name}/ImageCodecModules/SILLYImageCodec
478
479 %files Renderer-Irrlicht
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
482 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
483
484 %files Renderer-Irrlicht-devel
485 %defattr(644,root,root,755)
486 %{_libdir}/libCEGUIIrrlichtRenderer.la
487 %{_includedir}/%{name}/RendererModules/Irrlicht
488
489 %if %{with ogre}
490 %files Renderer-Ogre
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
493 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so
494
495 %files Renderer-Ogre-devel
496 %defattr(644,root,root,755)
497 %{_libdir}/libCEGUIOgreRenderer.la
498 %{_includedir}/%{name}/RendererModules/Ogre
499 %{_pkgconfigdir}/CEGUI-OGRE.pc
500 %endif
501
502 %if %{with opengl}
503 %files Renderer-OpenGL
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
506
507 %files Renderer-OpenGL-devel
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
510 %{_libdir}/libCEGUIOpenGLRenderer.la
511 %{_includedir}/%{name}/RendererModules/OpenGL
512 %{_pkgconfigdir}/CEGUI-OPENGL.pc
513 %endif
514
515 %files -n python-CEGUI
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{py_sitedir}/PyCEGUI.so
518
519 %if %{with ogre}
520 %files -n python-CEGUI-Renderer-Ogre
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{py_sitedir}/PyCEGUIOgreRenderer.so
523 %endif
524
525 %if %{with opengl}
526 %files -n python-CEGUI-Renderer-OpenGL
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{py_sitedir}/PyCEGUIOpenGLRenderer.so
529 %endif
This page took 0.061994 seconds and 4 git commands to generate.