]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- start update to 0.7.1 version
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 # - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
5 # - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
6 #
7 # Conditional build:
8 %bcond_without  xercesc         # build XercesParser
9 %bcond_with     ogre            # build samples with ogre3d
10 %bcond_with     samples         # build samples
11 #
12 Summary:        CEGUI - a free library providing windowing and widgets
13 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
14 Name:           CEGUI
15 Version:        0.7.1
16 Release:        0.1
17 License:        LGPL v2.1+ (with MIT parts)
18 Group:          Libraries
19 Source0:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
20 # Source0-md5:  0a2815d5204e3c5510884ab62285da97
21 Source1:        http://dl.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
22 # Source1-md5:  b6c1656d6b004c3dc11bf4b887fd5bd3
23 Patch0:         %{name}-link.patch
24 URL:            http://www.cegui.org.uk/
25 BuildRequires:  DevIL-devel
26 BuildRequires:  DirectFB-devel
27 BuildRequires:  FreeImage-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-glut-devel
30 BuildRequires:  SILLY-devel >= 0.1.0
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  corona-devel >= 1.0.2
34 BuildRequires:  expat-devel
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  glew-devel
37 BuildRequires:  irrlicht-devel >= 1.4
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  libxml2-devel >= 1:2.6
41 BuildRequires:  lua51-devel >= 5.1
42 %if %{with ogre}
43 BuildRequires:  ogre-devel >= 1.0.0
44 BuildRequires:  ois-devel
45 %endif
46 BuildRequires:  pcre-devel >= 5.0
47 BuildRequires:  pkgconfig
48 # for irrlicht renderer
49 BuildRequires:  xorg-lib-libXxf86vm-devel
50 %if %{with xercesc}
51 BuildRequires:  xerces-c-devel
52 %endif
53 Requires:       irrlicht >= 1.4
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 CEGUI stands for Crazy Eddie's Gui System; a free library providing
58 windowing and widgets for graphics APIs / engines where such
59 functionality is not natively available, or severely lacking. The
60 library is object orientated, written in C++, and targeted at games
61 developers who should be spending their time creating great games, not
62 building GUI sub-systems!
63
64 %description -l pl.UTF-8
65 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
66 zapewniającą okienka i widgety dla graficznych API i silników tam,
67 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
68 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
69 skierowana dla programistów gier, którzy powinni spędzać czas na
70 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
71
72 %package devel
73 Summary:        Development files for CEGUI
74 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       freetype-devel >= 2.0
78 Requires:       libstdc++-devel
79 Requires:       pcre-devel >= 5.0
80
81 %description devel
82 CEGUI headers.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe CEGUI.
86
87 %package docs
88 Summary:        Documentation files for CEGUI
89 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
90 Group:          Documentation
91 Requires:       %{name} = %{version}-%{release}
92
93 %description docs
94 CEGUI documentation.
95
96 %description docs -l pl.UTF-8
97 Dokumentacja CEGUI.
98
99
100 %prep
101 %setup -q -a 1
102 %patch0 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --with-default-image-codec=FreeImageImageCodec \
112         --with-default-xml-parser=LibxmlParser \
113         %{!?with_samples:--disable-samples} \
114         %{!?with_ogre:--without-ogre-renderer} \
115         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc doc/README
134 # libs
135 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
136 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
137 # plugins
138 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
139 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
140 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
141 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
142 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
143 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
144 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
145 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
146 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
147 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
148 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
149 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
150 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
151 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
152 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
153 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
154 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
155 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
156 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
157 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
158 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
159 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
160 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
161 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
162 %attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
163 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
164
165 %files docs
166 %defattr(644,root,root,755)
167 %doc docs/CEGUI-DOCS-%{version}
168 %dir %{_datadir}/%{name}
169 %dir %{_datadir}/%{name}/xml_schemas
170 %{_datadir}/%{name}/xml_schemas/*.xsd
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
175 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
176 %{_libdir}/libCEGUIBase.la
177 %{_libdir}/libCEGUIOpenGLRenderer.la
178 # plugins - but as their headers are included...
179 %{_libdir}/libCEGUICoronaImageCodec.la
180 %{_libdir}/libCEGUIDevILImageCodec.la
181 %{_libdir}/libCEGUIExpatParser.la
182 %{_libdir}/libCEGUIFalagardWRBase.la
183 %{_libdir}/libCEGUIFreeImageImageCodec.la
184 %{_libdir}/libCEGUIIrrlichtRenderer.la
185 %{_libdir}/libCEGUILibxmlParser.la
186 %{_libdir}/libCEGUILuaScriptModule.la
187 %{_libdir}/libCEGUISILLYImageCodec.la
188 %{_libdir}/libCEGUITGAImageCodec.la
189 %{_libdir}/libCEGUITinyXMLParser.la
190 %{_libdir}/libCEGUIXercesParser.la
191 %{_libdir}/libCEGUItoluapp.la
192 %{_includedir}/%{name}
193 %{_pkgconfigdir}/CEGUI.pc
194 %{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.092306 seconds and 4 git commands to generate.