]> git.pld-linux.org Git - packages/AMD.git/blob - AMD.spec
- build fortran libraries
[packages/AMD.git] / AMD.spec
1 Summary:        AMD: Approximate Minimum Degree
2 Summary(pl.UTF-8):      AMD - przybliżony algorytm minimalnego stopnia
3 Name:           AMD
4 Version:        2.3.1
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/amd/%{name}-%{version}.tar.gz
9 # Source0-md5:  ee402611aa672257752611cfac10d7cd
10 Patch0:         amd-ufconfig.patch
11 Patch1:         amd-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/amd/
13 BuildRequires:  SuiteSparse_config >= 4.0.0
14 BuildRequires:  gcc-fortran
15 BuildRequires:  libtool >= 2:1.5
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 AMD is a set of routines for ordering a sparse matrix prior to
20 Cholesky factorization (or for LU factorization with diagonal
21 pivoting). There are versions in both C and Fortran. A MATLAB
22 interface is provided. Note that this software has nothing to do with
23 AMD the company.
24
25 %description -l pl.UTF-8
26 AMD to zbiór procedur do porządkowania macierzy rzadkich przed
27 rozkładem Cholesky'ego (lub do rozkładu LU z obrotami diagonalnymi).
28 Istnieją wersje zarówno w C, jak i Fortranie. Dostępny jest interfejs
29 do MATLAB-a. Uwaga: to oprogramowanie nie ma nic wspólnego z firmą
30 AMD.
31
32 %package devel
33 Summary:        Header files for AMD library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AMD
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       SuiteSparse_config >= 4.0.0
38
39 %description devel
40 Header files for AMD library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki AMD.
44
45 %package static
46 Summary:        Static AMD library
47 Summary(pl.UTF-8):      Statyczna biblioteka AMD
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static AMD library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka AMD.
56
57 %package fortran
58 Summary:        Fortran version of AMD library
59 Summary(pl.UTF-8):      Wersja biblioteki AMD dla programów w Fortranie
60 Group:          Development/Libraries
61
62 %description fortran
63 Fortran version of AMD library.
64
65 %description fortran -l pl.UTF-8
66 Wersja biblioteki AMD dla programów napisanych w Fortranie.
67
68 %package fortran-static
69 Summary:        Fortran version of AMD static library
70 Summary(pl.UTF-8):      Wersja statycznej biblioteki AMD dla programów w Fortranie
71 Group:          Development/Libraries
72
73 %description fortran-static
74 Fortran version of AMD static library.
75
76 %description fortran-static -l pl.UTF-8
77 Wersja statycznej biblioteki AMD dla programów napisanych w Fortranie.
78
79 %prep
80 %setup -q -n %{name}
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 %{__make} \
86         CC="%{__cc}" \
87         CFLAGS="%{rpmcflags}" \
88         LDFLAGS="%{rpmldflags}" \
89         libdir=%{_libdir}
90
91 %{__make} fortran \
92         CC="%{__cc}" \
93         CFLAGS="%{rpmcflags}" \
94         LDFLAGS="%{rpmldflags}" \
95         libdir=%{_libdir}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_includedir}/amd
100
101 %{__make} -C Lib install install-fortran \
102         DESTDIR=$RPM_BUILD_ROOT \
103         libdir=%{_libdir}
104
105 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/amd
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README.txt Doc/{ChangeLog,License}
116 %attr(755,root,root) %{_libdir}/libamd.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libamd.so.0
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc Doc/AMD_UserGuide.pdf
122 %attr(755,root,root) %{_libdir}/libamd.so
123 %{_libdir}/libamd.la
124 %{_includedir}/amd
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libamd.a
129
130 %files fortran
131 %defattr(644,root,root,755)
132 %{_libdir}/libamdf77.la
133 %attr(755,root,root) %{_libdir}/libamdf77.so.*.*.*
134 %attr(755,root,root) %{_libdir}/libamdf77.so.0
135 %attr(755,root,root) %{_libdir}/libamdf77.so
136
137 %files fortran-static
138 %defattr(644,root,root,755)
139 %{_libdir}/libamdf77.a
This page took 0.090751 seconds and 4 git commands to generate.