]> git.pld-linux.org Git - packages/xfsprogs.git/blame_incremental - xfsprogs.spec
- updated pl.po-update patch
[packages/xfsprogs.git] / xfsprogs.spec
... / ...
CommitLineData
1Summary: Tools for the XFS filesystem
2Summary(pl.UTF-8): Narzędzia do systemu plików XFS
3Name: xfsprogs
4Version: 4.3.0
5Release: 1
6License: LGPL v2.1 (libhandle), GPL v2 (the rest)
7Group: Applications/System
8Source0: ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
9# Source0-md5: ade22791338fa3d2cf442d6bb84f1748
10Source1: xfs_lsprojid
11Patch0: %{name}-miscfix-v2.patch
12Patch1: %{name}-pl.po-update.patch
13Patch2: %{name}-noquotasync.patch
14URL: http://www.xfs.org/
15BuildRequires: autoconf >= 2.50
16BuildRequires: automake
17BuildRequires: bash
18BuildRequires: gettext-tools
19BuildRequires: glibc-static
20BuildRequires: libblkid-devel
21BuildRequires: libtool
22BuildRequires: libuuid-devel
23BuildRequires: libuuid-static
24BuildRequires: readline-devel
25BuildRequires: rpm >= 4.4.9-56
26BuildRequires: rpmbuild(macros) >= 1.402
27Obsoletes: xfsprogs-initrd
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%if "%{pld_release}" == "ac"
31# libtool in ac doesn't do the reordering of args properly
32%define filterout_ld -Wl,--as-needed
33%endif
34
35%define _sbindir /sbin
36%define _bindir /usr/sbin
37%define _libdir /%{_lib}
38%define _libexecdir /usr/%{_lib}
39
40%description
41A set of commands to use the XFS filesystem, including mkfs.xfs.
42
43XFS is a high performance journaling filesystem which originated on
44the SGI IRIX platform. It is completely multi-threaded, can support
45large files and large filesystems, extended attributes, variable block
46sizes, is extent based, and makes extensive use of Btrees
47(directories, extents, free space) to aid both performance and
48scalability.
49
50This implementation is on-disk compatible with the IRIX version of
51XFS.
52
53%description -l pl.UTF-8
54Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
55
56XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
57był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
58obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
59atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
60B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
61
62%package devel
63Summary: Header files and libraries to develop XFS software
64Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67Requires: libuuid-devel
68
69%description devel
70Header files and libraries to develop software which operates on XFS
71filesystems.
72
73%description devel -l pl.UTF-8
74Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
75operującego na systemie plików XFS.
76
77%package static
78Summary: Static XFS software libraries
79Summary(pl.UTF-8): Biblioteki statyczne do XFS
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82
83%description static
84Static XFS software libraries.
85
86%description static -l pl.UTF-8
87Biblioteki statyczne do XFS.
88
89%prep
90%setup -q
91%patch0 -p1
92%patch1 -p1
93%patch2 -p1
94
95%build
96%{__aclocal} -I m4
97%{__autoconf}
98%configure \
99 --sbindir=%{_bindir}\
100 --enable-gettext \
101 --enable-readline \
102 --enable-blkid \
103 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
104 OPTIMIZER="%{rpmcflags}"
105
106%{__make} -j1 \
107 V=1
108
109%install
110rm -rf $RPM_BUILD_ROOT
111install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
112
113DIST_ROOT=$RPM_BUILD_ROOT
114DIST_INSTALL=$(pwd)/install.manifest
115DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
116export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
117
118%{__make} install \
119 DIST_MANIFEST="$DIST_INSTALL"
120%{__make} install-dev \
121 DIST_MANIFEST="$DIST_INSTALL_DEV"
122
123install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
124
125ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
126 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
127
128%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
129%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
130
131%{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
132 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
133
134echo "#10:/mnt/ftp/roman" >> $RPM_BUILD_ROOT/etc/projects
135echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
136
137%find_lang %{name}
138
139%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
140
141# already in /usr
142%{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
150%files -f %{name}.lang
151%defattr(644,root,root,755)
152%doc README doc/{CHANGES,CREDITS}
153%config(noreplace) %verify(not md5 mtime size) /etc/projects
154%config(noreplace) %verify(not md5 mtime size) /etc/projid
155%attr(755,root,root) %{_sbindir}/fsck.xfs
156%attr(755,root,root) %{_sbindir}/mkfs.xfs
157%attr(755,root,root) %{_sbindir}/xfs_repair
158%attr(755,root,root) %{_bindir}/xfs_*
159%attr(755,root,root) %{_libdir}/libhandle.so.*.*
160%attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
161%{_mandir}/man5/projects.5*
162%{_mandir}/man5/projid.5*
163%{_mandir}/man5/xfs.5*
164%{_mandir}/man8/fsck.xfs.8*
165%{_mandir}/man8/mkfs.xfs.8*
166%{_mandir}/man8/xfs_*.8*
167
168%files devel
169%defattr(644,root,root,755)
170%attr(755,root,root) %{_libexecdir}/libhandle.so
171%{_libexecdir}/libhandle.la
172%{_includedir}/xfs
173%{_mandir}/man3/*handle.3*
174%{_mandir}/man3/xfsctl.3*
175
176%files static
177%defattr(644,root,root,755)
178%{_libexecdir}/libhandle.a
This page took 0.060727 seconds and 4 git commands to generate.