]> git.pld-linux.org Git - packages/gcc.git/blame_incremental - gcc.spec
- reverted, %patch doesn't play with -l.
[packages/gcc.git] / gcc.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ada # build without ADA support
4%bcond_without cxx # build without C++ support
5%bcond_without fortran # build without Fortran support
6%bcond_without java # build without Java support
7%bcond_without objc # build without Objective-C support
8%bcond_without objcxx # build without Objective-C++ support
9%bcond_without multilib # build without multilib support (it needs glibc[32&64]-devel)
10%bcond_with profiling # build with profiling
11%bcond_without bootstrap # omit 3-stage bootstrap
12%bcond_with tests # torture gcc
13
14%if %{without cxx}
15%undefine with_java
16%undefine with_objcxx
17%endif
18
19%if %{without objc}
20%undefine with_objcxx
21%endif
22
23%if %{without bootstrap}
24%undefine with_profiling
25%endif
26
27%ifnarch %{x8664} ppc64 s390x sparc64
28%undefine with_multilib
29%endif
30
31Summary: GNU Compiler Collection: the C compiler and shared files
32