]> git.pld-linux.org Git - packages/gcc.git/blame_incremental - gcc.spec
- updated to 4.1.0-RC2.
[packages/gcc.git] / gcc.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ada # build without ADA support
4%bcond_without cxx # build without C++ support
5%bcond_without fortran # build without Fortran support
6%bcond_without java # build without Java support
7%bcond_without objc # build without Objective-C support
8%bcond_without objcxx # build without Objective-C++ support
9%bcond_with multilib # build with multilib support (it needs glibc[32&64]-devel)
10%bcond_with profiling # build with profiling
11%bcond_without bootstrap # omit 3-stage bootstrap
12%bcond_with tests # torture gcc
13
14%if %{with multilib}
15# the latest chrpath(64) can't handle 32-bit binaries :/
16%define _noautochrpath .*/lib/.*\\.so.*
17%endif
18
19%if %{without cxx}
20%undefine with_java
21%undefine with_objcxx
22%endif
23
24%if %{without objc}
25%undefine with_objcxx
26%endif
27
28%if %{without bootstrap}
29%undefine with_profiling
30%endif
31
32%ifnarch %{x8664} ppc64 s390x sparc64
33%undefine with_multilib
34%endif
35
36Summary: GNU Compiler Collection: the C compiler and shared files
37