]> git.pld-linux.org Git - packages/gcc.git/blame_incremental - gcc.spec
- require proper version of compiler in libstd++-devel subpackage
[packages/gcc.git] / gcc.spec
... / ...
CommitLineData
1#
2# Conditional build:
3# _without_ada - build without ADA support
4# _without_java - build without Java support
5# _without_objc - build without objc support
6#
7%define DASHED_SNAP %{nil}
8%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
9%define GCC_VERSION 3.2.3
10%define KSI_VERSION 1.0.1.1567
11
12Summary: GNU C Compiler
13Summary(pl): Kompilator C GNU
14Summary(pt_BR): C Compilador GNU (GCC)
15Name: gcc
16Version: %{GCC_VERSION}
17Release: 0.3
18Epoch: 5
19License: GPL
20Group: Development/Languages
21Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
22Source1: ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
23Source2: %{name}-non-english-man-pages.tar.bz2
24Patch1: %{name}-paths.patch
25Patch2: %{name}-ada-no-addr2line.patch
26Patch3: %{name}-ada-no-prefix.o.patch
27Patch4: %{name}-nolocalefiles.patch
28Patch5: %{name}-gcc-page.c.patch
29Patch6: %{name}-info.patch
30Patch7: %{name}-ada-link-new-libgnat.patch
31# -- stolen patches from RH --
32Patch10: gcc32-ada-link.patch
33Patch11: gcc32-attr-visibility.patch
34Patch12: gcc32-attr-visibility2.patch
35Patch13: gcc32-attr-visibility3.patch
36Patch14: gcc32-attr-visibility4.patch
37Patch15: gcc32-attr-visibility5.patch
38Patch16: gcc32-boehm-gc-libs.patch
39Patch17: gcc32-bogus-inline.patch
40Patch18: gcc32-c++-nrv-test.patch
41Patch20: gcc32-c++-tsubst-asm.patch
42Patch21: gcc32-cfg-eh.patch
43Patch22: gcc32-debug-pr7241.patch
44
45Patch24: gcc32-duplicate-decl.patch
46Patch25: gcc32-dwarf2-pr6381.patch
47Patch26: gcc32-dwarf2-pr6436-test.patch
48Patch27: gcc32-fde-merge-compat.patch
49
50Patch29: gcc32-hard-reg-sharing.patch
51Patch30: gcc32-hard-reg-sharing2.patch
52Patch31: gcc32-i386-default-momit-leaf-frame-pointer.patch
53Patch32: gcc32-i386-memtest-test.patch
54Patch33: gcc32-i386-no-default-momit-leaf-frame-pointer.patch
55Patch34: gcc32-i386-pic-label-thunk.patch
56Patch35: gcc32-i386-profile-olfp.patch
57Patch36: gcc32-inline-label.patch
58Patch37: gcc32-java-no-rpath.patch
59Patch38: gcc32-pr6842.patch
60Patch39: gcc32-sparc-sll1.patch
61Patch40: gcc32-test-rh65771.patch
62Patch41: gcc32-test-rotate.patch
63Patch42: gcc32-tls-dwarf2.patch
64Patch43: gcc32-tls.patch
65Patch44: gcc32-tls2.patch
66Patch45: gcc32-tls3.patch
67Patch46: gcc32-tls4.patch
68Patch47: gcc32-tls5.patch
69BuildRequires: autoconf
70BuildRequires: bison
71BuildRequires: fileutils >= 4.0.41
72BuildRequires: gcc
73%{!?_without_ada:BuildRequires: gcc-ada}
74BuildRequires: glibc-devel >= 2.2.5-20
75BuildRequires: perl-devel
76BuildRequires: texinfo >= 4.1
77BuildRequires: zlib-devel
78BuildRequires: gettext-devel
79Requires: binutils >= 2.12.90.0.4
80Requires: cpp = %{GCC_VERSION}
81Requires: libgcc = %{GCC_VERSION}
82Conflicts: glibc-devel < 2.2.5-20
83URL: http://gcc.gnu.org/
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%define _slibdir /lib
87
88%description
89A compiler aimed at integrating all the optimizations and features
90necessary for a high-performance and stable development environment.
91
92%description -l pl
93