]> git.pld-linux.org Git - packages/gcc.git/blame_incremental - gcc.spec
- removed obsolete PR10849 patch (properly fixed now)
[packages/gcc.git] / gcc.spec
... / ...
CommitLineData
1#
2# Conditional build:
3# _without_ada - build without ADA support
4# _without_java - build without Java support
5# _without_objc - build without objc support
6
7%define DASHED_SNAP %{nil}
8%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
9%define GCC_VERSION 3.3.1
10%define KSI_VERSION 1.1.0.1567
11
12Summary: GNU C Compiler
13Summary(pl): Kompilator C GNU
14Summary(pt_BR): C Compilador GNU (GCC)
15Name: gcc
16Version: %{GCC_VERSION}
17Release: 1
18Epoch: 5
19License: GPL
20Group: Development/Languages
21Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
22# Source0-md5: 1135a104e9fa36fdf7c663598fab5c40
23Source1: ftp://ftp.pld-linux.org/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
24# Source1-md5: 66f07491b44f06928fd95b0e65bb8cd3
25Source2: http://ep09.kernel.pl/~djrzulf/gcc33/%{name}-non-english-man-pages.tar.bz2
26# Source2-md5: 4736f3422ddfb808423b745629acc321
27Patch0: %{name}-info.patch
28Patch1: %{name}-paths.patch
29Patch2: %{name}-nolocalefiles.patch
30Patch3: %{name}-ada-link-new-libgnat.patch
31# -- stolen patches from RH --
32Patch10: gcc32-ada-link.patch
33Patch11: gcc32-boehm-gc-libs.patch
34Patch12: gcc32-bogus-inline.patch
35Patch13: gcc32-c++-nrv-test.patch
36Patch14: gcc32-c++-tsubst-asm.patch
37Patch15: gcc32-debug-pr7241.patch
38Patch16: gcc32-duplicate-decl.patch
39Patch17: gcc32-dwarf2-pr6381.patch
40Patch18: gcc32-dwarf2-pr6436-test.patch
41Patch19: gcc32-fde-merge-compat.patch
42Patch20: gcc32-i386-memtest-test.patch
43Patch21: gcc32-inline-label.patch
44Patch22: gcc32-java-no-rpath.patch
45Patch23: gcc32-test-rh65771.patch
46Patch24: gcc32-test-rotate.patch
47#Patch25: %{name}-unwind.patch -- obsolete?
48BuildRequires: autoconf
49BuildRequires: binutils >= 2.14
50BuildRequires: bison
51BuildRequires: fileutils >= 4.0.41
52BuildRequires: gcc
53%{!?_without_ada:BuildRequires: gcc-ada}
54BuildRequires: glibc-devel >= 2.2.5-20
55BuildRequires: perl-devel
56BuildRequires: texinfo >= 4.1
57BuildRequires: zlib-devel
58BuildRequires: gettext-devel
59Requires: binutils >= 2.14
60Requires: cpp = %{epoch}:%{GCC_VERSION}
61Requires: libgcc = %{epoch}:%{GCC_VERSION}
62Conflicts: glibc-devel < 2.2.5-20
63URL: http://gcc.gnu.org/
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%define _slibdir /lib
67
68%description
69A compiler aimed at integrating all the optimizations and features
70necessary for a high-performance and stable development environment.
71
72%description -l pl
73