]> git.pld-linux.org Git - packages/gcc.git/blame_incremental - gcc.spec
- another correction of md5sum
[packages/gcc.git] / gcc.spec
... / ...
CommitLineData
1#
2# Conditional build:
3# _without_ada - build without ADA support
4# _without_java - build without Java support
5# _without_objc - build without objc support
6#
7%define DASHED_SNAP %{nil}
8%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
9%define GCC_VERSION 3.2.3
10%define KSI_VERSION 1.0.1.1567
11
12Summary: GNU C Compiler
13Summary(pl): Kompilator C GNU
14Summary(pt_BR): C Compilador GNU (GCC)
15Name: gcc
16Version: %{GCC_VERSION}
17Release: 1
18Epoch: 5
19License: GPL
20Group: Development/Languages
21# Source0-md5: 23d1146d5efa0e0bfad9968dbb418e1e
22Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
23# Source1-md5: 9e4bdd6492a7d7b650599e572169ff7a
24Source1: ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
25# Source2-md5: 4736f3422ddfb808423b745629acc321
26Source2: http://ep09.kernel.pl/~djrzulf/%{name}-non-english-man-pages.tar.bz2
27Patch0: %{name}-info.patch
28Patch1: %{name}-paths.patch
29Patch2: %{name}-ada-no-addr2line.patch
30Patch3: %{name}-ada-no-prefix.o.patch
31Patch4: %{name}-nolocalefiles.patch
32Patch5: %{name}-gcc-page.c.patch
33Patch6: %{name}-ada-link-new-libgnat.patch
34# -- stolen patches from RH --
35Patch10: gcc32-ada-link.patch
36Patch11: gcc32-attr-visibility.patch
37Patch12: gcc32-attr-visibility2.patch
38Patch13: gcc32-attr-visibility3.patch
39Patch14: gcc32-attr-visibility4.patch
40Patch15: gcc32-attr-visibility5.patch
41Patch16: gcc32-boehm-gc-libs.patch
42Patch17: gcc32-bogus-inline.patch
43Patch18: gcc32-c++-nrv-test.patch
44Patch20: gcc32-c++-tsubst-asm.patch
45Patch21: gcc32-cfg-eh.patch
46Patch22: gcc32-debug-pr7241.patch
47
48Patch24: gcc32-duplicate-decl.patch
49Patch25: gcc32-dwarf2-pr6381.patch
50Patch26: gcc32-dwarf2-pr6436-test.patch
51Patch27: gcc32-fde-merge-compat.patch
52
53Patch29: gcc32-hard-reg-sharing.patch
54Patch30: gcc32-hard-reg-sharing2.patch
55Patch31: gcc32-i386-default-momit-leaf-frame-pointer.patch
56Patch32: gcc32-i386-memtest-test.patch
57Patch33: gcc32-i386-no-default-momit-leaf-frame-pointer.patch
58Patch34: gcc32-i386-pic-label-thunk.patch
59Patch35: gcc32-i386-profile-olfp.patch
60Patch36: gcc32-inline-label.patch
61Patch37: gcc32-java-no-rpath.patch
62Patch38: gcc32-pr6842.patch
63Patch39: gcc32-sparc-sll1.patch
64Patch40: gcc32-test-rh65771.patch
65Patch41: gcc32-test-rotate.patch
66Patch42: gcc32-tls-dwarf2.patch
67Patch43: gcc32-tls.patch
68Patch44: gcc32-tls2.patch
69Patch45: gcc32-tls3.patch
70Patch46: gcc32-tls4.patch
71Patch47: gcc32-tls5.patch
72BuildRequires: autoconf
73BuildRequires: bison
74BuildRequires: fileutils >= 4.0.41
75BuildRequires: gcc
76%{!?_without_ada:BuildRequires: gcc-ada}
77BuildRequires: glibc-devel >= 2.2.5-20
78BuildRequires: perl-devel
79BuildRequires: texinfo >= 4.1
80BuildRequires: zlib-devel
81BuildRequires: gettext-devel
82Requires: binutils >= 2.12.90.0.4
83Requires: cpp = %{GCC_VERSION}
84Requires: libgcc = %{GCC_VERSION}
85Conflicts: glibc-devel < 2.2.5-20
86URL: http://gcc.gnu.org/
87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89%define _slibdir /lib
90
91%description
92A compiler aimed at integrating all the optimizations and features
93necessary for a high-performance and stable development environment.
94
95%description -l pl
96