]> git.pld-linux.org Git - packages/frogatto.git/blame_incremental - frogatto.spec
- release 3
[packages/frogatto.git] / frogatto.spec
... / ...
CommitLineData
1Summary: An open-source "platformer" game
2Name: frogatto
3Version: 1.1.1
4Release: 3
5License: GPL v3+
6Group: X11/Applications/Games
7Source0: http://www.frogatto.com/files/%{name}-%{version}.tar.bz2
8# Source0-md5: bf5a2ee4c3254a424766895ff250758b
9Patch0: %{name}-makefile.patch
10Patch1: %{name}-assertion.patch
11URL: http://www.frogatto.com/
12BuildRequires: OpenGL-GLU-devel
13BuildRequires: OpenGL-devel
14BuildRequires: SDL-devel >= 1.2.7
15BuildRequires: SDL_image-devel >= 1.2.0
16BuildRequires: SDL_mixer-devel >= 1.2.0
17BuildRequires: SDL_ttf-devel >= 2.0.8
18BuildRequires: boost-devel >= 1.35.0
19BuildRequires: ccache
20BuildRequires: glew-devel
21BuildRequires: sed >= 4.0
22BuildRequires: zlib-devel
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Frogatto is an open-source "platformer" game, which means you're given
27a cross-section view into the world, and you help a small green fellow
28named Frogatto walk and jump between solid footholds whilst you lead
29him through his story. There's a long history to the genre, so just by
30being in it we inevitably have a lot in common with other games,
31however, we're not trying to clone any specific game.
32
33%prep
34%setup -q
35%patch0 -p1
36%patch1 -p1
37
38# fix linking with our boost libs
39%{__sed} -i 's,-mt,,g' Makefile
40
41# set proper paths
42%{__sed} -i 's,data/,%{_datadir}/frogatto/data/,g' `find -name "*.[ch]pp" -o -name "*.po*" -o -name "*.cfg"`
43%{__sed} -i 's,./images/,%{_datadir}/frogatto/images/,g' `find -name "*.cpp"`
44%{__sed} -i 's,./locale/,%{_datadir}/locale/,g' src/i18n.cpp
45%{__sed} -i 's,music/,%{_datadir}/frogatto/music/,g' src/sound.cpp
46%{__sed} -i 's,sounds/,%{_datadir}/frogatto/sounds/,g' src/sound.cpp
47
48%build
49%{__make} \
50 CXX="%{__cxx}" \
51 OPT="%{rpmcxxflags}" \
52 LDFLAGS="%{rpmldflags}"
53
54%install
55rm -rf $RPM_BUILD_ROOT
56install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/frogatto,%{_datadir}/locale}
57
58cp -a game $RPM_BUILD_ROOT%{_bindir}/frogatto
59cp -a data $RPM_BUILD_ROOT%{_datadir}/frogatto
60cp -a images $RPM_BUILD_ROOT%{_datadir}/frogatto
61cp -a locale/* $RPM_BUILD_ROOT%{_datadir}/locale
62cp -a music $RPM_BUILD_ROOT%{_datadir}/frogatto
63cp -a sounds $RPM_BUILD_ROOT%{_datadir}/frogatto
64
65%find_lang %{name} --all-name
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files -f %{name}.lang
71%defattr(644,root,root,755)
72%doc CHANGELOG
73%attr(755,root,root) %{_bindir}/frogatto
74%{_datadir}/frogatto
This page took 0.053833 seconds and 4 git commands to generate.