]> git.pld-linux.org Git - packages/fontconfig.git/blame_incremental - fontconfig.spec
- up to 2.10.1
[packages/fontconfig.git] / fontconfig.spec
... / ...
CommitLineData
1#
2# Conditional build
3%bcond_without static_libs # don't build static library
4%bcond_without doc
5#
6Summary: Font configuration and customization tools
7Summary(pl.UTF-8): Narzędzia do konfigurowania fontów
8Summary(pt_BR.UTF-8): Ferramentas para configuração e customização do acesso a fontes
9Name: fontconfig
10Version: 2.10.1
11Release: 1
12Epoch: 1
13License: MIT
14Group: Libraries
15Source0: http://fontconfig.org/release/%{name}-%{version}.tar.gz
16# Source0-md5: c94e380eea42f2f23ca9537035ef1899
17Source1: %{name}-lcd-filter.conf
18Patch0: %{name}-blacklist.patch
19Patch1: %{name}-bitstream-cyberbit.patch
20URL: http://fontconfig.org/
21BuildRequires: autoconf
22BuildRequires: automake
23%if %{with doc}
24BuildRequires: docbook-dtd31-sgml
25BuildRequires: docbook-dtd41-sgml
26BuildRequires: docbook-utils >= 0.6.13-3
27%endif
28BuildRequires: ed
29BuildRequires: expat-devel
30BuildRequires: freetype-devel >= 2.1.5
31BuildRequires: libtool
32BuildRequires: pkgconfig
33Requires: %{name}-libs = %{epoch}:%{version}-%{release}
34Requires: freetype >= 2.1.5
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Fontconfig is designed to locate fonts within the system and select
39them according to requirements specified by applications.
40
41This package contains tools and documentation.
42
43%description -l pl.UTF-8
44Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
45systemie i wybierania ich w zależności od potrzeb aplikacji.
46
47Paket ten zawiera programy narzędziowe i dokumentację.
48
49%description -l pt_BR.UTF-8
50Fontconfig é uma biblioteca para configuração e customização do acesso
51a fontes.
52
53Este pacote contém as ferramentas e documentação.
54
55%package libs
56Summary: Font configuration and customization library
57Summary(pl.UTF-8): Biblioteka do konfigurowania fontów
58Summary(pt_BR.UTF-8): Biblioteca para configuração e customização do acesso a fontes
59Group: Libraries
60Requires: freetype >= 2.1.5
61Provides: XFree86-fontconfig
62Obsoletes: XFree86-fontconfig
63Conflicts: fontconfig <= 1:2.2.98-1
64
65%description libs
66Fontconfig is designed to locate fonts within the system and select
67them according to requirements specified by applications.
68
69%description libs -l pl.UTF-8
70Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
71systemie i wybierania ich w zależności od potrzeb aplikacji.
72
73%description libs -l pt_BR.UTF-8
74Fontconfig é uma biblioteca para configuração e customização do acesso
75a fontes.
76
77%package devel
78Summary: Font configuration and customization library - development files
79Summary(pl.UTF-8): Biblioteka do konfigurowania fontów - pliki dla programistów
80Summary(pt_BR.UTF-8): Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
81Group: Development/Libraries
82Requires: %{name}-libs = %{epoch}:%{version}-%{release}
83Requires: expat-devel
84Requires: freetype-devel >= 2.1.5
85Provides: XFree86-fontconfig-devel
86Obsoletes: XFree86-fontconfig-devel
87
88%description devel
89Fontconfig is designed to locate fonts within the system and select
90them according to requirements specified by applications.
91
92This package contains the header files needed to develop programs that
93use these fontconfig.
94
95%description devel -l pl.UTF-8
96Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
97systemie i wybierania ich w zależności od potrzeb aplikacji.
98
99Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
100programów korzystających z biblioteki fontconfig.
101
102%description devel -l pt_BR.UTF-8
103Fontconfig é uma biblioteca para configuração e customização do acesso
104a fontes.
105
106Este pacote contém arquivos de desenvolvimento necessários à criação
107de extensões baseadas na biblioteca fontconfig.
108
109%package static
110Summary: Static font configuration and customization library
111Summary(pl.UTF-8): Statyczna biblioteka do konfigurowania fontów
112Summary(pt_BR.UTF-8): Biblioteca estática para configuração e customização do acesso a fontes
113Group: Development/Libraries
114Requires: %{name}-devel = %{epoch}:%{version}-%{release}
115Provides: XFree86-fontconfig-static
116Obsoletes: XFree86-fontconfig-static
117
118%description static
119This package contains static version of fontconfig library.
120
121%description static -l pl.UTF-8
122Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
123
124%description static -l pt_BR.UTF-8
125Este pacote contém a biblioteca estática do fontconfig
126
127%prep
128%setup -q
129%patch0 -p1
130%patch1 -p1
131
132%build
133%{__libtoolize}
134%{__aclocal}
135%{__autoconf}
136%{__autoheader}
137%{__automake}
138%configure \
139 --%{?with_doc:en}%{!?with_doc:dis}able-docs \
140 --disable-silent-rules \
141 %{!?with_static_libs:--disable-static}
142%{__make}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
147
148%{__make} install \
149 DESTDIR=$RPM_BUILD_ROOT \
150 htmldoc_DATA= \
151 doc_DATA=
152
153install %{SOURCE1} \
154 $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
155
156ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
157
158cp -f conf.d/README README.confd
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%pretrans
164# this needs to be a symlink
165if [ -d "%{_sysconfdir}/fonts/conf.avail" ]; then
166 umask 022
167 mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
168fi
169
170%post
171umask 022
172HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
173
174%post libs -p /sbin/ldconfig
175%postun libs -p /sbin/ldconfig
176
177%files
178%defattr(644,root,root,755)
179%doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
180%dir %{_sysconfdir}/fonts
181%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
182%dir %{_datadir}/xml/%{name}
183%{_datadir}/xml/%{name}/fonts.dtd
184%{_sysconfdir}/fonts/conf.avail
185%dir %{_datadir}/%{name}/conf.avail
186%{_datadir}/%{name}/conf.avail/*.conf
187%dir %{_sysconfdir}/fonts/conf.d
188%{_sysconfdir}/fonts/conf.d/README
189%config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
190%attr(755,root,root) %{_bindir}/fc-cache
191%attr(755,root,root) %{_bindir}/fc-cat
192%attr(755,root,root) %{_bindir}/fc-list
193%attr(755,root,root) %{_bindir}/fc-match
194%attr(755,root,root) %{_bindir}/fc-query
195%attr(755,root,root) %{_bindir}/fc-pattern
196%attr(755,root,root) %{_bindir}/fc-scan
197%if %{with doc}
198%{_mandir}/man1/fc-*.1*
199%{_mandir}/man5/fonts-conf.5*
200%endif
201/var/cache/fontconfig
202
203%files libs
204%defattr(644,root,root,755)
205%attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
206%attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
207
208%files devel
209%defattr(644,root,root,755)
210%doc doc/fontconfig-devel/*.html
211%attr(755,root,root) %{_libdir}/libfontconfig.so
212%{_libdir}/libfontconfig.la
213%{_includedir}/fontconfig
214%{_pkgconfigdir}/fontconfig.pc
215%if %{with doc}
216%{_mandir}/man3/Fc*.3*
217%endif
218
219%if %{with static_libs}
220%files static
221%defattr(644,root,root,755)
222%{_libdir}/libfontconfig.a
223%endif
This page took 0.035775 seconds and 4 git commands to generate.