]> git.pld-linux.org Git - packages/eeze.git/blame_incremental - eeze.spec
- updated to 1.7.6
[packages/eeze.git] / eeze.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
5%define ecore_ver 1.7.6
6%define eet_ver 1.7.6
7%define eina_ver 1.7.6
8
9Summary: Library for manipulating devices through udev
10Summary(pl.UTF-8): Biblioteka do operowania urządzeniami korzystająca z udev
11Name: eeze
12Version: 1.7.6
13Release: 1
14License: BSD
15Group: Libraries
16Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17# Source0-md5: 911911b27c1a38c6d66ccfae805ee042
18URL: http://trac.enlightenment.org/e/wiki/Eeze
19BuildRequires: autoconf >= 2.52
20BuildRequires: automake >= 1.6
21BuildRequires: ecore-con-devel >= %{ecore_ver}
22BuildRequires: ecore-devel >= %{ecore_ver}
23BuildRequires: ecore-file-devel >= %{ecore_ver}
24BuildRequires: eet-devel >= %{eet_ver}
25BuildRequires: eina-devel >= %{eina_ver}
26BuildRequires: libmount-devel >= 2.18.0
27BuildRequires: libtool
28BuildRequires: udev-devel >= 1:148
29BuildRequires: pkgconfig >= 1:0.22
30Requires: ecore >= %{ecore_ver}
31Requires: eet >= %{eet_ver}
32Requires: eina >= %{eina_ver}
33Requires: libmount >= 2.18.0
34Requires: udev-libs >= 1:148
35Obsoletes: enlightenment-utils-eeze
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Eeze is a library for manipulating devices through udev with a simple
40and fast API. It interfaces directly with libudev, avoiding such
41middleman daemons as udisks/upower or hal, to immediately gather
42device information the instant it becomes known to the system. This
43can be used to determine such things as:
44 - If a CD-ROM has a disk inserted
45 - The temperature of a cpu core
46 - The remaining power left in a battery
47 - The current power consumption of various parts
48 - Monitor in realtime the status of peripheral devices.
49
50Each of the above examples can be performed by using only a single
51eeze function, as one of the primary focuses of the library is to
52reduce the complexity of managing devices.
53
54%description -l pl.UTF-8
55Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
56szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
57takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
58natychmiast, kiedy staną się znane w systemie. Może to służyć do
59określania rzeczy takich jak:
60 - włożenie płyty CD
61 - termperatura rdzenia procesora
62 - pozostała pojemność baterii
63 - aktualne zużycie energii przez różne elementy
64 - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
65
66Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
67funkcji eeze, jako że jedną z głównych idei biblioteki jest
68ograniczenie skomplikowania zarządzania urządzeniami.
69
70%package devel
71Summary: Eeze header files
72Summary(pl.UTF-8): Pliki nagłówkowe Eeze
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
75Requires: ecore-devel >= %{ecore_ver}
76Requires: eina-devel >= %{eina_ver}
77Requires: udev-devel >= 1:148
78
79%description devel
80Header files for Eeze.
81
82%description devel -l pl.UTF-8
83Pliki nagłówkowe Eeze.
84
85%package static
86Summary: Static Eeze library
87Summary(pl.UTF-8): Statyczna biblioteka Eeze
88Group: Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90
91%description static
92Static Eeze library.
93
94%description static -l pl.UTF-8
95Statyczna biblioteka Eeze.
96
97%prep
98%setup -q
99
100%build
101%{__libtoolize}
102%{__aclocal} -I m4
103%{__autoconf}
104%{__autoheader}
105%{__automake}
106%configure \
107 --disable-silent-rules \
108 %{!?with_static_libs:--disable-static} \
109 --with-eject=/usr/bin/eject \
110 --with-mount=/bin/mount \
111 --with-umount=/bin/umount
112%{__make}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(644,root,root,755)
128%doc AUTHORS COPYING ChangeLog NEWS README TODO
129%attr(755,root,root) %{_bindir}/eeze_disk_ls
130%attr(755,root,root) %{_bindir}/eeze_mount
131%attr(755,root,root) %{_bindir}/eeze_scanner
132%attr(755,root,root) %{_bindir}/eeze_umount
133%attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
134%attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
135
136%files devel
137%defattr(644,root,root,755)
138%attr(755,root,root) %{_libdir}/libeeze.so
139%{_libdir}/libeeze.la
140%{_includedir}/eeze-1
141%{_pkgconfigdir}/eeze.pc
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libeeze.a
147%endif
This page took 0.071108 seconds and 4 git commands to generate.