]> git.pld-linux.org Git - packages/curl.git/blame_incremental - curl.spec
- updated for 7.16.2
[packages/curl.git] / curl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with ares # with c-ares (asynchronous DNS operations) library (disables IPv6)
4%bcond_without ssh # without SSH support
5%bcond_without ssl # without SSL support
6%bcond_without kerberos5 # without MIT Kerberos 5 support
7#
8Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
9Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
10Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
11Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
12Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
13Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
14Name: curl
15Version: 7.16.1
16Release: 2
17License: MIT-like
18Group: Applications/Networking
19Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
20# Source0-md5: acdab0b0467c55e10ed02d2afed80575
21Patch0: %{name}-no_strip.patch
22Patch1: %{name}-ac.patch
23URL: http://curl.haxx.se/
24BuildRequires: autoconf >= 2.57
25BuildRequires: automake
26%{?with_ares:BuildRequires: c-ares-devel}
27%{?with_kerberos5:BuildRequires: krb5-devel}
28BuildRequires: libidn-devel >= 0.4.1
29%{?with_ssh:BuildRequires: libssh2-devel}
30BuildRequires: libtool
31%{?with_ssl:BuildRequires: openssl-devel >= 0.9.7d}
32BuildRequires: zlib-devel
33Requires: %{name}-libs = %{version}-%{release}
34Requires: libidn >= 0.4.1
35Requires: openssl-tools >= 0.9.7d
36Obsoletes: libcurl2
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40cURL is a tool for getting files with URL syntax, supporting FTP,
41HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
42POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
43cookies, user+password authentication and a busload of other useful
44tricks. The main use for curl is when you want to get or send files
45automatically to or from a site using one of the supported protocols.
46
47cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48Dict servers, using any of the supported protocols. cURL is designed
49to work without user interaction or any kind of interactivity. cURL
50offers many useful capabilities, like proxy support, user
51authentication, FTP upload, HTTP post, and file transfer resume.
52
53%description -l pl.UTF-8
54cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
55HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
56HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
57oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
58użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
59się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
60pliki z/na serwer używając jednego z dostępnych protokołów.
61%{?with_ssl:Ten pakiet obsługuje także SSL.}
62
63%description -l pt_BR.UTF-8
64Curl é um cliente para baixar/enviar arquivos de/para servidores
65usando um dos protocolos suportados. É projetado para funcionar sem a
66interação do usuário.
67
68Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
69continuar transferências interrompidas, e mais...
70
71%description -l ru.UTF-8
72curl - это клиент с множеством поддерживаемых протоколов для получения
73файлов с серверов, спроектированный для работы как в неинтерактивном
74режиме, так и с возможностью диалога с пользователем.
75
76curl поддерживает много полезных возможностей, среди которых поддержка
77прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
78POST, восстановление прерванной пересылки и многое другое.
79
80curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
81файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
82режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
83
84curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
85прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
86в╕дновлення перервано╖ пересилки та багато ╕ншого.
87
88%package libs
89Summary: curl library
90Summary(pl.UTF-8): Biblioteka curl
91Group: Libraries
92
93%description libs
94curl library.
95
96%description libs -l pl.UTF-8
97Biblioteka curl.
98
99%package devel
100Summary: Header files and development documentation for curl library
101Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
102Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
103Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
104Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
105Group: Development/Libraries
106Requires: %{name}-libs = %{version}-%{release}
107%{?with_ares:Requires: c-ares-devel}
108%{?with_kerberos5:Requires: krb5-devel}
109Requires: libidn-devel >= 0.4.1
110%{?with_ssl:Requires: openssl-devel >= 0.9.7c}
111Requires: zlib-devel
112Obsoletes: libcurl2-devel
113
114%description devel
115Header files and development documentation for curl library.
116
117%description devel -l pl.UTF-8
118Pliki nagłówkowe i dokumentacja do biblioteki curl.
119
120%description devel -l pt_BR.UTF-8
121Arquivos de cabeçalho e bibliotecas de desenvolvimento.
122
123%description devel -l ru.UTF-8
124Этот пакет содержит файлы, необходимые для разработки программ с
125использованием библиотеки curl.
126
127%description devel -l uk.UTF-8
128Цей пакет містить файли, необхідні для розробки програм з
129використанням бібліотеки curl.
130
131%package static
132Summary: Static version of curl library
133Summary(pl.UTF-8): Statyczna wersja biblioteki curl
134Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
135Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
136Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
137Group: Development/Libraries
138Requires: %{name}-devel = %{version}-%{release}
139
140%description static
141Static version of curl library.
142
143%description static -l pl.UTF-8
144Statyczna wersja biblioteki curl.
145
146%description static -l pt_BR.UTF-8
147Bibliotecas estáticas para desenvolvimento com o curl.
148
149%description static -l ru.UTF-8
150Этот пакет содержит статическую библиотеку для разработки программ с
151использованием библиотеки curl.
152
153%description static -l uk.UTF-8
154Цей пакет містить статичну бібліотеку для розробки програм з
155використанням бібліотеки curl.
156
157%prep
158%setup -q
159%patch0 -p1
160%patch1 -p1
161
162%build
163%{__libtoolize}
164%{__aclocal}
165%{__autoconf}
166%{__autoheader}
167%{__automake}
168%configure \
169 %{?with_ssl:--with-ssl=%{_prefix}} \
170 %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
171 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
172 %{?with_ares:--enable-ares=%{_prefix}} \
173 --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
174
175%{__make}
176
177%install
178rm -rf $RPM_BUILD_ROOT
179
180%{__make} install \
181 DESTDIR=$RPM_BUILD_ROOT
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186%post libs -p /sbin/ldconfig
187%postun libs -p /sbin/ldconfig
188
189%files
190%defattr(644,root,root,755)
191%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
192%attr(755,root,root) %{_bindir}/curl
193%{_mandir}/man1/curl.1*
194
195%files libs
196%defattr(644,root,root,755)
197%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
198
199%files devel
200%defattr(644,root,root,755)
201%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
202%attr(755,root,root) %{_bindir}/curl-config
203%attr(755,root,root) %{_libdir}/libcurl.so
204%{_libdir}/libcurl.la
205%{_includedir}/curl
206%{_pkgconfigdir}/libcurl.pc
207%{_mandir}/man1/curl-config.1*
208%{_mandir}/man3/*curl*.3*
209
210%files static
211%defattr(644,root,root,755)
212%{_libdir}/libcurl.a
This page took 0.064275 seconds and 4 git commands to generate.