]> git.pld-linux.org Git - packages/curl.git/blame_incremental - curl.spec
- up to 7.20.1
[packages/curl.git] / curl.spec
... / ...
CommitLineData
1# TODO
2# - VMware needs curl with ares
3#
4# Conditional build:
5%bcond_without ares # with c-ares (asynchronous DNS operations) library (c-ares may not work properly with ipv6)
6%bcond_without ssh # without SSH support
7%bcond_without ssl # without SSL support
8%bcond_without gnutls # use GnuTLS instead of OpenSSL
9%bcond_without kerberos5 # without Heimdal Kerberos 5 support
10#
11Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
12Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
13Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
14Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
15Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
16Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
17Name: curl
18Version: 7.20.1
19Release: 1
20License: MIT-like
21Group: Applications/Networking
22Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
23# Source0-md5: e259b58aab40dd4e7b72f52e96a498e4
24Patch0: %{name}-no_strip.patch
25Patch1: %{name}-ac.patch
26Patch2: %{name}-pc.patch
27Patch3: %{name}-krb5flags.patch
28URL: http://curl.haxx.se/
29BuildRequires: autoconf >= 2.57
30BuildRequires: automake
31%{?with_ares:BuildRequires: c-ares-devel}
32%{?with_kerberos5:BuildRequires: heimdal-devel}
33BuildRequires: libidn-devel >= 0.4.1
34%{?with_ssh:BuildRequires: libssh2-devel >= 0.16}
35BuildRequires: libtool
36BuildRequires: openldap-devel
37%if %{with ssl}
38%if %{with gnutls}
39BuildRequires: gnutls-devel
40%else
41BuildRequires: openssl-devel >= 0.9.7d
42%endif
43%endif
44BuildRequires: tar >= 1:1.22
45BuildRequires: zlib-devel
46Requires: %{name}-libs = %{version}-%{release}
47Requires: libidn >= 0.4.1
48%{?with_ssh:Requires: libssh2 >= 0.16}
49Requires: openssl-tools >= 0.9.7d
50Obsoletes: libcurl2
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54cURL is a tool for getting files with URL syntax, supporting FTP,
55HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
56POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
57cookies, user+password authentication and a busload of other useful
58tricks. The main use for curl is when you want to get or send files
59automatically to or from a site using one of the supported protocols.
60
61cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
62Dict servers, using any of the supported protocols. cURL is designed
63to work without user interaction or any kind of interactivity. cURL
64offers many useful capabilities, like proxy support, user
65authentication, FTP upload, HTTP post, and file transfer resume.
66
67%description -l pl.UTF-8
68cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
69HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
70HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
71oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
72użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
73się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
74pliki z/na serwer używając jednego z dostępnych protokołów.
75%{?with_ssl:Ten pakiet obsługuje także SSL.}
76
77%description -l pt_BR.UTF-8
78Curl é um cliente para baixar/enviar arquivos de/para servidores
79usando um dos protocolos suportados. É projetado para funcionar sem a
80interação do usuário.
81
82Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
83continuar transferências interrompidas, e mais...
84
85%description -l ru.UTF-8
86curl - это клиент с множеством поддерживаемых протоколов для получения
87файлов с серверов, спроектированный для работы как в неинтерактивном
88режиме, так и с возможностью диалога с пользователем.
89
90curl поддерживает много полезных возможностей, среди которых поддержка
91прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
92POST, восстановление прерванной пересылки и многое другое.
93
94curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
95файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
96режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
97
98curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
99прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
100в╕дновлення перервано╖ пересилки та багато ╕ншого.
101
102%package libs
103Summary: curl library
104Summary(pl.UTF-8): Biblioteka curl
105Group: Libraries
106Suggests: ca-certificates
107Conflicts: ca-certificates < 20080809-4
108
109%description libs
110curl library.
111
112%description libs -l pl.UTF-8
113Biblioteka curl.
114
115%package devel
116Summary: Header files and development documentation for curl library
117Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
118Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
119Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
120Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
121Group: Development/Libraries
122Requires: %{name}-libs = %{version}-%{release}
123%{?with_ares:Requires: c-ares-devel}
124%{?with_kerberos5:Requires: heimdal-devel}
125Requires: libidn-devel >= 0.4.1
126%{?with_ssh:Requires: libssh2-devel >= 0.16}
127%if %{with ssl}
128%if %{with gnutls}
129Requires: gnutls-devel
130%else
131Requires: openssl-devel >= 0.9.7c
132%endif
133%endif
134Requires: zlib-devel
135Obsoletes: libcurl2-devel
136
137%description devel
138Header files and development documentation for curl library.
139
140%description devel -l pl.UTF-8
141Pliki nagłówkowe i dokumentacja do biblioteki curl.
142
143%description devel -l pt_BR.UTF-8
144Arquivos de cabeçalho e bibliotecas de desenvolvimento.
145
146%description devel -l ru.UTF-8
147Этот пакет содержит файлы, необходимые для разработки программ с
148использованием библиотеки curl.
149
150%description devel -l uk.UTF-8
151Цей пакет містить файли, необхідні для розробки програм з
152використанням бібліотеки curl.
153
154%package static
155Summary: Static version of curl library
156Summary(pl.UTF-8): Statyczna wersja biblioteki curl
157Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
158Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
159Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
160Group: Development/Libraries
161Requires: %{name}-devel = %{version}-%{release}
162
163%description static
164Static version of curl library.
165
166%description static -l pl.UTF-8
167Statyczna wersja biblioteki curl.
168
169%description static -l pt_BR.UTF-8
170Bibliotecas estáticas para desenvolvimento com o curl.
171
172%description static -l ru.UTF-8
173Этот пакет содержит статическую библиотеку для разработки программ с
174использованием библиотеки curl.
175
176%description static -l uk.UTF-8
177Цей пакет містить статичну бібліотеку для розробки програм з
178використанням бібліотеки curl.
179
180%prep
181%setup -q
182%patch0 -p1
183%patch1 -p1
184%patch2 -p1
185%patch3 -p1
186
187%build
188%{__libtoolize}
189%{__aclocal} -I m4
190%{__autoconf}
191%{__autoheader}
192%{__automake}
193%configure \
194 ac_cv_header_gss_h=no \
195%if %{with ssl}
196 --with-ca-bundle=/etc/certs/ca-certificates.crt \
197%if %{with gnutls}
198 --with-gnutls=%{_prefix} --without-ssl \
199%else
200 --with-ssl=%{_prefix} \
201%endif
202%endif
203 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
204 %{?with_ares:--enable-ares=%{_prefix}} \
205 --enable-ldaps \
206 --enable-ipv6
207
208%{__make}
209
210%install
211rm -rf $RPM_BUILD_ROOT
212
213%{__make} install \
214 DESTDIR=$RPM_BUILD_ROOT
215
216%clean
217rm -rf $RPM_BUILD_ROOT
218
219%post libs -p /sbin/ldconfig
220%postun libs -p /sbin/ldconfig
221
222%files
223%defattr(644,root,root,755)
224%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
225%attr(755,root,root) %{_bindir}/curl
226%{_mandir}/man1/curl.1*
227
228%files libs
229%defattr(644,root,root,755)
230%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
231%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
232
233%files devel
234%defattr(644,root,root,755)
235%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
236%attr(755,root,root) %{_bindir}/curl-config
237%attr(755,root,root) %{_libdir}/libcurl.so
238%{_libdir}/libcurl.la
239%{_includedir}/curl
240%{_pkgconfigdir}/libcurl.pc
241%{_mandir}/man1/curl-config.1*
242%{_mandir}/man3/curl_*.3*
243%{_mandir}/man3/libcurl*.3*
244
245%files static
246%defattr(644,root,root,755)
247%{_libdir}/libcurl.a
This page took 0.039125 seconds and 4 git commands to generate.