]> git.pld-linux.org Git - packages/curl.git/blame_incremental - curl.spec
- release 4
[packages/curl.git] / curl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with ares # with c-ares (asynchronous DNS operations) library (disables IPv6)
4%bcond_without ssh # without SSH support
5%bcond_without ssl # without SSL support
6%bcond_without kerberos5 # without MIT Kerberos 5 support
7#
8Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
9Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
10Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
11Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
12Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
13Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
14Name: curl
15Version: 7.17.1
16Release: 4
17License: MIT-like
18Group: Applications/Networking
19Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
20# Source0-md5: 1fa635d1dfde8337c98c82749d75c1de
21Patch0: %{name}-no_strip.patch
22Patch1: %{name}-ac.patch
23Patch2: %{name}-pc.patch
24URL: http://curl.haxx.se/
25BuildRequires: autoconf >= 2.57
26BuildRequires: automake
27%{?with_ares:BuildRequires: c-ares-devel}
28%{?with_kerberos5:BuildRequires: krb5-devel}
29BuildRequires: libidn-devel >= 0.4.1
30%{?with_ssh:BuildRequires: libssh2-devel >= 0.16}
31BuildRequires: libtool
32BuildRequires: openldap-devel
33%{?with_ssl:BuildRequires: openssl-devel >= 0.9.7d}
34BuildRequires: zlib-devel
35Requires: %{name}-libs = %{version}-%{release}
36Requires: libidn >= 0.4.1
37%{?with_ssh:Requires: libssh2 >= 0.16}
38Requires: openssl-tools >= 0.9.7d
39Obsoletes: libcurl2
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43cURL is a tool for getting files with URL syntax, supporting FTP,
44HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
45POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
46cookies, user+password authentication and a busload of other useful
47tricks. The main use for curl is when you want to get or send files
48automatically to or from a site using one of the supported protocols.
49
50cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
51Dict servers, using any of the supported protocols. cURL is designed
52to work without user interaction or any kind of interactivity. cURL
53offers many useful capabilities, like proxy support, user
54authentication, FTP upload, HTTP post, and file transfer resume.
55
56%description -l pl.UTF-8
57cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
58HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
59HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
60oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
61użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
62się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
63pliki z/na serwer używając jednego z dostępnych protokołów.
64%{?with_ssl:Ten pakiet obsługuje także SSL.}
65
66%description -l pt_BR.UTF-8
67Curl é um cliente para baixar/enviar arquivos de/para servidores
68usando um dos protocolos suportados. É projetado para funcionar sem a
69interação do usuário.
70
71Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
72continuar transferências interrompidas, e mais...
73
74%description -l ru.UTF-8
75curl - это клиент с множеством поддерживаемых протоколов для получения
76файлов с серверов, спроектированный для работы как в неинтерактивном
77режиме, так и с возможностью диалога с пользователем.
78
79curl поддерживает много полезных возможностей, среди которых поддержка
80прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
81POST, восстановление прерванной пересылки и многое другое.
82
83curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
84файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
85режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
86
87curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
88прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
89в╕дновлення перервано╖ пересилки та багато ╕ншого.
90
91%package libs
92Summary: curl library
93Summary(pl.UTF-8): Biblioteka curl
94Group: Libraries
95
96%description libs
97curl library.
98
99%description libs -l pl.UTF-8
100Biblioteka curl.
101
102%package devel
103Summary: Header files and development documentation for curl library
104Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
105Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
106Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
107Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
108Group: Development/Libraries
109Requires: %{name}-libs = %{version}-%{release}
110%{?with_ares:Requires: c-ares-devel}
111%{?with_kerberos5:Requires: krb5-devel}
112Requires: libidn-devel >= 0.4.1
113%{?with_ssh:Requires: libssh2-devel >= 0.16}
114%{?with_ssl:Requires: openssl-devel >= 0.9.7c}
115Requires: zlib-devel
116Obsoletes: libcurl2-devel
117
118%description devel
119Header files and development documentation for curl library.
120
121%description devel -l pl.UTF-8
122Pliki nagłówkowe i dokumentacja do biblioteki curl.
123
124%description devel -l pt_BR.UTF-8
125Arquivos de cabeçalho e bibliotecas de desenvolvimento.
126
127%description devel -l ru.UTF-8
128Этот пакет содержит файлы, необходимые для разработки программ с
129использованием библиотеки curl.
130
131%description devel -l uk.UTF-8
132Цей пакет містить файли, необхідні для розробки програм з
133використанням бібліотеки curl.
134
135%package static
136Summary: Static version of curl library
137Summary(pl.UTF-8): Statyczna wersja biblioteki curl
138Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
139Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
140Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
141Group: Development/Libraries
142Requires: %{name}-devel = %{version}-%{release}
143
144%description static
145Static version of curl library.
146
147%description static -l pl.UTF-8
148Statyczna wersja biblioteki curl.
149
150%description static -l pt_BR.UTF-8
151Bibliotecas estáticas para desenvolvimento com o curl.
152
153%description static -l ru.UTF-8
154Этот пакет содержит статическую библиотеку для разработки программ с
155использованием библиотеки curl.
156
157%description static -l uk.UTF-8
158Цей пакет містить статичну бібліотеку для розробки програм з
159використанням бібліотеки curl.
160
161%prep
162%setup -q
163%patch0 -p1
164%patch1 -p1
165%patch2 -p1
166
167%build
168%{__libtoolize}
169%{__aclocal}
170%{__autoconf}
171%{__autoheader}
172%{__automake}
173%configure \
174 ac_cv_header_gss_h=no \
175 %{?with_ssl:--with-ssl=%{_prefix}} \
176 %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
177 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
178 %{?with_ares:--enable-ares=%{_prefix}} \
179 --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
180
181%{__make}
182
183%install
184rm -rf $RPM_BUILD_ROOT
185
186%{__make} install \
187 DESTDIR=$RPM_BUILD_ROOT
188
189%clean
190rm -rf $RPM_BUILD_ROOT
191
192%post libs -p /sbin/ldconfig
193%postun libs -p /sbin/ldconfig
194
195%files
196%defattr(644,root,root,755)
197%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
198%attr(755,root,root) %{_bindir}/curl
199%{_mandir}/man1/curl.1*
200
201%files libs
202%defattr(644,root,root,755)
203%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
204
205%files devel
206%defattr(644,root,root,755)
207%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
208%attr(755,root,root) %{_bindir}/curl-config
209%attr(755,root,root) %{_libdir}/libcurl.so
210%{_libdir}/libcurl.la
211%{_includedir}/curl
212%{_pkgconfigdir}/libcurl.pc
213%{_mandir}/man1/curl-config.1*
214%{_mandir}/man3/*curl*.3*
215
216%files static
217%defattr(644,root,root,755)
218%{_libdir}/libcurl.a
This page took 0.085413 seconds and 4 git commands to generate.