]> git.pld-linux.org Git - packages/chromium-browser.git/blame_incremental - chromium-browser.spec
simplify nacl toolchain symlinks setup
[packages/chromium-browser.git] / chromium-browser.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without cups # with cups
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
6%bcond_without gconf # with GConf
7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9%bcond_without libjpegturbo # use libjpeg-turbo features
10%bcond_without nacl # build Native Client support
11%bcond_without pulseaudio # with pulseaudio
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
18%bcond_without system_libexif # system libexif
19%bcond_without system_libmtp # system libmtp
20%bcond_without system_libusb # system libusb-1
21%bcond_without system_libwebp # system libwebp
22%bcond_without system_minizip # system minizip
23%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
24%bcond_without system_speex # system speex
25%bcond_with system_sqlite # system sqlite
26%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
27%bcond_with system_v8 # system v8
28%bcond_without system_libvpx # system libvpx
29%bcond_without system_yasm # system yasm
30%bcond_without system_zlib # system zlib
31%bcond_with tcmalloc # use tcmalloc
32%bcond_without verbose # verbose build (V=1)
33
34%if %{with nacl}
35# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
36# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
37#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
38#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
39#14:51:06 @baggins> as-needed will take care of unneeded lib
40#14:52:03 @baggins> -lssp comes with gcc
41%define _ssp_cflags %{nil}
42%endif
43
44# TODO
45# - check system sqlite linking problems
46# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
47# - use_system_ssl (use_openssl: http://crbug.com/62803)
48# - use_system_ffmpeg && build_ffmpegsumo
49# - use_system_hunspell
50# - use_system_stlport
51# - other defaults: src/build/common.gypi
52# - use_system_libmtp
53# - use_system_libexif
54# - use_system_opus
55# - use_system_libjpeg==1 use_libjpeg_turbo==0
56
57# NOTES:
58# - mute BEEP mixer if you do not want to hear horrible system bell when
59# pressing home/end in url bar or more ^F search results on page.
60# - space considerations:
61# - unpacked sources: ~800MiB
62# - built code: ~1.4GiB (x86_64)
63# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
64# - to look for new tarball, use update-source.sh script
65
66# NOTE TO USERS:
67# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
68# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
69# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
70
71%define gyp_rev 1014
72Summary: A WebKit powered web browser
73Name: chromium-browser
74Version: 24.0.1312.45
75Release: 0.8
76License: BSD, LGPL v2+ (ffmpeg)
77Group: X11/Applications/Networking
78Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
79# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
80Source1: %{name}.default
81Source2: %{name}.sh
82Source3: %{name}.desktop
83Source5: find-lang.sh
84Source6: update-source.sh
85Source7: clean-source.sh
86Source8: get-source.sh
87Source9: master_preferences.json
88#Patch10: system-libs.patch
89Patch1: plugin-searchdirs.patch
90Patch3: disable_dlog_and_dcheck_in_release_builds.patch
91Patch4: path-libpdf.patch
92Patch5: options-support.patch
93Patch6: get-webkit_revision.patch
94Patch7: dlopen_sonamed_gl.patch
95Patch8: chromium_useragent.patch.in
96Patch9: chromium-ppapi.patch
97# https://bugs.gentoo.org/show_bug.cgi?id=393471
98# libjpeg-turbo >= 1.1.90 supports that feature
99Patch11: chromium-revert-jpeg-swizzle-r2.patch
100Patch15: nacl-build-irt.patch
101Patch16: nacl-linkingfix.patch
102Patch18: nacl-no-untar.patch
103Patch19: system-jsoncpp.patch
104Patch21: system-srtp.patch
105Patch22: pulse_fix-157876.patch
106Patch23: no-pnacl.patch
107Patch24: nacl-verbose.patch
108Patch25: gnome3-volume-control.patch
109Patch26: master-prefs-path.patch
110URL: http://www.chromium.org/Home
111%{?with_gconf:BuildRequires: GConf2-devel}
112BuildRequires: OpenGL-GLU-devel
113BuildRequires: alsa-lib-devel
114BuildRequires: atk-devel
115BuildRequires: bison
116BuildRequires: bzip2-devel
117%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
118%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
119%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
120%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
121%{?with_cups:BuildRequires: cups-devel}
122BuildRequires: dbus-glib-devel
123BuildRequires: expat-devel
124%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
125BuildRequires: flex
126BuildRequires: fontconfig-devel
127BuildRequires: glib2-devel
128BuildRequires: gperf
129BuildRequires: gtk+2-devel
130%{?with_kerberos:BuildRequires: heimdal-devel}
131BuildRequires: hicolor-icon-theme
132%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
133BuildRequires: libevent-devel
134%{?with_keyring:BuildRequires: libgnome-keyring-devel}
135BuildRequires: libicu-devel >= 4.6
136%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
137%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
138BuildRequires: libpng-devel
139%{?with_selinux:BuildRequires: libselinux-devel}
140BuildRequires: libstdc++-devel
141%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
142%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
143%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
144BuildRequires: libxml2-devel
145BuildRequires: libxslt-devel
146BuildRequires: lzma
147%{?with_system_minizip:BuildRequires: minizip-devel}
148%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
149%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
150%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
151BuildRequires: nspr-devel
152BuildRequires: nss-devel >= 1:3.12.3
153BuildRequires: pam-devel
154BuildRequires: pango-devel
155BuildRequires: perl-modules
156BuildRequires: pkgconfig
157%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
158BuildRequires: python
159#BuildRequires: python-gyp >= 1-%{gyp_rev}
160BuildRequires: python-modules
161BuildRequires: rpm >= 4.4.9-56
162BuildRequires: rpmbuild(macros) >= 1.453
163%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
164BuildRequires: sqlite3-devel >= 3.6.1
165%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
166BuildRequires: subversion
167BuildRequires: tar >= 1:1.22
168BuildRequires: udev-devel
169BuildRequires: util-linux
170%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
171BuildRequires: which
172BuildRequires: xorg-lib-libXScrnSaver-devel
173BuildRequires: xorg-lib-libXt-devel
174BuildRequires: xorg-lib-libXtst-devel
175BuildRequires: xz
176%{?with_system_yasm:BuildRequires: yasm}
177%{?with_system_zlib:BuildRequires: zlib-devel}
178Requires: browser-plugins >= 2.0
179Requires: desktop-file-utils
180%{?with_system_flac:Requires: flac >= 1.2.1-7}
181Requires: hicolor-icon-theme
182%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
183%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
184Requires: xdg-utils >= 1.0.2-4
185Provides: wwwbrowser
186Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
187Obsoletes: chromium-browser-inspector < 15.0.863.0
188ExclusiveArch: %{ix86} %{x8664} arm
189BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
190
191%define find_lang sh find-lang.sh %{buildroot}
192
193# Usage: gyp_with BCOND_NAME [OPTION_NAME]
194%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
195
196%if %{without debuginfo}
197%define _enable_debug_packages 0
198%endif
199
200%description
201Chromium is an open-source browser project that aims to build a safer,
202faster, and more stable way for all Internet users to experience the
203web.
204
205Chromium serves as a base for Google Chrome, which is Chromium
206rebranded (name and logo) with very few additions such as usage
207tracking and an auto-updater system.
208
209%package l10n
210Summary: chromium-browser language packages
211Group: I18n
212Requires: %{name} = %{version}-%{release}
213
214%description l10n
215Chromium is an open-source browser project that aims to build a safer,
216faster, and more stable way for all Internet users to experience the
217web.
218
219This package contains language packages for 50 languages:
220
221ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
222he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
223pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
224zh-TW
225
226%prep
227%setup -q
228
229# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
230# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
231. ./src/chrome/VERSION
232ver=$MAJOR.$MINOR.$BUILD.$PATCH
233test "$ver" = %{version}
234
235gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
236test "$gyp_rev" = %{gyp_rev} || :
237
238v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
239
240# add chromium and pld to useragent
241%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
242sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
243 -e 's/@BUILD_DIST_NAME@/PLD/g' \
244 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
245 < %{PATCH8} | %{__patch} -p1
246
247%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
248ln -s %{SOURCE7} src
249
250#%patch10 -p1
251%patch1 -p1
252%patch3 -p1
253%patch4 -p1
254%patch5 -p1
255%patch6 -p1
256%patch7 -p1
257%patch15 -p1
258cd src
259%patch9 -p0
260%{!?with_libjpegturbo:%patch11 -p0}
261%patch16 -p1
262%patch19 -p1
263%patch21 -p1
264%patch22 -p1
265%patch25 -p1
266cd ..
267%patch18 -p1
268%patch23 -p1
269%patch24 -p1
270%patch26 -p1
271
272cd src
273
274# Missing gyp files in tarball.
275# https://code.google.com/p/chromium/issues/detail?id=144823
276if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
277 echo "tarball fixed, please remove workaround"
278 exit 1
279fi
280
281install -d chrome/test/data/nacl
282cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
283{
284 'targets': [
285 {
286 'target_name': 'nacl_tests',
287 'type': 'none',
288 },
289 ],
290}
291EOF
292
293sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} %{!?with_system_zlib:zlib=0}
294
295%build
296cd src
297
298%if %{with nacl}
299if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
300# Make symlinks for NaCL
301install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
302
303cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
304__cc='%{__cc}'
305if [ "${__cc}#ccache}" != "$__cc" ]; then
306 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
307 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
308 %{__sed} -i -e '1i#!/bin/sh' gcc g++
309 chmod +x gcc g++
310else
311 ln -s %{_bindir}/x86_64-nacl-gcc gcc
312 ln -s %{_bindir}/x86_64-nacl-g++ g++
313fi
314ln -s %{_bindir}/x86_64-nacl-ar ar
315ln -s %{_bindir}/x86_64-nacl-as as
316ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
317ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
318ln -s %{_bindir}/x86_64-nacl-strip strip
319ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
320ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
321ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
322cd ../../../../..
323fi
324%endif
325
326test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
327test -e Makefile || %{__python} build/gyp_chromium \
328 --format=make \
329 -Goutput_dir=../out \
330 build/all.gyp \
331%ifarch %{ix86}
332 -Dtarget_arch=ia32 \
333%endif
334%ifarch %{x8664}
335 -Dtarget_arch=x64 \
336%endif
337%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
338 -Dno_strict_aliasing=1 -Dgcc_version=44 \
339%endif
340%if %{with sandboxing}
341 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
342 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
343%endif
344 %{!?debug:-Dwerror=} \
345 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
346 %{?with_shared_libs:-Dlibrary=shared_library} \
347 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
348 -Dffmpeg_branding=Chrome \
349 -Dremove_webcore_debug_symbols=1 \
350 -Dproprietary_codecs=1 \
351%if %{with nacl}
352 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
353 -Ddisable_glibc_untar=1 \
354 -Ddisable_newlib_untar=1 \
355 -Ddisable_glibc=1 \
356 -Ddisable_pnacl=1 \
357 -Dbuild_pnacl_newlib=0 \
358%else
359 -Ddisable_pnacl_untar=1 \
360 -Ddisable_nacl=1 \
361%endif
362 %{!?with_sse2:-Ddisable_sse2=1} \
363 %{?with_selinux:-Dselinux=1} \
364 %{gyp_with cups} \
365 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
366 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
367 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
368 %{gyp_with pulseaudio} \
369 %{gyp_with system_flac} \
370 %{gyp_with system_libexif} \
371 %{gyp_with system_libmtp} \
372 %{gyp_with system_libusb} \
373 %{gyp_with system_libvpx} \
374 %{gyp_with system_libwebp} \
375 %{gyp_with system_minizip} \
376 %{gyp_with system_opus} \
377 %{gyp_with system_speex} \
378 %{gyp_with system_sqlite} \
379 %{gyp_with system_v8} \
380 %{gyp_with system_yasm} \
381 %{gyp_with system_zlib} \
382 -Duse_system_bzip2=1 \
383 -Duse_system_expat=1 \
384 -Duse_system_icu=1 \
385 -Duse_system_libevent=1 \
386 -Duse_system_libjpeg=1 \
387 -Duse_system_libpng=1 \
388 -Duse_system_libxml=1 \
389 -Duse_system_libxslt=1 \
390 -Duse_system_xdg_utils=1 \
391 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
392 -Dlinux_use_gold_binary=0 \
393 -Dlinux_use_gold_flags=0
394
395%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
396 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
397 %{?with_verbose:V=1} \
398 CC="%{__cc}" \
399 CXX="%{__cxx}" \
400 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
401 CC.host="%{__cc}" \
402 CXX.host="%{__cxx}" \
403 LDFLAGS.host="%{rpmldflags}" \
404 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
405 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
406
407%install
408rm -rf $RPM_BUILD_ROOT
409install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
410 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
411
412cd out/%{!?debug:Release}%{?debug:Debug}
413cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
414install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
415%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
416cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
417cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
418install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
419install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
420%if %{with ffmpegsumo}
421install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
422%endif
423cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
424cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
425
426%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
427
428%if %{with nacl}
429# Install Native Client files on platforms that support it.
430install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
431install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
432%ifarch %{x8664}
433install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
434%endif
435%ifarch %{ix86}
436install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
437%endif
438%endif
439
440cd -
441
442for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
443 size=${icon##*/product_logo_}
444 size=${size%.png}
445
446 # this will skip non-numeric (22_mono_invert, 22_mono)
447 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
448 test -d "$dir" || continue
449
450 install -d $RPM_BUILD_ROOT$dir
451 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
452done
453
454%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
455# http://code.google.com/p/chromium/issues/detail?id=24507
456gecko-mediaplayer*.so
457EOF
458
459# find locales
460%find_lang %{name}.lang
461# always package en-US
462%{__sed} -i -e '/en-US.pak/d' %{name}.lang
463
464%clean
465rm -rf $RPM_BUILD_ROOT
466
467%post
468%update_icon_cache hicolor
469%update_desktop_database
470%update_browser_plugins
471
472%postun
473if [ "$1" = 0 ]; then
474 %update_icon_cache hicolor
475 %update_browser_plugins
476fi
477
478%files
479%defattr(644,root,root,755)
480%doc src/{AUTHORS,LICENSE}
481%{_browserpluginsconfdir}/browsers.d/%{name}.*
482%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
483%dir %{_sysconfdir}/%{name}
484%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
485%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
486%attr(755,root,root) %{_bindir}/%{name}
487%{_mandir}/man1/%{name}.1*
488%{_desktopdir}/*.desktop
489%{_iconsdir}/hicolor/*/apps/%{name}.png
490%dir %{_libdir}/%{name}
491%{_libdir}/%{name}/chrome*.pak
492%{_libdir}/%{name}/content_resources.pak
493%{_libdir}/%{name}/resources.pak
494%dir %{_libdir}/%{name}/locales
495%{_libdir}/%{name}/locales/en-US.pak
496%dir %{_libdir}/%{name}/resources
497%{_libdir}/%{name}/resources/inspector
498%dir %{_libdir}/%{name}/themes
499%dir %{_libdir}/%{name}/extensions
500%dir %{_libdir}/%{name}/plugins
501%attr(755,root,root) %{_libdir}/%{name}/%{name}
502# These unique permissions are intentional and necessary for the sandboxing
503%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
504
505# ffmpeg libs
506%if %{with ffmpegsumo}
507%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
508%endif
509
510%if %{with nacl}
511%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
512%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
513%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
514%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
515%endif
516
517%files l10n -f %{name}.lang
518%defattr(644,root,root,755)
This page took 0.053733 seconds and 4 git commands to generate.