]> git.pld-linux.org Git - packages/chromium-browser.git/blame_incremental - chromium-browser.spec
clean webp (using system one)
[packages/chromium-browser.git] / chromium-browser.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without cups # with cups
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without gconf # with GConf
6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9%bcond_without libjpegturbo # use libjpeg-turbo features
10%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
11%bcond_without pulseaudio # with pulseaudio
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
16%bcond_without system_flac # system flac
17%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
18%bcond_without system_harfbuzz # system harfbuzz
19%bcond_without system_jsoncpp # system jsoncpp
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
22%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
23%bcond_without system_libwebp # system libwebp
24%bcond_without system_libxnvctrl # system libxnvctrl
25%bcond_with system_mesa # system Mesa
26%bcond_without system_minizip # system minizip
27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
28%bcond_without system_protobuf # system protobuf
29%bcond_without system_re2 # system re2
30%bcond_without system_snappy # system snappy
31%bcond_without system_speex # system speex
32%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
33%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
34%bcond_with system_v8 # system v8
35%bcond_without system_libvpx # system libvpx
36%bcond_without system_yasm # system yasm
37%bcond_without system_zlib # system zlib
38%bcond_without tcmalloc # use tcmalloc
39%bcond_without verbose # verbose build (V=1)
40
41%ifarch %{ix86}
42# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43%undefine with_system_mesa
44%endif
45
46# TODO
47# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
48# - use_system_skia
49# - use_system_ssl (use_openssl: http://crbug.com/62803)
50# - use_system_stlport (android specific)
51# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
52
53# NOTES:
54# - mute BEEP mixer if you do not want to hear horrible system bell when
55# pressing home/end in url bar or more ^F search results on page.
56# - space considerations:
57# - unpacked sources: ~490MiB
58# - built code: ~1.4GiB (x86_64/i686)
59# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
60# - to look for new tarball, use update-source.sh script
61
62%define branch 33.0.1750
63%define basever 117
64#define patchver 107
65%define gyp_rev 1014
66Summary: A WebKit powered web browser
67Name: chromium-browser
68%if "%{?patchver}" != ""
69Version: %{branch}.%{patchver}
70%else
71Version: %{branch}.%{basever}
72%endif
73Release: 1
74License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
75Group: X11/Applications/Networking
76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77# Source0-md5: c14a4bcb8bed66ea2204cd698d938250
78%if "%{?patchver}" != ""
79Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80# Patch0-md5: 82e3012b5510187907bba50dadbe7137
81%endif
82Source1: %{name}.default
83Source2: %{name}.sh
84Source3: %{name}.desktop
85Source5: find-lang.sh
86Source6: update-source.sh
87Source7: clean-source.sh
88Source8: get-source.sh
89Source9: master_preferences.json
90Patch1: plugin-searchdirs.patch
91Patch4: path-libpdf.patch
92Patch7: dlopen_sonamed_gl.patch
93Patch8: chromium_useragent.patch.in
94Patch10: system-libxnvctrl.patch
95# https://bugs.gentoo.org/show_bug.cgi?id=393471
96# libjpeg-turbo >= 1.1.90 supports that feature
97Patch11: chromium-revert-jpeg-swizzle-r2.patch
98Patch12: system-ffmpeg.patch
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
101Patch18: nacl-no-untar.patch
102Patch24: nacl-verbose.patch
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
105Patch28: system-mesa.patch
106Patch30: system-ply.patch
107Patch31: system-jinja.patch
108Patch32: remove_bundled_libraries-stale.patch
109Patch33: gn.patch
110URL: http://www.chromium.org/Home
111%{?with_gconf:BuildRequires: GConf2-devel}
112%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
113BuildRequires: Mesa-libGLES-devel >= 9.1
114%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
115%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
116BuildRequires: alsa-lib-devel
117BuildRequires: atk-devel
118BuildRequires: bison
119BuildRequires: bzip2-devel
120%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
121%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
122%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
123%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
124%{?with_cups:BuildRequires: cups-devel}
125BuildRequires: elfutils-devel
126BuildRequires: expat-devel
127%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
128%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
129BuildRequires: fontconfig-devel
130BuildRequires: glib2-devel
131BuildRequires: gperf
132%{?with_gps:BuildRequires: gpsd-devel}
133BuildRequires: gtest-devel
134BuildRequires: gtk+2-devel
135%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
136%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
137%{?with_kerberos:BuildRequires: heimdal-devel}
138BuildRequires: hicolor-icon-theme
139%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
140%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
141BuildRequires: libevent-devel
142%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
143%{?with_keyring:BuildRequires: libgnome-keyring-devel}
144BuildRequires: libicu-devel >= 4.6
145%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
146%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
147%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
148BuildRequires: libpng-devel
149%{?with_selinux:BuildRequires: libselinux-devel}
150BuildRequires: libstdc++-devel
151%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
152%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
153%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
154BuildRequires: libxml2-devel
155BuildRequires: libxslt-devel
156BuildRequires: man-db
157%{?with_system_minizip:BuildRequires: minizip-devel}
158BuildRequires: nspr-devel
159BuildRequires: nss-devel >= 1:3.12.3
160%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
161BuildRequires: pam-devel
162BuildRequires: pango-devel
163BuildRequires: pciutils-devel
164BuildRequires: perl-JSON
165BuildRequires: perl-modules
166BuildRequires: pkgconfig
167%{?with_system_protobuf:BuildRequires: protobuf-devel}
168%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
169BuildRequires: python
170#BuildRequires: python-gyp >= 1-%{gyp_rev}
171BuildRequires: python-jinja2 >= 2.7
172BuildRequires: python-modules
173BuildRequires: python-ply >= 3.4
174%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
175BuildRequires: rpm >= 4.4.9-56
176BuildRequires: rpmbuild(macros) >= 1.453
177%{?with_system_snappy:BuildRequires: snappy-devel}
178BuildRequires: speech-dispatcher-devel >= 0.8
179%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
180%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
181%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
182BuildRequires: tar >= 1:1.22
183BuildRequires: udev-devel
184BuildRequires: usbutils
185BuildRequires: util-linux
186%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
187BuildRequires: which
188BuildRequires: xorg-lib-libXScrnSaver-devel
189BuildRequires: xorg-lib-libXtst-devel
190BuildRequires: xz
191%{?with_system_yasm:BuildRequires: yasm}
192%{?with_system_zlib:BuildRequires: zlib-devel}
193Requires: browser-plugins >= 2.0
194Requires: desktop-file-utils
195%{?with_system_flac:Requires: flac >= 1.2.1-7}
196# crashes if no fontconfig font present
197Requires: fonts-Type1-urw
198Requires: hicolor-icon-theme
199Requires: libevent >= 2.0.21
200%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
201%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
202Requires: lsb-release
203%{?with_system_re2:Requires: re2 >= 20130115-2}
204Requires: shared-mime-info
205%{?with_system_sqlite:Requires: sqlite3(icu)}
206Requires: xdg-utils >= 1.0.2-4
207Requires: xorg-lib-libX11 >= 1.4.99.1
208Provides: wwwbrowser
209Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
210Obsoletes: chromium-browser-inspector < 15.0.863.0
211ExclusiveArch: %{ix86} %{x8664} arm
212BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
213
214# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
215# Note: these are for PLD Linux use ONLY.
216# For your own distribution, please get your own set of keys.
217%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
218%define google_default_client_id 724288223830.apps.googleusercontent.com
219%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
220
221%define find_lang sh find-lang.sh %{buildroot}
222
223# Usage: gyp_with BCOND_NAME [OPTION_NAME]
224%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
225
226%ifarch %{ix86}
227%define target_arch ia32
228%endif
229%ifarch %{x8664}
230%define target_arch x64
231%endif
232
233%if %{without debuginfo}
234%define _enable_debug_packages 0
235%endif
236
237%description
238Chromium is an open-source browser project that aims to build a safer,
239faster, and more stable way for all Internet users to experience the
240web.
241
242Chromium serves as a base for Google Chrome, which is Chromium
243rebranded (name and logo) with very few additions such as usage
244tracking and an auto-updater system.
245
246%package l10n
247Summary: chromium-browser language packages
248Group: I18n
249Requires: %{name} = %{version}-%{release}
250%if "%{_rpmversion}" >= "5"
251BuildArch: noarch
252%endif
253
254%description l10n
255Chromium is an open-source browser project that aims to build a safer,
256faster, and more stable way for all Internet users to experience the
257web.
258
259This package contains language packages for 50 languages:
260
261ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
262he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
263pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
264zh-TW
265
266%prep
267%setup -qc
268%if "%{?patchver}" != ""
269cd %{name}-%{branch}.%{basever}
270%patch0 -p1
271cd ..
272%endif
273mv %{name}-%{branch}.%{basever}/* .
274
275# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
276# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
277. ./chrome/VERSION
278chrome=$MAJOR.$MINOR.$BUILD.$PATCH
279test "$chrome" = %{version}
280
281gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
282test "$gyp_rev" = %{gyp_rev} || :
283
284. ./v8.sh
285v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
286
287# add chromium and pld to useragent
288%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
289sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
290 -e 's/@BUILD_DIST_NAME@/PLD/g' \
291 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
292 < %{PATCH8} | %{__patch} -p1
293
294%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
295ln -s %{SOURCE7} .
296
297%patch1 -p1
298%patch4 -p3
299%patch7 -p1
300%patch10 -p1
301%patch15 -p2
302%{!?with_libjpegturbo:%patch11 -p0}
303%patch12 -p1
304%patch16 -p1
305%patch28 -p1
306%patch25 -p1
307%{?with_nacl:%patch18 -p1}
308%patch24 -p2
309%patch26 -p2
310%patch30 -p1
311%patch31 -p0
312%patch32 -p1
313%patch33 -p0
314
315sh -x clean-source.sh \
316 %{!?with_nacl:nacl=0} \
317 %{!?with_system_libvpx:libvpx=0} \
318 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
319 %{!?with_system_mesa:mesa=0} \
320 %{!?with_system_protobuf:protobuf=0} \
321 %{!?with_system_re2:re2=0} \
322 %{!?with_system_snappy:snappy=0} \
323 %{!?with_system_sqlite:sqlite=0} \
324 %{!?with_system_v8:v8=0} \
325 %{!?with_system_libwebp:libwebp=0} \
326 %{!?with_system_zlib:zlib=0} \
327 %{!?with_system_ffmpeg:ffmpeg=0} \
328 %{nil}
329
330%build
331%if %{with nacl}
332rm -rf native_client/toolchain/linux_x86_newlib
333if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
334# Make symlinks for NaCL
335install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
336
337cd native_client/toolchain/linux_x86_newlib
338ln -s x86_64-nacl/bin bin
339cd x86_64-nacl/bin
340__cc='%{__cc}'
341if [ "${__cc#ccache}" != "$__cc" ]; then
342 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
343 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
344 %{__sed} -i -e '1i#!/bin/sh' gcc g++
345 chmod +x gcc g++
346else
347 ln -s %{_bindir}/x86_64-nacl-gcc gcc
348 ln -s %{_bindir}/x86_64-nacl-g++ g++
349fi
350ln -s gcc x86_64-nacl-gcc
351ln -s g++ x86_64-nacl-g++
352ln -s %{_bindir}/x86_64-nacl-ar .
353ln -s %{_bindir}/x86_64-nacl-ar ar
354ln -s %{_bindir}/x86_64-nacl-as as
355ln -s %{_bindir}/x86_64-nacl-ranlib .
356ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
357ln -s %{_bindir}/x86_64-nacl-strip .
358ln -s %{_bindir}/x86_64-nacl-strip strip
359ln -s %{_bindir}/x86_64-nacl-objcopy .
360ln -s %{_prefix}/x86_64-nacl/lib ../lib
361ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
362ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
363cd ../../../../..
364fi
365%endif
366
367%if %{without system_ffmpeg}
368# Re-configure bundled ffmpeg
369cd third_party/ffmpeg
370chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
371chromium/scripts/copy_config.sh
372cd -
373%endif
374
375flags="
376 -Dtarget_arch=%{target_arch} \
377 -Dpython_arch=%{target_arch} \
378 -Dsystem_libdir=%{_lib} \
379 -Dpython_ver=%{py_ver} \
380%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
381 -Dno_strict_aliasing=1 -Dgcc_version=44 \
382%endif
383 %{!?debug:-Dwerror=} \
384 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
385 %{?with_shared_libs:-Dlibrary=shared_library} \
386 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
387 -Dinclude_tests=0 \
388%if %{with nacl}
389 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
390 -Ddisable_glibc_untar=1 \
391 -Ddisable_newlib_untar=1 \
392 -Ddisable_glibc=1 \
393 -Ddisable_pnacl=1 \
394 -Dbuild_pnacl_newlib=0 \
395%else
396 -Ddisable_pnacl_untar=1 \
397 -Ddisable_nacl=1 \
398%endif
399 %{!?with_sse2:-Ddisable_sse2=1} \
400 %{?with_selinux:-Dselinux=1} \
401 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
402 -Dlinux_link_libpci=1 \
403 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
404 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
405 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
406 -Dlinux_use_gold_binary=0 \
407 -Dlinux_use_gold_flags=0 \
408 -Dlogging_like_official_build=1 \
409 -Dgoogle_api_key=%{google_api_key} \
410 -Dgoogle_default_client_id=%{google_default_client_id} \
411 -Dgoogle_default_client_secret=%{google_default_client_secret} \
412 %{gyp_with cups} \
413 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
414 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
415 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
416 %{gyp_with pulseaudio} \
417 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
418 %{gyp_with system_flac} \
419 %{gyp_with system_harfbuzz} \
420 %{gyp_with system_jsoncpp} \
421 %{gyp_with system_libexif} \
422 %{gyp_with system_libmtp} \
423 %{gyp_with system_libsrtp} \
424 %{gyp_with system_libusb} \
425 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
426 %{gyp_with system_libwebp} \
427 %{gyp_with system_libxnvctrl} \
428 %{gyp_with system_mesa} \
429 %{gyp_with system_minizip} \
430 %{gyp_with system_opus} \
431 %{gyp_with system_protobuf} \
432 %{gyp_with system_re2} \
433 %{gyp_with system_snappy} \
434 %{gyp_with system_speex} \
435 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
436 %{gyp_with system_v8} \
437 %{gyp_with system_yasm} \
438 %{gyp_with system_zlib} \
439 -Duse_system_bzip2=1 \
440 -Duse_system_expat=1 \
441 -Duse_system_icu=1 \
442 -Duse_system_libevent=1 \
443 -Duse_system_libjpeg=1 \
444 -Duse_system_libpng=1 \
445 -Duse_system_libxml=1 \
446 -Duse_system_libxslt=1 \
447 -Duse_system_nspr=1 \
448 -Duse_system_xdg_utils=1 \
449"
450
451build/linux/unbundle/replace_gyp_files.py $flags
452
453test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
454test -e Makefile || \
455 CC="%{__cc}" \
456 CXX="%{__cxx}" \
457 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
458 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
459 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
460 CC_host="%{__cc}" \
461 CXX_host="%{__cxx}" \
462 LD_host="%{__cxx}" \
463%{__python} build/gyp_chromium \
464 --format=make \
465 --depth=. \
466 build/all.gyp \
467 $flags
468
469# need {CC/CXX/LDFLAGS}.host overrides for v8 build
470%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
471 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
472 %{?with_verbose:V=1} \
473 CC.host="%{__cc}" \
474 CXX.host="%{__cxx}" \
475 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
476
477cd out/%{!?debug:Release}%{?debug:Debug}
478MANWIDTH=80 man ./chrome.1 > man.out
479%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
480
481%install
482rm -rf $RPM_BUILD_ROOT
483install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
484 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
485 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
486
487cd out/%{!?debug:Release}%{?debug:Debug}
488cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
489install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
490%{__sed} -i -e '
491 s,@libdir@,%{_libdir}/%{name},
492
493 /@OPTIONS@/ {
494 r options.txt
495 d
496 }
497' $RPM_BUILD_ROOT%{_bindir}/%{name}
498cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
499cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
500ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
501ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
502cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
503install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
504install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
505%if %{without system_ffmpeg}
506install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
507%endif
508cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
509cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
510
511%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
512
513%if %{with nacl}
514# Install Native Client files on platforms that support it.
515install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
516install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
517%ifarch %{x8664}
518install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
519%endif
520%ifarch %{ix86}
521install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
522%endif
523%endif
524
525cd -
526
527for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
528 size=${icon##*/product_logo_}
529 size=${size%.png}
530
531 # this will skip non-numeric (22_mono_invert, 22_mono)
532 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
533 test -d "$dir" || continue
534
535 install -d $RPM_BUILD_ROOT$dir
536 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
537done
538
539%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
540# http://code.google.com/p/chromium/issues/detail?id=24507
541gecko-mediaplayer*.so
542EOF
543
544# find locales
545%find_lang %{name}.lang
546# always package en-US
547%{__sed} -i -e '/en-US.pak/d' %{name}.lang
548
549%clean
550rm -rf $RPM_BUILD_ROOT
551
552%pretrans
553for d in locales resources; do
554 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
555 install -d %{_datadir}/%{name}
556 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
557 fi
558done
559exit 0
560
561%post
562%update_icon_cache hicolor
563%update_desktop_database
564%update_browser_plugins
565
566%postun
567if [ "$1" = 0 ]; then
568 %update_icon_cache hicolor
569 %update_browser_plugins
570fi
571
572%files
573%defattr(644,root,root,755)
574%doc AUTHORS LICENSE
575%{_browserpluginsconfdir}/browsers.d/%{name}.*
576%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
577%dir %{_sysconfdir}/%{name}
578%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
579%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
580%attr(755,root,root) %{_bindir}/%{name}
581%{_mandir}/man1/%{name}.1*
582%{_desktopdir}/*.desktop
583%{_iconsdir}/hicolor/*/apps/%{name}.png
584%dir %{_libdir}/%{name}
585%{_libdir}/%{name}/chrome*.pak
586%{_libdir}/%{name}/content_resources.pak
587%{_libdir}/%{name}/resources.pak
588%{_libdir}/%{name}/locales
589%{_libdir}/%{name}/resources
590
591%dir %{_datadir}/%{name}
592%dir %{_datadir}/%{name}/locales
593%{_datadir}/%{name}/locales/en-US.pak
594%dir %{_datadir}/%{name}/resources
595%{_datadir}/%{name}/resources/inspector
596
597%dir %{_libdir}/%{name}/plugins
598%attr(755,root,root) %{_libdir}/%{name}/%{name}
599# These unique permissions are intentional and necessary for the sandboxing
600%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
601
602# ffmpeg libs
603%if %{without system_ffmpeg}
604%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
605%endif
606
607%if %{with nacl}
608%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
609%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
610%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
611%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
612%endif
613
614%files l10n -f %{name}.lang
615%defattr(644,root,root,755)
This page took 0.033062 seconds and 4 git commands to generate.