]> git.pld-linux.org Git - packages/chromium-browser.git/blame_incremental - chromium-browser.spec
package icudtl.dat
[packages/chromium-browser.git] / chromium-browser.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without cups # with cups
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without gconf # with GConf
6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9%bcond_without libjpegturbo # use libjpeg-turbo features
10%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
11%bcond_with ninja # use Ninja instead of make to build
12%bcond_without pulseaudio # with pulseaudio
13%bcond_without sandboxing # with sandboxing
14%bcond_with selinux # with SELinux (need policy first)
15%bcond_with shared_libs # with shared libs
16%bcond_with sse2 # use SSE2 instructions
17%bcond_without system_flac # system flac
18%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
19%bcond_without system_harfbuzz # system harfbuzz
20%bcond_without system_jsoncpp # system jsoncpp
21%bcond_without system_libexif # system libexif
22%bcond_without system_libmtp # system libmtp
23%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
24%bcond_without system_libwebp # system libwebp
25%bcond_without system_libxnvctrl # system libxnvctrl
26%bcond_with system_mesa # system Mesa
27%bcond_without system_minizip # system minizip
28%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
29%bcond_without system_protobuf # system protobuf
30%bcond_without system_re2 # system re2
31%bcond_without system_snappy # system snappy
32%bcond_without system_speex # system speex
33%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
34%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
35%bcond_with system_v8 # system v8
36%bcond_without system_libvpx # system libvpx
37%bcond_without system_yasm # system yasm
38%bcond_without system_zlib # system zlib
39%bcond_without tcmalloc # use tcmalloc
40%bcond_without verbose # verbose build (V=1)
41
42%ifarch %{ix86}
43# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
44%undefine with_system_mesa
45%endif
46
47# TODO
48# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
49# - use_system_skia
50# - use_system_ssl (use_openssl: http://crbug.com/62803)
51# - use_system_stlport (android specific)
52# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
53
54# NOTES:
55# - mute BEEP mixer if you do not want to hear horrible system bell when
56# pressing home/end in url bar or more ^F search results on page.
57# - space considerations:
58# - unpacked sources: ~490MiB
59# - built code: ~1.4GiB (x86_64/i686)
60# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
61# - to look for new tarball, use update-source.sh script
62
63%define branch 34.0.1847
64%define basever 116
65#define patchver 152
66%define gyp_rev 1014
67Summary: A WebKit powered web browser
68Name: chromium-browser
69%if "%{?patchver}" != ""
70Version: %{branch}.%{patchver}
71%else
72Version: %{branch}.%{basever}
73%endif
74Release: 2
75License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
76Group: X11/Applications/Networking
77Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
78# Source0-md5: 987b25c0a3aa7bc2354c573113e94e04
79%if "%{?patchver}" != ""
80Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
81# Patch0-md5: 194579901c234fbce9e1538e7956d36c
82%endif
83Source1: %{name}.default
84Source2: %{name}.sh
85Source3: %{name}.desktop
86Source5: find-lang.sh
87Source6: update-source.sh
88Source7: clean-source.sh
89Source8: get-source.sh
90Source9: master_preferences.json
91Patch1: plugin-searchdirs.patch
92Patch2: enable-video-decode-accel.patch
93Patch4: path-libpdf.patch
94Patch7: dlopen_sonamed_gl.patch
95Patch8: chromium_useragent.patch.in
96# https://bugs.gentoo.org/show_bug.cgi?id=393471
97# libjpeg-turbo >= 1.1.90 supports that feature
98Patch11: chromium-revert-jpeg-swizzle-r2.patch
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
101Patch18: nacl-no-untar.patch
102Patch24: nacl-verbose.patch
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
105Patch28: system-mesa.patch
106Patch30: system-ply.patch
107Patch31: system-jinja.patch
108Patch32: remove_bundled_libraries-stale.patch
109Patch33: gn.patch
110Patch34: depot-tools.patch
111URL: http://www.chromium.org/Home
112%{?with_gconf:BuildRequires: GConf2-devel}
113%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
114BuildRequires: Mesa-libGLES-devel >= 9.1
115%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
116%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
117BuildRequires: alsa-lib-devel
118BuildRequires: atk-devel
119BuildRequires: bison
120BuildRequires: bzip2-devel
121%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
122%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
123%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
124%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
125%{?with_cups:BuildRequires: cups-devel}
126BuildRequires: elfutils-devel
127BuildRequires: expat-devel
128%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
129%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
130BuildRequires: fontconfig-devel
131BuildRequires: glib2-devel
132BuildRequires: gperf
133%{?with_gps:BuildRequires: gpsd-devel}
134BuildRequires: gtest-devel
135BuildRequires: gtk+2-devel
136%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
137%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
138%{?with_kerberos:BuildRequires: heimdal-devel}
139BuildRequires: hicolor-icon-theme
140%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
141%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
142BuildRequires: libevent-devel
143%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
144%{?with_keyring:BuildRequires: libgnome-keyring-devel}
145BuildRequires: libicu-devel >= 4.6
146%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
147%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
148%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
149BuildRequires: libpng-devel
150%{?with_selinux:BuildRequires: libselinux-devel}
151BuildRequires: libstdc++-devel
152%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
153%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
154%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
155BuildRequires: libxml2-devel
156BuildRequires: libxslt-devel
157BuildRequires: man-db
158%{?with_system_minizip:BuildRequires: minizip-devel}
159%{?with_ninja:BuildRequires: ninja >= 1.3.0}
160BuildRequires: nspr-devel
161BuildRequires: nss-devel >= 1:3.12.3
162%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
163BuildRequires: pam-devel
164BuildRequires: pango-devel
165BuildRequires: pciutils-devel
166BuildRequires: perl-JSON
167BuildRequires: perl-modules
168BuildRequires: pkgconfig
169%{?with_system_protobuf:BuildRequires: protobuf-devel}
170%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
171BuildRequires: python
172#BuildRequires: python-gyp >= 1-%{gyp_rev}
173BuildRequires: python-jinja2 >= 2.7
174BuildRequires: python-modules
175BuildRequires: python-ply >= 3.4
176%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
177BuildRequires: rpm >= 4.4.9-56
178BuildRequires: rpmbuild(macros) >= 1.453
179%{?with_system_snappy:BuildRequires: snappy-devel}
180BuildRequires: speech-dispatcher-devel >= 0.8
181%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
182%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
183%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
184BuildRequires: tar >= 1:1.22
185BuildRequires: udev-devel
186BuildRequires: usbutils
187BuildRequires: util-linux
188%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
189BuildRequires: which
190BuildRequires: xorg-lib-libXScrnSaver-devel
191BuildRequires: xorg-lib-libXtst-devel
192BuildRequires: xz
193%{?with_system_yasm:BuildRequires: yasm}
194%{?with_system_zlib:BuildRequires: zlib-devel}
195Requires: browser-plugins >= 2.0
196Requires: desktop-file-utils
197%{?with_system_flac:Requires: flac >= 1.2.1-7}
198# crashes if no fontconfig font present
199Requires: fonts-Type1-urw
200Requires: hicolor-icon-theme
201Requires: libevent >= 2.0.21
202%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
203%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
204Requires: lsb-release
205%{?with_system_re2:Requires: re2 >= 20130115-2}
206Requires: shared-mime-info
207%{?with_system_sqlite:Requires: sqlite3(icu)}
208Requires: xdg-utils >= 1.0.2-4
209Requires: xorg-lib-libX11 >= 1.4.99.1
210Provides: wwwbrowser
211Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
212Obsoletes: chromium-browser-inspector < 15.0.863.0
213ExclusiveArch: %{ix86} %{x8664} arm
214BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
215
216# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
217# Note: these are for PLD Linux use ONLY.
218# For your own distribution, please get your own set of keys.
219%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
220%define google_default_client_id 724288223830.apps.googleusercontent.com
221%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
222
223%define find_lang sh find-lang.sh %{buildroot}
224
225# Usage: gyp_with BCOND_NAME [OPTION_NAME]
226%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
227
228%ifarch %{ix86}
229%define target_arch ia32
230%endif
231%ifarch %{x8664}
232%define target_arch x64
233%endif
234
235%define buildtype %{?debug:Debug}%{!?debug:Release}
236%define builddir out/%{buildtype}
237
238%if %{without debuginfo}
239%define _enable_debug_packages 0
240%endif
241
242%description
243Chromium is an open-source browser project that aims to build a safer,
244faster, and more stable way for all Internet users to experience the
245web.
246
247Chromium serves as a base for Google Chrome, which is Chromium
248rebranded (name and logo) with very few additions such as usage
249tracking and an auto-updater system.
250
251%package l10n
252Summary: chromium-browser language packages
253Group: I18n
254Requires: %{name} = %{version}-%{release}
255%if "%{_rpmversion}" >= "5"
256BuildArch: noarch
257%endif
258
259%description l10n
260Chromium is an open-source browser project that aims to build a safer,
261faster, and more stable way for all Internet users to experience the
262web.
263
264This package contains language packages for 50 languages:
265
266ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
267he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
268pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
269zh-TW
270
271%prep
272%setup -qc
273%if "%{?patchver}" != ""
274cd chromium*-%{branch}.%{basever}
275%patch0 -p1
276cd ..
277%endif
278mv chromium*-%{branch}.%{basever}/* .
279
280# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
281# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
282. ./chrome/VERSION
283chrome=$MAJOR.$MINOR.$BUILD.$PATCH
284test "$chrome" = %{version}
285
286gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
287test "$gyp_rev" = %{gyp_rev} || :
288
289# add chromium and pld to useragent
290%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
291sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
292 -e 's/@BUILD_DIST_NAME@/PLD/g' \
293 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
294 < %{PATCH8} | %{__patch} -p1
295
296%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
297ln -s %{SOURCE7} .
298
299%patch1 -p1
300#%patch2 -p1 NOT COMPILING
301%patch4 -p3
302%patch7 -p1
303%patch15 -p2
304%{!?with_libjpegturbo:%patch11 -p0}
305%patch16 -p1
306%patch28 -p1
307%patch25 -p1
308%{?with_nacl:%patch18 -p1}
309%patch24 -p2
310%patch26 -p2
311#%patch30 -p1
312#%patch31 -p0
313%patch32 -p1
314%patch33 -p1
315%patch34 -p0
316
317sh -x clean-source.sh \
318 %{!?with_nacl:nacl=0} \
319 %{!?with_system_libvpx:libvpx=0} \
320 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
321 %{!?with_system_mesa:mesa=0} \
322 %{!?with_system_protobuf:protobuf=0} \
323 %{!?with_system_re2:re2=0} \
324 %{!?with_system_snappy:snappy=0} \
325 %{!?with_system_sqlite:sqlite=0} \
326 %{!?with_system_v8:v8=0} \
327 %{!?with_system_libwebp:libwebp=0} \
328 %{!?with_system_zlib:zlib=0} \
329 %{!?with_system_ffmpeg:ffmpeg=0} \
330 %{nil}
331
332%build
333%if %{with nacl}
334rm -rf native_client/toolchain/linux_x86_newlib
335if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
336# Make symlinks for NaCL
337install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
338
339cd native_client/toolchain/linux_x86_newlib
340ln -s x86_64-nacl/bin bin
341cd x86_64-nacl/bin
342__cc='%{__cc}'
343if [ "${__cc#ccache}" != "$__cc" ]; then
344 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
345 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
346 %{__sed} -i -e '1i#!/bin/sh' gcc g++
347 chmod +x gcc g++
348else
349 ln -s %{_bindir}/x86_64-nacl-gcc gcc
350 ln -s %{_bindir}/x86_64-nacl-g++ g++
351fi
352ln -s gcc x86_64-nacl-gcc
353ln -s g++ x86_64-nacl-g++
354ln -s %{_bindir}/x86_64-nacl-ar .
355ln -s %{_bindir}/x86_64-nacl-ar ar
356ln -s %{_bindir}/x86_64-nacl-as as
357ln -s %{_bindir}/x86_64-nacl-ranlib .
358ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
359ln -s %{_bindir}/x86_64-nacl-strip .
360ln -s %{_bindir}/x86_64-nacl-strip strip
361ln -s %{_bindir}/x86_64-nacl-objcopy .
362ln -s %{_prefix}/x86_64-nacl/lib ../lib
363ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
364ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
365cd ../../../../..
366fi
367%endif
368
369%if %{without system_ffmpeg}
370if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
371 # Re-configure bundled ffmpeg
372 cd third_party/ffmpeg
373 chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
374 chromium/scripts/copy_config.sh
375 cd -
376fi
377%endif
378
379flags="
380 -Dtarget_arch=%{target_arch} \
381 -Dpython_arch=%{target_arch} \
382 -Dsystem_libdir=%{_lib} \
383 -Dpython_ver=%{py_ver} \
384%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
385 -Dno_strict_aliasing=1 -Dgcc_version=44 \
386%endif
387 %{!?debug:-Dwerror=} \
388 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
389 %{?with_shared_libs:-Dlibrary=shared_library} \
390 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
391 -Dinclude_tests__=0 \
392%if %{with nacl}
393 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
394 -Ddisable_glibc_untar=1 \
395 -Ddisable_newlib_untar=1 \
396 -Ddisable_glibc=1 \
397 -Ddisable_pnacl=1 \
398 -Dbuild_pnacl_newlib=0 \
399%else
400 -Ddisable_pnacl_untar=1 \
401 -Ddisable_nacl=1 \
402%endif
403 %{!?with_sse2:-Ddisable_sse2=1} \
404 %{?with_selinux:-Dselinux=1} \
405 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
406 -Dlinux_link_libpci=1 \
407 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
408 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
409 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
410 -Dlinux_use_gold_binary=0 \
411 -Dlinux_use_gold_flags=0 \
412 -Dlogging_like_official_build=1 \
413 -Dgoogle_api_key=%{google_api_key} \
414 -Dgoogle_default_client_id=%{google_default_client_id} \
415 -Dgoogle_default_client_secret=%{google_default_client_secret} \
416 %{gyp_with cups} \
417 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
418 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
419 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
420 %{gyp_with pulseaudio} \
421 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
422 %{gyp_with system_flac} \
423 %{gyp_with system_harfbuzz} \
424 %{gyp_with system_jsoncpp} \
425 %{gyp_with system_libexif} \
426 %{gyp_with system_libmtp} \
427 %{gyp_with system_libsrtp} \
428 %{gyp_with system_libusb} \
429 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
430 %{gyp_with system_libwebp} \
431 %{gyp_with system_libxnvctrl} \
432 %{gyp_with system_mesa} \
433 %{gyp_with system_minizip} \
434 %{gyp_with system_opus} \
435 %{gyp_with system_protobuf} \
436 %{gyp_with system_re2} \
437 %{gyp_with system_snappy} \
438 %{gyp_with system_speex} \
439 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
440 %{gyp_with system_v8} \
441 %{gyp_with system_yasm} \
442 %{gyp_with system_zlib} \
443 -Duse_system_bzip2=1 \
444 -Duse_system_expat=1 \
445 -Duse_system_icu=1 \
446 -Duse_system_libevent=1 \
447 -Duse_system_libjpeg=1 \
448 -Duse_system_libpng=1 \
449 -Duse_system_libxml=1 \
450 -Duse_system_libxslt=1 \
451 -Duse_system_nspr=1 \
452 -Duse_system_xdg_utils=1 \
453"
454
455build/linux/unbundle/replace_gyp_files.py $flags
456
457%if %{with ninja}
458chkfile=%{builddir}/build.ninja
459%else
460chkfile=Makefile
461%endif
462test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
463test -e $chkfile || \
464 CC="%{__cc}" \
465 CXX="%{__cxx}" \
466 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
467 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
468 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
469 CC_host="%{__cc}" \
470 CXX_host="%{__cxx}" \
471 LD_host="%{__cxx}" \
472%{__python} build/gyp_chromium \
473 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
474 --depth=. \
475 build/all.gyp \
476 $flags
477
478%if %{with ninja}
479ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
480%else
481# need {CC/CXX/LDFLAGS}.host overrides for v8 build
482%{__make} -r \
483 BUILDTYPE=%{buildtype} \
484 %{?with_verbose:V=1} \
485 CC.host="%{__cc}" \
486 CXX.host="%{__cxx}" \
487 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
488%endif
489 chrome %{?with_sandboxing:chrome_sandbox} \
490 %{nil}
491
492cd %{builddir}
493MANWIDTH=80 man ./chrome.1 > man.out
494%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
495
496%install
497rm -rf $RPM_BUILD_ROOT
498install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
499 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
500 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
501
502cd %{builddir}
503cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
504install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
505%{__sed} -i -e '
506 s,@libdir@,%{_libdir}/%{name},
507
508 /@OPTIONS@/ {
509 r options.txt
510 d
511 }
512' $RPM_BUILD_ROOT%{_bindir}/%{name}
513cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
514cp -p *.pak icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
515ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
516ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
517cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
518install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
519install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
520%if %{without system_ffmpeg}
521install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
522%endif
523cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
524cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
525
526%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
527
528%if %{with nacl}
529# Install Native Client files on platforms that support it.
530install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
531install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
532%ifarch %{x8664}
533install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
534%endif
535%ifarch %{ix86}
536install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
537%endif
538%endif
539
540cd -
541
542for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
543 size=${icon##*/product_logo_}
544 size=${size%.png}
545
546 # this will skip non-numeric (22_mono_invert, 22_mono)
547 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
548 test -d "$dir" || continue
549
550 install -d $RPM_BUILD_ROOT$dir
551 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
552done
553
554%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
555# http://code.google.com/p/chromium/issues/detail?id=24507
556gecko-mediaplayer*.so
557EOF
558
559# find locales
560%find_lang %{name}.lang
561# always package en-US
562%{__sed} -i -e '/en-US.pak/d' %{name}.lang
563
564%clean
565rm -rf $RPM_BUILD_ROOT
566
567%pretrans
568for d in locales resources; do
569 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
570 install -d %{_datadir}/%{name}
571 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
572 fi
573done
574exit 0
575
576%post
577%update_icon_cache hicolor
578%update_desktop_database
579%update_browser_plugins
580
581%postun
582if [ "$1" = 0 ]; then
583 %update_icon_cache hicolor
584 %update_browser_plugins
585fi
586
587%files
588%defattr(644,root,root,755)
589%doc AUTHORS LICENSE
590%{_browserpluginsconfdir}/browsers.d/%{name}.*
591%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
592%dir %{_sysconfdir}/%{name}
593%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
594%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
595%attr(755,root,root) %{_bindir}/%{name}
596%{_mandir}/man1/%{name}.1*
597%{_desktopdir}/*.desktop
598%{_iconsdir}/hicolor/*/apps/%{name}.png
599%dir %{_libdir}/%{name}
600%{_libdir}/%{name}/chrome*.pak
601%{_libdir}/%{name}/icudtl.dat
602%{_libdir}/%{name}/content_resources.pak
603%{_libdir}/%{name}/resources.pak
604%{_libdir}/%{name}/locales
605%{_libdir}/%{name}/resources
606
607%dir %{_datadir}/%{name}
608%dir %{_datadir}/%{name}/locales
609%{_datadir}/%{name}/locales/en-US.pak
610%dir %{_datadir}/%{name}/resources
611%{_datadir}/%{name}/resources/inspector
612
613%dir %{_libdir}/%{name}/plugins
614%attr(755,root,root) %{_libdir}/%{name}/%{name}
615# These unique permissions are intentional and necessary for the sandboxing
616%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
617
618# ffmpeg libs
619%if %{without system_ffmpeg}
620%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
621%endif
622
623%if %{with nacl}
624%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
625%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
626%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
627%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
628%endif
629
630%files l10n -f %{name}.lang
631%defattr(644,root,root,755)
This page took 0.082614 seconds and 4 git commands to generate.