]> git.pld-linux.org Git - packages/capseo.git/blame_incremental - capseo.spec
- verbose bin, lib, include files
[packages/capseo.git] / capseo.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with mmx # MMX acceleration (won't work without)
4#
5%ifarch %{x8664} pentium2 pentium3 pentium4 athlon
6%define with_mmx 1
7%endif
8Summary: Video codec library
9Summary(pl.UTF-8): Biblioteka kodeka obrazu
10Name: capseo
11Version: 0.3.0
12Release: 2
13License: GPL v2
14Group: Libraries
15Source0: ftp://ftp.debian.org/debian/pool/main/c/capseo/%{name}_%{version}~svn158.orig.tar.gz
16# Source0-md5: 46660f02f7d5b8fcf7c9b5cc89eca6fe
17URL: http://rm-rf.in/capseo
18BuildRequires: OpenGL-devel
19BuildRequires: libogg-devel >= 1:1.1
20BuildRequires: libstdc++-devel
21BuildRequires: libtheora-devel
22BuildRequires: pkgconfig >= 1:0.17.2
23%if %{with mmx}
24BuildRequires: yasm
25%endif
26Requires: libogg >= 1:1.1
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30capseo is a realtime video encoder/decoder library. The capseo codec
31is meant to encode fast, not to generate the smallest files on your
32file system.
33
34%description -l pl.UTF-8
35capseo to biblioteka kodera/dekodera obrazu czasu rzeczywistego. Kodek
36ma za zadanie szybko kodować, niekoniecznie generując najmniejsze
37pliki.
38
39%package devel
40Summary: Header files for capseo library
41Summary(pl.UTF-8): Pliki nagłówkowe biblioteki capseo
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: libogg-devel >= 1:1.1
45Requires: libstdc++-devel
46
47%description devel
48Header files for capseo library.
49
50%description devel -l pl.UTF-8
51Pliki nagłówkowe biblioteki capseo.
52
53%package static
54Summary: Static capseo library
55Summary(pl.UTF-8): Biblioteka statyczna capseo
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60Static capseo library.
61
62%description static -l pl.UTF-8
63Biblioteka statyczna capseo.
64
65%prep
66%setup -q -n %{name}-%{version}~svn158.orig
67
68%build
69%configure \
70 --enable-theora \
71%if %{with mmx}
72%ifarch %{ix86}
73 --with-accel=x86 \
74%endif
75%ifarch %{x8664}
76 --with-accel=amd64
77%endif
78%endif
79
80%{__make}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85%{__make} install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%files
95%defattr(644,root,root,755)
96%doc AUTHORS ChangeLog README TODO
97%attr(755,root,root) %{_bindir}/cpsinfo
98%attr(755,root,root) %{_bindir}/cpsplay
99%attr(755,root,root) %{_bindir}/cpsrecode
100%attr(755,root,root) %{_libdir}/libcapseo.so.*.*.*
101%attr(755,root,root) %ghost %{_libdir}/libcapseo.so.0
102
103%files devel
104%defattr(644,root,root,755)
105%attr(755,root,root) %{_libdir}/libcapseo.so
106%{_libdir}/libcapseo.la
107%{_includedir}/capseo.h
108%{_pkgconfigdir}/capseo.pc
109
110%files static
111%defattr(644,root,root,755)
112%{_libdir}/libcapseo.a
This page took 0.069288 seconds and 4 git commands to generate.