]> git.pld-linux.org Git - packages/calibre.git/blame_incremental - calibre.spec
- pass our CXXFLAGS
[packages/calibre.git] / calibre.spec
... / ...
CommitLineData
1#
2# NOTE:
3# Upstream packages some unfree fonts which we cannot redistribute,
4# so when upgrading calibre we should download upstream tarball by hand from
5# http://downloads.sourceforge.net/calibre and run below script in order
6# to remove them:
7#
8# #!/bin/sh
9#
10# VERSION=$1
11#
12# rm -rf calibre
13# tar -xvzf calibre-$VERSION.tar.gz
14# rm -f calibre/resources/fonts/liberation/*
15# rm -f calibre/resources/fonts/prs500/*
16#
17# tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre
18#
19Summary: E-book converter and library management
20Name: calibre
21Version: 0.6.53
22Release: 0.1
23License: GPL v3+
24Group: Applications/Multimedia
25Source0: %{name}-%{version}-nofonts.tar.bz2
26# Source0-md5: 7ed89159bbd97db0d2dcf850bb1dd867
27Patch0: %{name}-prefix.patch
28Patch1: %{name}-manpages.patch
29Patch2: %{name}-no-update.patch
30URL: http://www.calibre-ebook.com/
31BuildRequires: ImageMagick-devel
32BuildRequires: chmlib-devel
33BuildRequires: podofo-devel
34BuildRequires: poppler-Qt-devel
35BuildRequires: python-BeautifulSoup
36BuildRequires: python-PIL
37BuildRequires: python-PyQt4-devel
38BuildRequires: python-cssutils
39BuildRequires: python-dateutil
40BuildRequires: python-lxml
41BuildRequires: python-mechanize
42BuildRequires: python-modules-sqlite
43BuildRequires: python-sip-devel
44BuildRequires: rpm-pythonprov
45Requires: python-PIL
46Requires: python-cssutils
47Requires: python-dateutil
48Requires: python-lxml
49Requires: python-mechanize
50Requires: python-modules-sqlite
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54Calibre is meant to be a complete e-library solution. It includes
55library management, format conversion, news feeds to ebook conversion
56as well as e-book reader sync features.
57
58Calibre is primarily a ebook cataloging program. It manages your ebook
59collection for you. It is designed around the concept of the logical
60book, i.e. a single entry in the database that may correspond to
61ebooks in several formats. It also supports conversion to and from a
62dozen different ebook formats.
63
64Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
65CBR, CBZ, RTF, TXT, PDF and LRS.
66
67%prep
68%setup -q -n %{name}
69%patch0 -p1
70%patch1 -p1
71%patch2 -p1
72
73%build
74%{__python} setup.py build \
75 OVERRIDE_CFLAGS="%{rpmcxxflags}"
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__python} setup.py install \
81 --root=$RPM_BUILD_ROOT \
82 --libdir=%{_libdir}
83
84mv $RPM_BUILD_ROOT%{_datadir}/%{name}/man $RPM_BUILD_ROOT%{_mandir}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
91%doc COPYRIGHT README
92%attr(755,root,root) %{_bindir}/*
93%{_datadir}/%{name}
94%{_libdir}/%{name}
95%{_mandir}/man1/*.1*
This page took 0.058016 seconds and 4 git commands to generate.