]> git.pld-linux.org Git - packages/btparser.git/blame_incremental - btparser.spec
- release 7 (by relup.sh)
[packages/btparser.git] / btparser.spec
... / ...
CommitLineData
1Summary: Parser and analyzer for backtraces produced by GDB
2Summary(pl.UTF-8): Analizator śladów wywołań tworzonych przez GDB
3Name: btparser
4Version: 0.25
5Release: 7
6License: GPL v2+
7Group: Development/Tools
8Source0: https://fedorahosted.org/released/btparser/%{name}-%{version}.tar.xz
9# Source0-md5: 7fcf3f97dd6df827151638a41855c5bb
10URL: http://fedorahosted.org/btparser/
11%ifarch %{x8664}
12BuildRequires: binutils-static
13%endif
14BuildRequires: glib2-devel >= 1:2.21
15BuildRequires: pkgconfig
16BuildRequires: python-devel
17BuildRequires: python-distribute
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.219
20BuildRequires: tar >= 1:1.22
21BuildRequires: xmlto
22BuildRequires: xz
23Requires: %{name}-libs = %{version}-%{release}
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Btparser is a backtrace parser and analyzer, which works with
28backtraces produced by the GNU Project Debugger. It can parse a text
29file with a backtrace to a tree of C structures, allowing to analyze
30the threads and frames of the backtrace and work with them.
31
32Btparser also contains some backtrace manipulation and extraction
33routines:
34- it can find a frame in the crash-time backtrace where the program
35 most likely crashed (a chance is that the function described in that
36 frame is buggy)
37- it can produce a duplication hash of the backtrace, which helps to
38 discover that two crash-time backtraces are duplicates, triggered by
39 the same flaw of the code
40- it can "rate" the backtrace quality, which depends on the number of
41 frames with and without the function name known (missing function
42 name is caused by missing debugging symbols)
43
44%description -l pl.UTF-8
45Btparser to analizator śladów wywołań (backtrace'ów), działający ze
46śladami tworzonymi przez debugger GDB z projektu GNU. Potrafi
47przetworzyć plik tekstowy ze śladem na drzewo struktur C, co pozwala
48na analizę wątków oraz ramek śladu wywołań i dalszą pracę z nimi.
49
50Btparser zawiera także trochę procedur do obróbki i wydobywania śladów
51wywołań:
52- potrafi znaleźć ramkę w pośmiertnym śladzie wywołań, w której
53 najprawdopodobniej nastąpiła wywrotka programu (możliwe, że to
54 funkcja w tej ramce zawiera błąd)
55- potrafi utworzyć skrót (hasz) śladu, pozwalający wykryć, czy dwa
56 zadane ślady pośmiertne są duplikatami spowodowanymi tym samym
57 błędem w kodzie
58- potrafi "ocenić jakość" śladów, zależną od liczby ramek ze znaną i
59 bez znanej nazwy funkcji (brak nazwy funkcji wynika z braku symboli
60 diagnostycznych)
61
62%package libs
63Summary: Btparser library
64Summary(pl.UTF-8): Biblioteka btparser
65Group: Libraries
66Requires: glib2 >= 1:2.21
67
68%description libs
69Btparser library.
70
71%description libs -l pl.UTF-8
72Biblioteka btparser.
73
74%package devel
75Summary: Header files for %{name} library
76Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
77Group: Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79Requires: glib2-devel >= 1:2.21
80
81%description devel
82Header files for %{name} library.
83
84%description devel -l pl.UTF-8
85Pliki nagłówkowe biblioteki %{name}.
86
87%package -n python-btparser
88Summary: Python bindings for %{name}
89Summary(pl.UTF-8): Wiązania Pythona do biblioteki btparser
90Group: Libraries/Python
91Requires: %{name}-libs = %{version}-%{release}
92Requires: python-modules
93
94%description -n python-btparser
95Python bindings for %{name}.
96
97%description -n python-btparser -l pl.UTF-8
98Wiązania Pythona do biblioteki btparser.
99
100%prep
101%setup -q
102
103%build
104%configure \
105%ifarch %{x8664}
106 --enable-fingerprints
107%endif
108
109%{__make}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
117%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
118
119%py_postclean
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post libs -p /sbin/ldconfig
125%postun libs -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
129%doc ChangeLog NEWS README RELEASE TODO
130%attr(755,root,root) %{_bindir}/btparser
131%{_mandir}/man1/btparser.1*
132
133%files libs
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_libdir}/libbtparser.so.*.*
136%attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
137
138%files devel
139%defattr(644,root,root,755)
140%attr(755,root,root) %{_libdir}/libbtparser.so
141%{_includedir}/btparser
142%{_pkgconfigdir}/btparser.pc
143
144%files -n python-btparser
145%defattr(644,root,root,755)
146%dir %{py_sitedir}/btparser
147%{py_sitedir}/btparser/__init__.py[co]
148%attr(755,root,root) %{py_sitedir}/btparser/_btparser.so
This page took 0.046584 seconds and 4 git commands to generate.