]> git.pld-linux.org Git - packages/autogen.git/blame_incremental - autogen.spec
- added fallthrough,format-truncate patches (fix build with gcc 8)
[packages/autogen.git] / autogen.spec
... / ...
CommitLineData
1Summary: Automated program generator
2Summary(pl.UTF-8): Zautomatyzowany generator programów
3Name: autogen
4Version: 5.18.14
5Release: 2
6License: GPL v3+ (AutoGen), LGPL v2+ (genshell), LGPL v3+ or Modified BSD (AutoOpts library)
7Group: Development/Tools
8Source0: http://ftp.gnu.org/gnu/autogen/rel%{version}/%{name}-%{version}.tar.xz
9# Source0-md5: c4d9a1641cb1bad4a3cc4108de6d867a
10Patch0: %{name}-notinstalled.patch
11Patch1: %{name}-info.patch
12Patch2: %{name}-fallthrough.patch
13Patch3: %{name}-format-truncate.patch
14URL: http://autogen.sourceforge.net/
15BuildRequires: guile-devel >= 5:2.0
16BuildRequires: libltdl-devel
17BuildRequires: libxml2-devel
18BuildRequires: tar >= 1:1.22
19BuildRequires: texinfo
20BuildRequires: xz
21BuildConflicts: guile1-devel
22Requires: %{name}-libs = %{version}-%{release}
23Suggests: %{name}-devel = %{version}-%{release}
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27AutoGen is a tool designed for generating program files that contain
28repetitive text with varied substitutions. Its goal is to simplify the
29maintenance of programs that contain large amounts of repetitious
30text. This is especially valuable if there are several blocks of such
31text that must be kept synchronized in parallel tables.
32
33%description -l pl.UTF-8
34AutoGen to narzędzie zaprojektowane do generowania plików programów
35zawierających powtarzający się tekst z różnymi podstawieniami. Celem
36projektu jest uproszczenie zarządzania programów zawierających duże
37ilości powtórzonego tekstu. Jest szczególnie wartościowy jeśli jest
38kilka bloków takiego tekstu, które muszą być synchronizowane
39równolegle.
40
41%package libs
42Summary: Shared AutoOpts library
43Summary(pl.UTF-8): Biblioteka współdzielona AutoOpts
44License: LGPL v3+ or Modified BSD
45Group: Libraries
46Conflicts: autogen < 5.14
47
48%description libs
49Shared AutoOpts library.
50
51%description libs -l pl.UTF-8
52Biblioteka współdzielona AutoOpts.
53
54%package devel
55Summary: Header files for AutoOpts library
56Summary(pl.UTF-8): Pliki nagłówkowe biblioteki AutoOpts
57License: LGPL v3+ or Modified BSD
58Group: Development/Libraries
59Requires: %{name}-libs = %{version}-%{release}
60
61%description devel
62Header files for AutoOpts library.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe biblioteki AutoOpts.
66
67%package static
68Summary: Static AutoOpts library
69Summary(pl.UTF-8): Statyczna biblioteka AutoOpts
70License: LGPL v3+ or Modified BSD
71Group: Development/Libraries
72Requires: %{name}-devel = %{version}-%{release}
73
74%description static
75Static AutoOpts library.
76
77%description static -l pl.UTF-8
78Statyczna biblioteka AutoOpts.
79
80%prep
81%setup -q
82%patch0 -p1
83%patch1 -p1
84%patch2 -p1
85%patch3 -p1
86
87# force regeneration
88%{__rm} doc/autogen.info*
89
90%build
91%configure
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post
104[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
105
106%postun
107[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
108
109%post libs -p /sbin/ldconfig
110%postun libs -p /sbin/ldconfig
111
112%files
113%defattr(644,root,root,755)
114%doc AUTHORS ChangeLog NEWS README THANKS TODO
115%attr(755,root,root) %{_bindir}/autogen
116%attr(755,root,root) %{_bindir}/columns
117%attr(755,root,root) %{_bindir}/getdefs
118%attr(755,root,root) %{_bindir}/xml2ag
119%dir %{_libdir}/%{name}
120%{_libdir}/%{name}/tpl-config.tlib
121%dir %{_datadir}/%{name}
122%{_datadir}/%{name}/*.def
123%{_datadir}/%{name}/*.lic
124%{_datadir}/%{name}/*.m4
125%{_datadir}/%{name}/*.pm
126%{_datadir}/%{name}/*.tlib
127%{_datadir}/%{name}/*.tpl
128%{_datadir}/%{name}/libopts-*.tar.gz
129%attr(755,root,root) %{_datadir}/%{name}/man2mdoc
130%attr(755,root,root) %{_datadir}/%{name}/man2texi
131%attr(755,root,root) %{_datadir}/%{name}/mdoc2man
132%attr(755,root,root) %{_datadir}/%{name}/mdoc2texi
133%attr(755,root,root) %{_datadir}/%{name}/texi2man
134%attr(755,root,root) %{_datadir}/%{name}/texi2mdoc
135%{_infodir}/autogen.info*
136%{_mandir}/man1/autogen.1*
137%{_mandir}/man1/columns.1*
138%{_mandir}/man1/getdefs.1*
139%{_mandir}/man1/xml2ag.1*
140
141%files libs
142%defattr(644,root,root,755)
143%attr(755,root,root) %{_libdir}/libopts.so.*.*.*
144%attr(755,root,root) %ghost %{_libdir}/libopts.so.25
145
146%files devel
147%defattr(644,root,root,755)
148%attr(755,root,root) %{_bindir}/autoopts-config
149%attr(755,root,root) %{_libdir}/libopts.so
150%{_libdir}/libopts.la
151%{_includedir}/autoopts
152%{_aclocaldir}/autoopts.m4
153%{_pkgconfigdir}/autoopts.pc
154%{_mandir}/man1/autoopts-config.1*
155%{_mandir}/man3/ao_string_tokenize.3*
156%{_mandir}/man3/configFileLoad.3*
157%{_mandir}/man3/option*.3*
158%{_mandir}/man3/str*.3*
159
160%files static
161%defattr(644,root,root,755)
162%{_libdir}/libopts.a
This page took 0.052671 seconds and 4 git commands to generate.