]> git.pld-linux.org Git - packages/apr.git/blame_incremental - apr.spec
- use fdflags not flags for consistency
[packages/apr.git] / apr.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform make test
4#
5Summary: Apache Portable Runtime
6Summary(pl.UTF-8): Apache Portable Runtime - przenośna biblioteka uruchomieniowa
7Name: apr
8Version: 1.3.3
9Release: 12
10Epoch: 1
11License: Apache v2.0
12Group: Libraries
13Source0: http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
14# Source0-md5: 2090c21dee4f0eb1512604127dcd158f
15Patch0: %{name}-link.patch
16Patch1: %{name}-metuxmpm.patch
17Patch2: %{name}-libtool.patch
18Patch3: %{name}-bug-46425.patch
19URL: http://apr.apache.org/
20BuildRequires: autoconf >= 2.50
21BuildRequires: automake
22BuildRequires: glibc-devel >= 6:2.9
23%if "%{pld_release}" != "ac"
24BuildRequires: libtool >= 2:2.2
25%else
26BuildRequires: libtool
27%endif
28BuildRequires: libuuid-devel
29BuildRequires: python
30BuildRequires: rpm >= 4.4.9-56
31BuildRequires: rpm-pythonprov
32BuildRequires: sed >= 4.0
33%if "%{pld_release}" != "ac"
34BuildRequires: uname(release) >= 2.6
35Requires: uname(release) >= 2.6.13
36%endif
37# uuid.h misdetected from this one instead of libuuid-devel
38BuildConflicts: ossp-uuid-devel < 1.6.2-6
39Conflicts: kernel24
40Conflicts: kernel24-smp
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%define _includedir /usr/include/apr
44%define _datadir /usr/share/apr
45
46%description
47The mission of the Apache Portable Runtime (APR) project is to create
48and maintain software libraries that provide a predictable and
49consistent interface to underlying platform-specific implementations.
50The primary goal is to provide an API to which software developers may
51code and be assured of predictable if not identical behaviour
52regardless of the platform on which their software is built, relieving
53them of the need to code special-case conditions to work around or
54take advantage of platform-specific deficiencies or features.
55
56%description -l pl.UTF-8
57Celem projektu APR (Apache Portable Runtime) jest stworzenie i
58utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
59interfejsu do leżących u podstaw implementacji zależnych od platformy.
60Głównym celem jest dostarczenie API, którego mogą używać programiści
61mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
62identyczny, niezależnie od platformy na jakiej oprogramowanie jest
63budowane oraz bez potrzeby kodowania specjalnych warunków do
64obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
65możliwości.
66
67%package devel
68Summary: Header files and development documentation for apr
69Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja programisty do apr
70Group: Development/Libraries
71Requires: %{name} = %{epoch}:%{version}-%{release}
72Requires: automake
73%if "%{pld_release}" != "ac"
74Requires: libtool >= 2:2.2
75%else
76Requires: libtool
77%endif
78Requires: libuuid-devel
79Requires: python-modules
80
81%description devel
82Header files and development documentation for apr.
83
84%description devel -l pl.UTF-8
85Pliki nagłówkowe i dokumentacja programisty do apr.
86
87%package static
88Summary: Static apr library
89Summary(pl.UTF-8): Statyczna biblioteka apr
90Group: Development/Libraries
91Requires: %{name}-devel = %{epoch}:%{version}-%{release}
92
93%description static
94Static apr library.
95
96%description static -l pl.UTF-8
97Statyczna biblioteka apr.
98
99%prep
100%setup -q
101%patch0 -p1
102%patch1 -p1
103%patch2 -p1
104%patch3 -p1
105
106cat >> config.layout <<'EOF'
107<Layout PLD>
108sbindir: %{_sbindir}
109libexecdir: %{_libdir}/apr
110installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
111localstatedir: /var/run
112runtimedir: /var/run
113libsuffix: -${APR_MAJOR_VERSION}
114</Layout>
115EOF
116
117%build
118install /usr/share/automake/config.* build
119%{__autoconf}
120
121%configure \
122 --enable-layout=PLD \
123%ifarch %{ix86} %{x8664}
124%ifnarch i386
125 --enable-nonportable-atomics \
126%endif
127%endif
128 --enable-threads \
129 --with-devrandom=/dev/urandom
130%{__make}
131
132%{?with_tests:%{__make} -j1 test}
133
134%install
135rm -rf $RPM_BUILD_ROOT
136
137%{__make} install \
138 DESTDIR=$RPM_BUILD_ROOT
139
140mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
141install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
142ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
143if [ -f /usr/share/libtool/config/ltmain.sh ]; then
144 ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
145else
146 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
147fi
148ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
149ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
150
151sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
152 $RPM_BUILD_ROOT%{_bindir}/apr-1-config
153sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
154 $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
155sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
156
157%clean
158rm -rf $RPM_BUILD_ROOT
159
160%post -p /sbin/ldconfig
161%postun -p /sbin/ldconfig
162
163%files
164%defattr(644,root,root,755)
165%doc CHANGES docs/*.html
166%attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
167%attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
168
169%files devel
170%defattr(644,root,root,755)
171%attr(755,root,root) %{_bindir}/apr-1-config
172%attr(755,root,root) %{_libdir}/libapr-1.so
173%{_libdir}/libapr-1.la
174%{_libdir}/apr.exp
175%{_includedir}
176%dir %{_datadir}
177%dir %{_datadir}/build
178%{_datadir}/build/*.mk
179%{_datadir}/build/*.m4
180%{_datadir}/build/*.awk
181%attr(755,root,root) %{_datadir}/build/config.*
182%attr(755,root,root) %{_datadir}/build/*.sh
183%attr(755,root,root) %{_datadir}/build/libtool
184%attr(755,root,root) %{_datadir}/build/gen-build.py
185%{_datadir}/build-1
186%{_pkgconfigdir}/apr-1.pc
187
188%files static
189%defattr(644,root,root,755)
190%{_libdir}/libapr-1.a
This page took 0.056651 seconds and 4 git commands to generate.