]> git.pld-linux.org Git - packages/R.git/blame_incremental - R.spec
- added bcond_without tests (for make check)
[packages/R.git] / R.spec
... / ...
CommitLineData
1
2# Conditional build
3%bcond_without tcl # disable tcl support
4%bcond_without tests # do not run "make check"
5
6# TODO:
7# - script for rpm to autoprovides/autorequires R internals
8#
9%define KernSmooth_version 2.22r19
10%define VR_version 7.2r30
11%define boot_version 1.2r27
12%define cluster_version 1.11.4
13%define foreign_version 0.8r18
14%define lattice_version 0.14r16
15%define mgcv_version 1.3r22
16%define nlme_version 3.1r78
17%define rpart_version 3.1r33
18%define survival_version 2.30
19
20%include /usr/lib/rpm/macros.perl
21Summary: A language for data analysis and graphics
22Summary(pl.UTF-8): Język do analizy danych oraz grafiki
23Name: R
24Version: 2.6.0
25Release: 0.1
26License: Mixed (distributable), mostly GPL
27Group: Development/Languages
28# CRAN master site: ftp://cran.r-project.org/pub/R/src/
29Source0: ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
30# Source0-md5: 97e5d2542349925962b7469456d45731
31Source1: %{name}.desktop
32URL: http://www.r-project.org/
33BuildRequires: autoconf
34BuildRequires: automake
35BuildRequires: blas-devel
36BuildRequires: bzip2-devel
37BuildRequires: gcc-c++
38BuildRequires: gcc-fortran
39BuildRequires: gettext-devel
40#BuildRequires: lapack-devel >= 3.1.1
41BuildRequires: libjpeg-devel >= 6b
42BuildRequires: libpng-devel >= 1.0.5
43BuildRequires: libstdc++-devel
44BuildRequires: libtool
45BuildRequires: libxml2-devel >= 2.6.26
46BuildRequires: pcre-devel
47BuildRequires: perl-base >= 1:5.6
48BuildRequires: readline-devel
49BuildRequires: rpm-perlprov
50%{?with_tcl:BuildRequires: tcl-devel}
51BuildRequires: tetex-dvips
52BuildRequires: tetex-latex
53BuildRequires: tetex-pdftex
54%{?with_tcl:BuildRequires: tk-devel}
55BuildRequires: xorg-lib-libX11-devel
56BuildRequires: zip
57BuildRequires: zlib-devel >= 1.1.3
58#Requires: lpr
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
62A system for statistical computation and graphics. R consists of a
63language plus a run-time environment with graphics, a debugger, access
64to certain system functions, and the ability to run programs stored in
65script files.
66
67The design of R has been heavily influenced by two existing languages:
68Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
69resulting language is very similar in appearance to S, the underlying
70implementation and semantics are derived from Scheme.
71
72%description -l pl.UTF-8
73System do obliczeń statystycznych i grafiki. R składa się z języka
74oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
75niektórych funkcji systemowych oraz możliwością uruchamiania programów
76zapisanych w skryptach.
77
78Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
79Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
80implementacja i semantyka wywodzi się ze Scheme.
81
82%package base
83Summary: The R base distribution
84Summary(pl.UTF-8): Podstawowa dystrybucja R
85License: GPL v2 / LGPL
86Group: Development/Languages
87Requires(post): perl-base
88Requires(post): textutils
89Provides: R-cran-base
90Provides: R-cran-datasets
91Provides: R-cran-grDevices
92Provides: R-cran-graphics
93Provides: R-cran-grid
94Provides: R-cran-methods
95Provides: R-cran-splines
96Provides: R-cran-stats
97Provides: R-cran-stats4
98Provides: R-cran-tcltk
99Provides: R-cran-tools
100Provides: R-cran-utils
101
102%description base
103R is a language and run-time environment for carrying out interactive
104statistical data analysis. It is not entirely dissimilar to the S
105language developed at AT&T Bell Laboratories (and now Lucent
106Technologies). Indeed, S users will find the environment quite
107familiar and a good deal of S software will run without change under
108R.
109
110%description base -l pl.UTF-8
111R jest językiem i środowiskiem uruchomieniowym do interaktywnej
112analizy danych statystycznych. R nie jest całkowicie zgodny z językiem
113S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
114mimo to użytkownicy S zauważą zbliżone środowisko, a duża część
115oprogramowania w S będzie działała bez zmian w R.
116
117%package recommended
118Summary: Recommended contributed packages for the R language
119Summary(pl.UTF-8): Zalecane dodatkowe pakiety do języka R
120License: GPL, free or free for non-commercial use
121Group: Development/Languages
122URL: http://www.ci.tuwien.ac.at/R/
123Requires(post,postun): R-base
124Requires(post,postun): perl-base
125Requires(post,postun): textutils
126Requires: R-base = %{version}-%{release}
127Provides: R-cran-KernSmooth = %{KernSmooth_version}
128Provides: R-cran-MASS = %{VR_version}
129Provides: R-cran-VR = %{VR_version}
130Provides: R-cran-boot = %{boot_version}
131Provides: R-cran-class = %{VR_version}
132Provides: R-cran-cluster = %{cluster_version}
133Provides: R-cran-foreign = %{foreign_version}
134Provides: R-cran-lattice = %{lattice_version}
135Provides: R-cran-mgcv = %{mgcv_version}
136Provides: R-cran-nlme = %{nlme_version}
137Provides: R-cran-nnet = %{VR_version}
138Provides: R-cran-rpart = %{rpart_version}
139Provides: R-cran-spatial = %{VR_version}
140Provides: R-cran-survival = %{survival_version}
141Obsoletes: R-contrib
142Obsoletes: R-cran-KernSmooth
143Obsoletes: R-cran-MASS
144Obsoletes: R-cran-VR
145Obsoletes: R-cran-boot
146Obsoletes: R-cran-class
147Obsoletes: R-cran-cluster
148Obsoletes: R-cran-foreign
149Obsoletes: R-cran-lattice
150Obsoletes: R-cran-mgcv
151Obsoletes: R-cran-nlme
152Obsoletes: R-cran-nnet
153Obsoletes: R-cran-rpart
154Obsoletes: R-cran-spatial
155Obsoletes: R-cran-survival
156
157%description recommended
158Packages which extend the capabilities of the R base distribution and
159are distributed on the Comprehensive R Archive Network (CRAN).
160
161%description recommended -l pl.UTF-8
162Pakiety rozszerzające możliwości podstawowej dystrybucji języka R,
163dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
164
165%prep
166%setup -q
167
168%build
169%configure \
170 --enable-R-shlib \
171 --enable-linux-lfs \
172 --with-system-zlib \
173 --with-system-bzlib \
174 --with-system-pcre \
175 --with-libpng \
176 --with-jpeglib \
177 --with-blas \
178 --with-readline \
179 --with%{!?with_tcl:out}-tcltk \
180 --with-recommended-packages
181
182# R gets into infinite loop in src/library/grDevices when this is enabled
183# --with-lapack \
184
185%{__make}
186%{__make} %{?with_tests:check} docs help html info
187
188%install
189rm -rf $RPM_BUILD_ROOT
190install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
191install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
192
193%{__make} install \
194 DESTDIR=${RPM_BUILD_ROOT}
195
196install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
197
198find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
199mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
200mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
201ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
202rm $RPM_BUILD_ROOT%{_bindir}/%{name}
203sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
204ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
205
206(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
207for f in * ; do
208 ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
209done)
210(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
211for f in * ; do
212 ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
213done)
214
215rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/{R,File,Text}
216rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/Text
217
218%clean
219rm -rf $RPM_BUILD_ROOT
220
221%post
222(cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
223 R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
224/sbin/ldconfig
225
226%postun -p /sbin/ldconfig
227
228%files base
229%defattr(644,root,root,755)
230%doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
231
232%{_mandir}/man1/R.1*
233%{_mandir}/man1/Rscript*
234%attr(755,root,root) %{_bindir}/R
235%attr(755,root,root) %{_bindir}/Rscript
236%dir %{_libdir}/R
237%attr(755,root,root) %{_libdir}/R/bin
238%attr(755,root,root) %{_libdir}/libR*.so
239%{_libdir}/R/etc
240%{_libdir}/R/include
241%{_includedir}/R
242%{_libdir}/R/share
243%{_libdir}/R/COPYING
244%{_libdir}/R/NEWS
245%{_libdir}/R/SVN-REVISION
246%dir %{_libdir}/R/library
247%{_libdir}/%{name}/library/R.css
248# %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
249%dir %{_libdir}/R/doc
250%{_libdir}/R/doc/[KRm]*
251%dir %{_libdir}/R/doc/html
252%{_libdir}/R/doc/html/*.css
253%{_libdir}/R/doc/html/[Ra-lr-u]*.html
254%{_libdir}/R/doc/html/packages-head*.html
255%{_libdir}/R/doc/html/*.jpg
256%dir %{_libdir}/R/doc/html/search
257%{_libdir}/R/doc/html/search/[A-Z]*
258%ghost %{_libdir}/R/doc/html/search/index.txt
259%ghost %{_libdir}/R/doc/html/packages.html
260%{_desktopdir}/*.desktop
261
262%{perl_vendorlib}/R
263
264%attr(755,root,root) %{_libdir}/%{name}/modules
265
266%{_libdir}/%{name}/library/KernSmooth
267%{_libdir}/%{name}/library/MASS
268%{_libdir}/%{name}/library/base
269%{_libdir}/%{name}/library/boot
270%{_libdir}/%{name}/library/class
271%{_libdir}/%{name}/library/cluster
272%{_libdir}/%{name}/library/codetools
273%{_libdir}/%{name}/library/datasets
274%{_libdir}/%{name}/library/foreign
275%{_libdir}/%{name}/library/grDevices
276%{_libdir}/%{name}/library/graphics
277%{_libdir}/%{name}/library/grid
278%{_libdir}/%{name}/library/lattice
279%{_libdir}/%{name}/library/methods
280%{_libdir}/%{name}/library/mgcv
281%{_libdir}/%{name}/library/nlme
282%{_libdir}/%{name}/library/nnet
283%{_libdir}/%{name}/library/rcompgen
284%{_libdir}/%{name}/library/rpart
285%{_libdir}/%{name}/library/spatial
286%{_libdir}/%{name}/library/survival
287%{_libdir}/%{name}/library/splines
288%{_libdir}/%{name}/library/stats
289%{_libdir}/%{name}/library/stats4
290%{_libdir}/%{name}/library/tcltk
291%{_libdir}/%{name}/library/tools
292%{_libdir}/%{name}/library/utils
293
294%{_pkgconfigdir}/*.pc
295
296%files recommended
297%defattr(644,root,root,755)
This page took 0.034767 seconds and 4 git commands to generate.