]> git.pld-linux.org Git - packages/sysprof.git/blame - sysprof.spec
- rel 2
[packages/sysprof.git] / sysprof.spec
CommitLineData
b0b4c66b
AM
1# Conditional build:
2%bcond_without dist_kernel # without distribution kernel
3%bcond_without kernel # don't build kernel modules
4%bcond_without userspace # don't build userspace tools
5#
66e95fb5 6%define rel 2
b0b4c66b
AM
7Summary: Sampling CPU profiler for Linux
8Name: sysprof
260d1a8f 9Version: 1.0.12
b0b4c66b
AM
10Release: %{rel}
11License: GPL v2
12Group: Applications/System
13Source0: http://www.daimi.au.dk/~sandmann/sysprof/%{name}-%{version}.tar.gz
260d1a8f 14# Source0-md5: 9566040f3175678e75133b1c52a473f8
b0b4c66b
AM
15URL: http://www.daimi.au.dk/~sandmann/sysprof/
16BuildRequires: binutils-devel
17BuildRequires: gtk+2-devel
18BuildRequires: rpmbuild(macros) >= 1.217
19Requires: uname(release) >= 2.6
20Conflicts: kernel < 2.6
66e95fb5 21ExclusiveArch: %{ix86} %{x8664}
b0b4c66b
AM
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Sysprof is a sampling CPU profiler for Linux that uses a kernel module
26to profile the entire system, not just a single application. Sysprof
27handles shared libraries and applications do not need to be
28recompiled. In fact they don't even have to be restarted.
29
30Just insert the kernel module and start sysprof.
31
32%package -n kernel%{_alt_kernel}-sysprof
33Summary: sysprof kernel driver
34Release: %{rel}@%{_kernel_ver_str}
35Group: Base/Kernel
36Requires(post,postun): /sbin/depmod
37%if %{with dist_kernel}
38%requires_releq_kernel
39Requires(postun): %releq_kernel
40%endif
41
42%description -n kernel%{_alt_kernel}-sysprof
43sysprof Linux kernel driver.
44
45%prep
46%setup -q
47
48%build
49%configure \
50 --disable-kernel-module
51%if %{with userspace}
52%{__make}
53%endif
54
55%if %{with kernel}
56cd module
57%build_kernel_modules SUBDIRS=$PWD -m sysprof-module
58%endif
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%if %{with userspace}
64%{__make} install \
65 DESTDIR=$RPM_BUILD_ROOT
66%endif
67
68%if %{with kernel}
69cd module
70%install_kernel_modules -m sysprof-module -d misc
71%endif
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
f8073522
ŁK
76%post -n kernel%{_alt_kernel}-sysprof
77%depmod %{_kernel_ver}
78
79%postun -n kernel%{_alt_kernel}-sysprof
80%depmod %{_kernel_ver}
81
b0b4c66b
AM
82%if %{with userspace}
83%files
84%defattr(644,root,root,755)
85%doc AUTHORS ChangeLog README TODO
86%attr(755,root,root) %{_bindir}/*
87%{_pixmapsdir}/*.png
88%{_datadir}/%{name}
89%endif
90
91%if %{with kernel}
92%files -n kernel%{_alt_kernel}-sysprof
93%defattr(644,root,root,755)
94/lib/modules/%{_kernel_ver}/misc/*.ko*
95%endif
This page took 0.032649 seconds and 4 git commands to generate.