]> git.pld-linux.org Git - packages/sysprof.git/blame - sysprof.spec
- ver. 1.0.10
[packages/sysprof.git] / sysprof.spec
CommitLineData
b0b4c66b
AM
1# Conditional build:
2%bcond_without dist_kernel # without distribution kernel
3%bcond_without kernel # don't build kernel modules
4%bcond_without userspace # don't build userspace tools
5#
6%define rel 1
7Summary: Sampling CPU profiler for Linux
8Name: sysprof
36d76210 9Version: 1.0.10
b0b4c66b
AM
10Release: %{rel}
11License: GPL v2
12Group: Applications/System
13Source0: http://www.daimi.au.dk/~sandmann/sysprof/%{name}-%{version}.tar.gz
36d76210 14# Source0-md5: 7e70e7f3cc40608d61c1431361a25459
b0b4c66b
AM
15URL: http://www.daimi.au.dk/~sandmann/sysprof/
16BuildRequires: binutils-devel
17BuildRequires: gtk+2-devel
18BuildRequires: rpmbuild(macros) >= 1.217
19Requires: uname(release) >= 2.6
20Conflicts: kernel < 2.6
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Sysprof is a sampling CPU profiler for Linux that uses a kernel module
25to profile the entire system, not just a single application. Sysprof
26handles shared libraries and applications do not need to be
27recompiled. In fact they don't even have to be restarted.
28
29Just insert the kernel module and start sysprof.
30
31%package -n kernel%{_alt_kernel}-sysprof
32Summary: sysprof kernel driver
33Release: %{rel}@%{_kernel_ver_str}
34Group: Base/Kernel
35Requires(post,postun): /sbin/depmod
36%if %{with dist_kernel}
37%requires_releq_kernel
38Requires(postun): %releq_kernel
39%endif
40
41%description -n kernel%{_alt_kernel}-sysprof
42sysprof Linux kernel driver.
43
44%prep
45%setup -q
46
47%build
48%configure \
49 --disable-kernel-module
50%if %{with userspace}
51%{__make}
52%endif
53
54%if %{with kernel}
55cd module
56%build_kernel_modules SUBDIRS=$PWD -m sysprof-module
57%endif
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%if %{with userspace}
63%{__make} install \
64 DESTDIR=$RPM_BUILD_ROOT
65%endif
66
67%if %{with kernel}
68cd module
69%install_kernel_modules -m sysprof-module -d misc
70%endif
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%if %{with userspace}
76%files
77%defattr(644,root,root,755)
78%doc AUTHORS ChangeLog README TODO
79%attr(755,root,root) %{_bindir}/*
80%{_pixmapsdir}/*.png
81%{_datadir}/%{name}
82%endif
83
84%if %{with kernel}
85%files -n kernel%{_alt_kernel}-sysprof
86%defattr(644,root,root,755)
87/lib/modules/%{_kernel_ver}/misc/*.ko*
88%endif
This page took 0.271819 seconds and 4 git commands to generate.