]> git.pld-linux.org Git - packages/suil.git/blame - suil.spec
- updated to 0.10.10
[packages/suil.git] / suil.spec
CommitLineData
a9e89817
JK
1#
2# Conditional build:
1e3d6834 3%bcond_without gtk # GTK+ (2,3) support
d6671a04 4%bcond_without qt4 # Qt4 support
1e3d6834 5%bcond_without qt5 # Qt5 support
a9e89817 6
ff9ca567
JB
7Summary: Lightweight C library for loading and wrapping LV2 plugin UIs
8Summary(pl.UTF-8): Lekka biblioteka C do ładowania i obudowywania UI wtyczek LV2
9Name: suil
f298c2f6 10Version: 0.10.10
533b3768 11Release: 1
ff9ca567
JB
12License: ISC
13Group: Libraries
14Source0: http://download.drobilla.net/%{name}-%{version}.tar.bz2
f298c2f6
JB
15# Source0-md5: 565c25c3b231e050642517a63627e64a
16Patch0: %{name}-build.patch
ff9ca567 17URL: http://drobilla.net/software/suil/
a9e89817 18%{?with_qt4:BuildRequires: QtGui-devel >= 4.4.0}
1e3d6834
JB
19%{?with_qt5:BuildRequires: Qt5Widgets-devel >= 5.1.0}
20%{?with_gtk:BuildRequires: gtk+2-devel >= 2:2.18.0}
21%{?with_gtk:BuildRequires: gtk+3-devel >= 3.14.0}
ff9ca567 22BuildRequires: libstdc++-devel
533b3768 23BuildRequires: lv2-devel >= 1.16.0
f298c2f6 24BuildRequires: python >= 2
ff9ca567
JB
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Suil is a lightweight C library for loading and wrapping LV2 plugin
29UIs.
30
31Suil makes it possible to load a UI of any toolkit in a host using any
32other toolkit (assuming the toolkits are both supported by Suil).
33Hosts do not need to build against or link to foreign toolkit
34libraries to use UIs written with that toolkit (Suil performs its
35magic at runtime using dynamically loaded modules). The API is
36designed such that hosts do not need to explicitly support particular
37toolkits whatsoever - if Suil supports a particular toolkit, then all
38hosts that use Suil will support that toolkit "for free".
39
40%description -l pl.UTF-8
41Suil to lekka biblioteka C do ładowania i obudowywania interfejsów
42użytkownika (UI) wtyczek LV2.
43
44Suil umożliwia wczytanie UI dowolnego toolkitu do hosta
45wykorzystującego dowolny inny toolkit (zakładając, że oba toolkity są
46obsługiwane prez Suil). Hosty nie muszą być budowane z obsługą obcych
47bibliotek toolkitów, aby można było używać UI napisanego z użyciem
48danego toolkitu (Suil wykonuje całą potrzebną magię w czasie działania
49przy użyciu modułów ładowanych dynamicznie). API jest zaprojektowane
50tak, że hosty nie muszą jawnie obsługiwać konkretnego toolkitu - jeśli
51Suil obsługuje ten toolkit, to wszystkie hosty wykorzystujące Suil
52będą obsługiwały ten toolkit za darmo.
53
54%package modules
55Summary: UI wrapper modules for suil library
56Summary(pl.UTF-8): Moduły obudowujące UI dla biblioteki suil
57Group: Libraries
58Requires: %{name} = %{version}-%{release}
1e3d6834
JB
59%{?with_qt4:Requires: QtGui >= 4.4.0}
60%{?with_qt5:Requires: Qt5Widgets >= 5.1.0}
61%{?with_gtk:Requires: gtk+2 >= 2:2.18.0}
62%{?with_gtk:Requires: gtk+3 >= 3.14.0}
ff9ca567
JB
63
64%description modules
65Dynamically loaded modules for suil library, allowing to use X11
66UIs in GTK+ or Qt host, GTK+ UI in Qt host, Qt UI in GTK+ host.
67
68%description modules -l pl.UTF-8
69Dynamicznie wczytywane moduły dla biblioteki suil, pozwalające na
70używanie interfejsów użytkownika X11 w hostach GTK+ lub Qt,
71interfejsów GTK+ w hostach Qt oraz interfejsów Qt w hostach GTK+.
72
73%package devel
74Summary: Header files for suil library
75Summary(pl.UTF-8): Pliki nagłówkowe biblioteki suil
76Group: Development/Libraries
77Requires: %{name} = %{version}-%{release}
533b3768 78Requires: lv2-devel >= 1.16.0
ff9ca567
JB
79
80%description devel
81Header files for suil library.
82
83%description devel -l pl.UTF-8
84Pliki nagłówkowe biblioteki suil.
85
86%prep
87%setup -q
f298c2f6 88%patch0 -p1
ff9ca567
JB
89
90%build
91CC="%{__cc}" \
92CFLAGS="%{rpmcflags}" \
93./waf configure \
94 --prefix=%{_prefix} \
95 --libdir=%{_libdir} \
1e3d6834
JB
96 --gtk2-lib-name=libgtk-x11-2.0.so.0 \
97 --gtk3-lib-name=libgtk-3.so.0 \
98 %{!?with_gtk:--no-gtk} \
99 %{!?with_qt4:--no-qt4} \
100 %{!?with_qt4:--no-qt4} \
101 %{!?with_qt5:--no-qt5}
ff9ca567
JB
102
103./waf -v
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108./waf install \
109 --destdir=$RPM_BUILD_ROOT
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
ae4c37ba 119%doc AUTHORS COPYING NEWS README.md
ff9ca567
JB
120%attr(755,root,root) %{_libdir}/libsuil-0.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libsuil-0.so.0
122%dir %{_libdir}/suil-0
123
124%files modules
125%defattr(644,root,root,755)
1e3d6834
JB
126%attr(755,root,root) %{_libdir}/suil-0/libsuil_x11.so
127%if %{with gtk}
ff9ca567 128%attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk2.so
ae4c37ba 129%attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk3.so
1e3d6834 130%endif
a9e89817 131%if %{with qt4}
a9e89817 132%attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt4.so
1e3d6834
JB
133%endif
134%if %{with qt5}
135%attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt5.so
136%endif
137%if %{with gtk} && %{with qt4}
138%attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt4.so
ff9ca567 139%attr(755,root,root) %{_libdir}/suil-0/libsuil_qt4_in_gtk2.so
a9e89817 140%endif
1e3d6834
JB
141%if %{with gtk} && %{with qt5}
142%attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt5.so
143%attr(755,root,root) %{_libdir}/suil-0/libsuil_qt5_in_gtk2.so
533b3768 144%attr(755,root,root) %{_libdir}/suil-0/libsuil_qt5_in_gtk3.so
1e3d6834 145%endif
ff9ca567
JB
146
147%files devel
148%defattr(644,root,root,755)
149%attr(755,root,root) %{_libdir}/libsuil-0.so
150%{_includedir}/suil-0
151%{_pkgconfigdir}/suil-0.pc
This page took 0.108223 seconds and 4 git commands to generate.