]> git.pld-linux.org Git - packages/suil.git/commitdiff
- updated to 0.10.10 auto/th/suil-0.10.10-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Jan 2021 21:12:31 +0000 (22:12 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Jan 2021 21:12:31 +0000 (22:12 +0100)
- added build patch (fix build of qt4-related modules)

suil-build.patch [new file with mode: 0644]
suil.spec

diff --git a/suil-build.patch b/suil-build.patch
new file mode 100644 (file)
index 0000000..b7ad0da
--- /dev/null
@@ -0,0 +1,36 @@
+--- suil-0.10.10/src/gtk2_in_qt4.cpp.orig      2021-01-02 16:14:16.063443200 +0100
++++ suil-0.10.10/src/gtk2_in_qt4.cpp   2021-01-10 22:10:07.636286700 +0100
+@@ -27,9 +27,7 @@
+ extern "C" {
+-using SuilGtk2InQt4Wrapper = _SuilGtk2InQt4Wrapper;
+-
+-struct _SuilGtk2InQt4Wrapper {
++struct SuilGtk2InQt4Wrapper {
+   QX11EmbedContainer* host_widget;
+   QWidget*            parent;
+   GtkWidget*          plug;
+--- suil-0.10.10/src/qt4_in_gtk2.cpp.orig      2021-01-02 16:14:16.063443200 +0100
++++ suil-0.10.10/src/qt4_in_gtk2.cpp   2021-01-10 22:10:27.692844711 +0100
+@@ -30,10 +30,7 @@
+ #define SUIL_QT_WRAPPER(obj) \
+   (G_TYPE_CHECK_INSTANCE_CAST((obj), SUIL_TYPE_QT_WRAPPER, SuilQtWrapper))
+-using SuilQtWrapper      = _SuilQtWrapper;
+-using SuilQtWrapperClass = _SuilQtWrapperClass;
+-
+-struct _SuilQtWrapper {
++struct SuilQtWrapper {
+   GtkSocket        socket;
+   QApplication*    app;
+   QX11EmbedWidget* qembed;
+@@ -41,7 +38,7 @@
+   SuilInstance*    instance;
+ };
+-struct _SuilQtWrapperClass {
++struct SuilQtWrapperClass {
+   GtkSocketClass parent_class;
+ };
index fc9df972f35b92e7c8068ac2a8781254e7112d51..7a6e853572d4f852248899ce8c2775afee781659 100644 (file)
--- a/suil.spec
+++ b/suil.spec
@@ -7,12 +7,13 @@
 Summary:       Lightweight C library for loading and wrapping LV2 plugin UIs
 Summary(pl.UTF-8):     Lekka biblioteka C do ładowania i obudowywania UI wtyczek LV2
 Name:          suil
-Version:       0.10.6
+Version:       0.10.10
 Release:       1
 License:       ISC
 Group:         Libraries
 Source0:       http://download.drobilla.net/%{name}-%{version}.tar.bz2
-# Source0-md5: 12c87f830c06d280e2826fae7bc6dd86
+# Source0-md5: 565c25c3b231e050642517a63627e64a
+Patch0:                %{name}-build.patch
 URL:           http://drobilla.net/software/suil/
 %{?with_qt4:BuildRequires:     QtGui-devel >= 4.4.0}
 %{?with_qt5:BuildRequires:     Qt5Widgets-devel >= 5.1.0}
@@ -20,7 +21,7 @@ URL:          http://drobilla.net/software/suil/
 %{?with_gtk:BuildRequires:     gtk+3-devel >= 3.14.0}
 BuildRequires: libstdc++-devel
 BuildRequires: lv2-devel >= 1.16.0
-BuildRequires: python
+BuildRequires: python >= 2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -84,6 +85,7 @@ Pliki nagłówkowe biblioteki suil.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 CC="%{__cc}" \
This page took 0.129776 seconds and 4 git commands to generate.