]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
support icu enabling
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
17b8c9f1 4#
5# Conditional build:
d12e8042 6%bcond_with tests # run tests
dd55e3fd 7%bcond_without tcl # Tcl extension
d12e8042
JB
8%bcond_without doc # disable documentation building
9%bcond_without unlock_notify # disable unlock notify API
60f66380 10%bcond_without load_extension # enable load extension API
e0fdf246 11%bcond_with icu # ICU tokenizer support
5df4522e 12
f1015391
JR
13%ifarch alpha sparc %{x8664}
14%undefine with_tests
15%endif
16
17# disabling tcl currently breaks making test target,
18# some hack in Makefile needs to be done
5df4522e 19%if %{without tcl}
f1015391
JR
20%undefine with_tests
21%endif
22
7e2f6050 23#define version_num %(echo %{version} | awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
625d6d92 24%define version_num 3071602
65cfa56f 25%define _ulibdir /usr/lib
539069d8 26%define tclver 8.5
f1015391 27
17b8c9f1 28Summary: SQLite library
e882a99f 29Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 30Name: sqlite3
625d6d92 31Version: 3.7.16.2
a20aff57 32Release: 1
dd55e3fd 33License: Public Domain
17b8c9f1 34Group: Libraries
65cfa56f 35# Source0Download: http://www.sqlite.org/download.html
e4bb9672 36Source0: http://www.sqlite.org/2013/sqlite-src-%{version_num}.zip
625d6d92 37# Source0-md5: 0d821779acdb56eee1fd71343b41a1cc
a3d8a32d 38Patch0: %{name}-sign-function.patch
65cfa56f 39URL: http://www.sqlite.org/
d70f95dc 40%{?with_load_extension:Provides: %{name}(load_extension)}
41%{?with_unlock_notify:Provides: %{name}(unlock_notify)}
e0fdf246 42%{?with_icu:Provides: %{name}(icu)}
dd55e3fd 43BuildRequires: autoconf >= 2.50
17b8c9f1 44BuildRequires: automake
45BuildRequires: libtool
46BuildRequires: readline-devel
6ca4ac16 47%{?with_load_extension:BuildRequires: sed >= 4.0}
0e44e992 48BuildRequires: tcl
1a6aae8d 49%{?with_tcl:BuildRequires: tcl-devel}
086e11d9 50BuildRequires: unzip
17b8c9f1 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54SQLite is a C library that implements an SQL database engine. A large
55subset of SQL92 is supported. A complete database is stored in a
56single disk file. The API is designed for convenience and ease of use.
57Applications that link against SQLite can enjoy the power and
58flexiblity of an SQL database without the administrative hassles of
59supporting a separate database server. Because it omits the
60client-server interaction overhead and writes directly to disk, SQLite
61is also faster than the big database servers for most operations. In
62addition to the C library, the SQLite distribution includes a
63command-line tool for interacting with SQLite databases and SQLite
64bindings for Tcl/Tk.
65
b7c0e1f2
JR
66%description -l pl.UTF-8
67SQLite jest biblioteką języka C, która implementuje silnik baz danych
68SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
69przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
70bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
71danych bez konieczności utrzymywania osobnego serwera baz danych.
72Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
73bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
74bazodanowych przy większości operacji na bazie danych. Dodatkowo
75oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 76bazami danych.
77
78%package devel
79Summary: Header files for SQLite development
e882a99f 80Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
d70f95dc 83%if %{with unlock_notify}
d70f95dc 84Provides: %{name}-devel(unlock_notify)
85%endif
86%if %{with load_extension}
d70f95dc 87Provides: %{name}-devel(load_extension)
88%endif
e0fdf246
ER
89%if %{with icu}
90Provides: %{name}-devel(icu)
91%endif
17b8c9f1 92
93%description devel
94SQLite is a C library that implements an SQL database engine. A large
95subset of SQL92 is supported. A complete database is stored in a
96single disk file. The API is designed for convenience and ease of use.
97Applications that link against SQLite can enjoy the power and
98flexiblity of an SQL database without the administrative hassles of
99supporting a separate database server. Because it omits the
100client-server interaction overhead and writes directly to disk, SQLite
101is also faster than the big database servers for most operations. In
102addition to the C library, the SQLite distribution includes a
103command-line tool for interacting with SQLite databases and SQLite
104bindings for Tcl/Tk.
105
106This package contains the header files needed to develop programs that
107use these SQLite.
108
b7c0e1f2
JR
109%description devel -l pl.UTF-8
110SQLite jest biblioteką języka C, która implementuje silnik baz danych
111SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
112przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
113bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
114danych bez konieczności utrzymywania osobnego serwera baz danych.
115Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
116bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
117bazodanowych przy większości operacji na bazie danych. Dodatkowo
118oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 119bazami danych.
120
b7c0e1f2
JR
121Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
122używających biblioteki SQLite.
17b8c9f1 123
124%package static
125Summary: Static libraries for SQLite development
e882a99f 126Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 127Group: Development/Libraries
128Requires: %{name}-devel = %{version}-%{release}
d70f95dc 129%if %{with unclock_notify}
d70f95dc 130Provides: %{name}-static(unlock_notify)
131%endif
132%if %{with load_extension}
d70f95dc 133Provides: %{name}-static(load_extension)
134%endif
17b8c9f1 135
136%description static
137SQLite is a C library that implements an SQL database engine. A large
138subset of SQL92 is supported. A complete database is stored in a
139single disk file. The API is designed for convenience and ease of use.
140Applications that link against SQLite can enjoy the power and
141flexiblity of an SQL database without the administrative hassles of
142supporting a separate database server. Because it omits the
143client-server interaction overhead and writes directly to disk, SQLite
144is also faster than the big database servers for most operations. In
145addition to the C library, the SQLite distribution includes a
146command-line tool for interacting with SQLite databases and SQLite
147bindings for Tcl/Tk.
148
149This package contains the static SQLite libraries.
150
b7c0e1f2
JR
151%description static -l pl.UTF-8
152SQLite jest biblioteką języka C, która implementuje silnik baz danych
153SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
154przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
155bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
156danych bez konieczności utrzymywania osobnego serwera baz danych.
157Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
158bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
159bazodanowych przy większości operacji na bazie danych. Dodatkowo
160oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 161bazami danych.
162
163Pakiet zawiera statyczne biblioteki SQLite.
164
c743401f 165%package -n tcl-%{name}
8e66772b 166Summary: sqlite3 tcl extension
e882a99f 167Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 168Group: Development/Languages/Tcl
c743401f
AM
169
170%description -n tcl-%{name}
171sqlite3 tcl extension.
172
b7c0e1f2 173%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
174Rozszerzenie sqlite3 dla Tcl.
175
17b8c9f1 176%prep
c883dce2 177%setup -q -n sqlite-src-%{version_num}
30682d5a 178%patch0 -p1
1cd2f537 179
faed6cf7
ER
180%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
181
17b8c9f1 182%build
183%{__libtoolize}
184cp -f /usr/share/automake/config.sub .
185%{__aclocal}
186%{__autoconf}
e0fdf246
ER
187export CFLAGS="%{rpmcflags}
188 -DSQLITE_ENABLE_COLUMN_METADATA=1
189 -DSQLITE_DISABLE_DIRSYNC=1
190 -DSQLITE_ENABLE_FTS3=3
191 -DSQLITE_ENABLE_RTREE=1
192 -DSQLITE_SECURE_DELETE
193 %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}
194 %{?with_icu:-DSQLITE_ENABLE_ICU}
195"
196export LIBS="%{?with_load_extension:-ldl} %{?with_icu:-licui18n -licuuc}"
87af9815
MB
197%if %{with tcl}
198export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
199%endif
e0fdf246 200
17b8c9f1 201%configure \
e0fdf246 202 %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
60f66380 203 %{__enable_disable load_extension load-extension} \
17b8c9f1 204 --enable-threadsafe
60f66380 205
5df4522e 206%{__make}
1a6aae8d 207
e16bc4b1 208%if %{with doc}
17b8c9f1 209%{__make} doc
1a6aae8d 210%endif
17b8c9f1 211
3e5df83c 212%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 213
214%install
215rm -rf $RPM_BUILD_ROOT
1c91d9d5 216install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
17b8c9f1 217%{__make} install \
dd55e3fd 218 DESTDIR=$RPM_BUILD_ROOT
ec30f86a 219
1c91d9d5 220mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
dd55e3fd 221%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
1c91d9d5
JR
222ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
223 $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
224
e0fdf246 225cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 226
227%clean
228rm -rf $RPM_BUILD_ROOT
229
230%post -p /sbin/ldconfig
231%postun -p /sbin/ldconfig
232
233%files
234%defattr(644,root,root,755)
235%doc README
236%attr(755,root,root) %{_bindir}/sqlite3
1c91d9d5
JR
237%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
238%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
c743401f 239%{_mandir}/man1/sqlite3.1*
17b8c9f1 240
241%files devel
242%defattr(644,root,root,755)
7e92c022
JB
243%attr(755,root,root) %{_libdir}/libsqlite3.so
244%{_libdir}/libsqlite3.la
17b8c9f1 245%{_includedir}/sqlite3.h
ef88c71c 246%{_includedir}/sqlite3ext.h
7e92c022 247%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 248
249%files static
250%defattr(644,root,root,755)
7e92c022 251%{_libdir}/libsqlite3.a
c743401f 252
1a6aae8d 253%if %{with tcl}
c743401f
AM
254%files -n tcl-%{name}
255%defattr(644,root,root,755)
80deaf18 256%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
257%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
258%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 259%endif
This page took 0.143145 seconds and 4 git commands to generate.