]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- updated to 3.6.19
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
65cfa56f
ER
4# - alpha build fail:
5# tclsh ./tool/mksqlite3c.tcl
6# tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
7# make: *** [sqlite3.c] Aborted
8ef92c1a 8# - enable --enable-load-extension?
17b8c9f1 9#
10# Conditional build:
f1015391 11%bcond_with tests # run tests
158e8e57 12%bcond_with tcl # enable tcl extension
f1015391 13%bcond_without doc # disable documentation building
17b8c9f1 14#
f1015391
JR
15%ifarch alpha sparc %{x8664}
16%undefine with_tests
17%endif
18
19# disabling tcl currently breaks making test target,
20# some hack in Makefile needs to be done
21%if !%{with tcl}
22%undefine with_tests
23%endif
24
65cfa56f 25%define _ulibdir /usr/lib
539069d8 26%define tclver 8.5
f1015391 27
17b8c9f1 28Summary: SQLite library
e882a99f 29Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 30Name: sqlite3
9353a24f 31Version: 3.6.19
1fafea49 32Release: 1
17b8c9f1 33License: LGPL
34Group: Libraries
65cfa56f
ER
35# Source0Download: http://www.sqlite.org/download.html
36Source0: http://www.sqlite.org/sqlite-%{version}.tar.gz
9353a24f 37# Source0-md5: aa03cc24a52851bb204fc1e489e195e8
a3d8a32d 38Patch0: %{name}-sign-function.patch
65cfa56f 39URL: http://www.sqlite.org/
17b8c9f1 40BuildRequires: autoconf
41BuildRequires: automake
42BuildRequires: libtool
43BuildRequires: readline-devel
1a6aae8d 44%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
48SQLite is a C library that implements an SQL database engine. A large
49subset of SQL92 is supported. A complete database is stored in a
50single disk file. The API is designed for convenience and ease of use.
51Applications that link against SQLite can enjoy the power and
52flexiblity of an SQL database without the administrative hassles of
53supporting a separate database server. Because it omits the
54client-server interaction overhead and writes directly to disk, SQLite
55is also faster than the big database servers for most operations. In
56addition to the C library, the SQLite distribution includes a
57command-line tool for interacting with SQLite databases and SQLite
58bindings for Tcl/Tk.
59
b7c0e1f2
JR
60%description -l pl.UTF-8
61SQLite jest biblioteką języka C, która implementuje silnik baz danych
62SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
63przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
64bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
65danych bez konieczności utrzymywania osobnego serwera baz danych.
66Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
67bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
68bazodanowych przy większości operacji na bazie danych. Dodatkowo
69oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 70bazami danych.
71
72%package devel
73Summary: Header files for SQLite development
e882a99f 74Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77
78%description devel
79SQLite is a C library that implements an SQL database engine. A large
80subset of SQL92 is supported. A complete database is stored in a
81single disk file. The API is designed for convenience and ease of use.
82Applications that link against SQLite can enjoy the power and
83flexiblity of an SQL database without the administrative hassles of
84supporting a separate database server. Because it omits the
85client-server interaction overhead and writes directly to disk, SQLite
86is also faster than the big database servers for most operations. In
87addition to the C library, the SQLite distribution includes a
88command-line tool for interacting with SQLite databases and SQLite
89bindings for Tcl/Tk.
90
91This package contains the header files needed to develop programs that
92use these SQLite.
93
b7c0e1f2
JR
94%description devel -l pl.UTF-8
95SQLite jest biblioteką języka C, która implementuje silnik baz danych
96SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
97przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
98bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
99danych bez konieczności utrzymywania osobnego serwera baz danych.
100Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
101bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
102bazodanowych przy większości operacji na bazie danych. Dodatkowo
103oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 104bazami danych.
105
b7c0e1f2
JR
106Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
107używających biblioteki SQLite.
17b8c9f1 108
109%package static
110Summary: Static libraries for SQLite development
e882a99f 111Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 112Group: Development/Libraries
113Requires: %{name}-devel = %{version}-%{release}
114
115%description static
116SQLite is a C library that implements an SQL database engine. A large
117subset of SQL92 is supported. A complete database is stored in a
118single disk file. The API is designed for convenience and ease of use.
119Applications that link against SQLite can enjoy the power and
120flexiblity of an SQL database without the administrative hassles of
121supporting a separate database server. Because it omits the
122client-server interaction overhead and writes directly to disk, SQLite
123is also faster than the big database servers for most operations. In
124addition to the C library, the SQLite distribution includes a
125command-line tool for interacting with SQLite databases and SQLite
126bindings for Tcl/Tk.
127
128This package contains the static SQLite libraries.
129
b7c0e1f2
JR
130%description static -l pl.UTF-8
131SQLite jest biblioteką języka C, która implementuje silnik baz danych
132SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
133przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
134bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
135danych bez konieczności utrzymywania osobnego serwera baz danych.
136Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
137bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
138bazodanowych przy większości operacji na bazie danych. Dodatkowo
139oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 140bazami danych.
141
142Pakiet zawiera statyczne biblioteki SQLite.
143
c743401f 144%package -n tcl-%{name}
8e66772b 145Summary: sqlite3 tcl extension
e882a99f 146Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 147Group: Development/Languages/Tcl
c743401f
AM
148
149%description -n tcl-%{name}
150sqlite3 tcl extension.
151
b7c0e1f2 152%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
153Rozszerzenie sqlite3 dla Tcl.
154
17b8c9f1 155%prep
c743401f 156%setup -q -n sqlite-%{version}
30682d5a 157%patch0 -p1
1cd2f537 158
faed6cf7
ER
159%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
160
161%ifarch alpha
162# See also LP#276821
163# wrapper script to reset stack to 8192 as if ran from make it's insanely huge!:
164# stack(kbytes) 18014398509481983
165cat <<'EOF' > tclsh.sh
166#!/bin/sh
167ulimit -s 8192
168exec tclsh "$@"
169EOF
170chmod +x tclsh.sh
171%endif
17b8c9f1 172
173%build
174%{__libtoolize}
175cp -f /usr/share/automake/config.sub .
176%{__aclocal}
177%{__autoconf}
f1015391
JR
178CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
179export CFLAGS
17b8c9f1 180%configure \
1a6aae8d 181 %{?with_tcl:--with-tcl=%{_ulibdir}} \
182 %{!?with_tcl:--disable-tcl} \
17b8c9f1 183 --enable-threadsafe
faed6cf7
ER
184%{__make} \
185%ifarch alpha
186 TCLSH_CMD=./tclsh.sh
187%endif
1a6aae8d 188
e16bc4b1 189%if %{with doc}
17b8c9f1 190%{__make} doc
1a6aae8d 191%endif
17b8c9f1 192
3e5df83c 193%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 194
195%install
196rm -rf $RPM_BUILD_ROOT
197install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
198
199%{__make} install \
faed6cf7
ER
200%ifarch alpha
201 TCLSH_CMD=./tclsh.sh \
202%endif
80deaf18
JR
203 DESTDIR=$RPM_BUILD_ROOT \
204 TCLLIBDIR=%{_libdir}/tcl%{tclver}
17b8c9f1 205
22de4c1c 206%if %{with tcl}
7e92c022 207sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
22de4c1c 208%endif
ec30f86a 209
c743401f 210install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 211
212%clean
213rm -rf $RPM_BUILD_ROOT
214
215%post -p /sbin/ldconfig
216%postun -p /sbin/ldconfig
217
218%files
219%defattr(644,root,root,755)
220%doc README
221%attr(755,root,root) %{_bindir}/sqlite3
7e92c022
JB
222%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
223%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
c743401f 224%{_mandir}/man1/sqlite3.1*
17b8c9f1 225
226%files devel
227%defattr(644,root,root,755)
7e92c022
JB
228%attr(755,root,root) %{_libdir}/libsqlite3.so
229%{_libdir}/libsqlite3.la
17b8c9f1 230%{_includedir}/sqlite3.h
ef88c71c 231%{_includedir}/sqlite3ext.h
7e92c022 232%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 233
234%files static
235%defattr(644,root,root,755)
7e92c022 236%{_libdir}/libsqlite3.a
c743401f 237
1a6aae8d 238%if %{with tcl}
c743401f
AM
239%files -n tcl-%{name}
240%defattr(644,root,root,755)
80deaf18 241%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
242%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
243%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 244%endif
This page took 0.099747 seconds and 4 git commands to generate.