]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- up to 3.7.13, cleanup macros
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
8ef92c1a 4# - enable --enable-load-extension?
17b8c9f1 5#
6# Conditional build:
d12e8042 7%bcond_with tests # run tests
dd55e3fd 8%bcond_without tcl # Tcl extension
d12e8042
JB
9%bcond_without doc # disable documentation building
10%bcond_without unlock_notify # disable unlock notify API
11%bcond_with load_extension # enable load extension API
5df4522e 12
f1015391
JR
13%ifarch alpha sparc %{x8664}
14%undefine with_tests
15%endif
16
17# disabling tcl currently breaks making test target,
18# some hack in Makefile needs to be done
5df4522e 19%if %{without tcl}
f1015391
JR
20%undefine with_tests
21%endif
22
c883dce2 23%define version_num %(echo %{version} | awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
65cfa56f 24%define _ulibdir /usr/lib
539069d8 25%define tclver 8.5
f1015391 26
17b8c9f1 27Summary: SQLite library
e882a99f 28Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 29Name: sqlite3
c883dce2 30Version: 3.7.13
1dca1e50 31Release: 1
dd55e3fd 32License: Public Domain
17b8c9f1 33Group: Libraries
65cfa56f 34# Source0Download: http://www.sqlite.org/download.html
c883dce2
ER
35Source0: http://www.sqlite.org/sqlite-src-%{version_num}.zip
36# Source0-md5: 13bb3eaae94592ef3220ea23582763f5
a3d8a32d 37Patch0: %{name}-sign-function.patch
65cfa56f 38URL: http://www.sqlite.org/
d70f95dc 39%{?with_load_extension:Provides: %{name}(load_extension)}
40%{?with_unlock_notify:Provides: %{name}(unlock_notify)}
dd55e3fd 41BuildRequires: autoconf >= 2.50
17b8c9f1 42BuildRequires: automake
43BuildRequires: libtool
44BuildRequires: readline-devel
6ca4ac16 45%{?with_load_extension:BuildRequires: sed >= 4.0}
0e44e992 46BuildRequires: tcl
1a6aae8d 47%{?with_tcl:BuildRequires: tcl-devel}
086e11d9 48BuildRequires: unzip
17b8c9f1 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52SQLite is a C library that implements an SQL database engine. A large
53subset of SQL92 is supported. A complete database is stored in a
54single disk file. The API is designed for convenience and ease of use.
55Applications that link against SQLite can enjoy the power and
56flexiblity of an SQL database without the administrative hassles of
57supporting a separate database server. Because it omits the
58client-server interaction overhead and writes directly to disk, SQLite
59is also faster than the big database servers for most operations. In
60addition to the C library, the SQLite distribution includes a
61command-line tool for interacting with SQLite databases and SQLite
62bindings for Tcl/Tk.
63
b7c0e1f2
JR
64%description -l pl.UTF-8
65SQLite jest biblioteką języka C, która implementuje silnik baz danych
66SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
67przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
68bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
69danych bez konieczności utrzymywania osobnego serwera baz danych.
70Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
71bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
72bazodanowych przy większości operacji na bazie danych. Dodatkowo
73oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 74bazami danych.
75
76%package devel
77Summary: Header files for SQLite development
e882a99f 78Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
d70f95dc 81%if %{with unlock_notify}
82Requires: %{name}(unlock_notify)
83Provides: %{name}-devel(unlock_notify)
84%endif
85%if %{with load_extension}
86Requires: %{name}(load_extension)
87Provides: %{name}-devel(load_extension)
88%endif
17b8c9f1 89
90%description devel
91SQLite is a C library that implements an SQL database engine. A large
92subset of SQL92 is supported. A complete database is stored in a
93single disk file. The API is designed for convenience and ease of use.
94Applications that link against SQLite can enjoy the power and
95flexiblity of an SQL database without the administrative hassles of
96supporting a separate database server. Because it omits the
97client-server interaction overhead and writes directly to disk, SQLite
98is also faster than the big database servers for most operations. In
99addition to the C library, the SQLite distribution includes a
100command-line tool for interacting with SQLite databases and SQLite
101bindings for Tcl/Tk.
102
103This package contains the header files needed to develop programs that
104use these SQLite.
105
b7c0e1f2
JR
106%description devel -l pl.UTF-8
107SQLite jest biblioteką języka C, która implementuje silnik baz danych
108SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
109przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
110bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
111danych bez konieczności utrzymywania osobnego serwera baz danych.
112Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
113bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
114bazodanowych przy większości operacji na bazie danych. Dodatkowo
115oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 116bazami danych.
117
b7c0e1f2
JR
118Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
119używających biblioteki SQLite.
17b8c9f1 120
121%package static
122Summary: Static libraries for SQLite development
e882a99f 123Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 124Group: Development/Libraries
125Requires: %{name}-devel = %{version}-%{release}
d70f95dc 126%if %{with unclock_notify}
127Requires: %{name}-devel(unlock_notify)
128Provides: %{name}-static(unlock_notify)
129%endif
130%if %{with load_extension}
131Requires: %{name}-devel(load_extension)
132Provides: %{name}-static(load_extension)
133%endif
17b8c9f1 134
135%description static
136SQLite is a C library that implements an SQL database engine. A large
137subset of SQL92 is supported. A complete database is stored in a
138single disk file. The API is designed for convenience and ease of use.
139Applications that link against SQLite can enjoy the power and
140flexiblity of an SQL database without the administrative hassles of
141supporting a separate database server. Because it omits the
142client-server interaction overhead and writes directly to disk, SQLite
143is also faster than the big database servers for most operations. In
144addition to the C library, the SQLite distribution includes a
145command-line tool for interacting with SQLite databases and SQLite
146bindings for Tcl/Tk.
147
148This package contains the static SQLite libraries.
149
b7c0e1f2
JR
150%description static -l pl.UTF-8
151SQLite jest biblioteką języka C, która implementuje silnik baz danych
152SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
153przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
154bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
155danych bez konieczności utrzymywania osobnego serwera baz danych.
156Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
157bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
158bazodanowych przy większości operacji na bazie danych. Dodatkowo
159oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 160bazami danych.
161
162Pakiet zawiera statyczne biblioteki SQLite.
163
c743401f 164%package -n tcl-%{name}
8e66772b 165Summary: sqlite3 tcl extension
e882a99f 166Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 167Group: Development/Languages/Tcl
c743401f
AM
168
169%description -n tcl-%{name}
170sqlite3 tcl extension.
171
b7c0e1f2 172%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
173Rozszerzenie sqlite3 dla Tcl.
174
17b8c9f1 175%prep
c883dce2 176%setup -q -n sqlite-src-%{version_num}
30682d5a 177%patch0 -p1
1cd2f537 178
faed6cf7
ER
179%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
180
17b8c9f1 181%build
182%{__libtoolize}
183cp -f /usr/share/automake/config.sub .
184%{__aclocal}
185%{__autoconf}
6ca4ac16 186CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}"
f1015391 187export CFLAGS
6ca4ac16 188%if %{with load_extension}
189LIBS=-ldl
190export LIBS
191%endif
87af9815
MB
192%if %{with tcl}
193export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
194%endif
17b8c9f1 195%configure \
1a6aae8d 196 %{?with_tcl:--with-tcl=%{_ulibdir}} \
197 %{!?with_tcl:--disable-tcl} \
17b8c9f1 198 --enable-threadsafe
6ca4ac16 199%{?with_load_extension:sed -i~ s/-DSQLITE_OMIT_LOAD_EXTENSION=1// Makefile}
5df4522e 200%{__make}
1a6aae8d 201
e16bc4b1 202%if %{with doc}
17b8c9f1 203%{__make} doc
1a6aae8d 204%endif
17b8c9f1 205
3e5df83c 206%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 207
208%install
209rm -rf $RPM_BUILD_ROOT
1c91d9d5 210install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
17b8c9f1 211
212%{__make} install \
dd55e3fd 213 DESTDIR=$RPM_BUILD_ROOT
ec30f86a 214
1c91d9d5 215mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
dd55e3fd 216%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
1c91d9d5
JR
217ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
218 $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
219
5df4522e 220cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 221
222%clean
223rm -rf $RPM_BUILD_ROOT
224
225%post -p /sbin/ldconfig
226%postun -p /sbin/ldconfig
227
228%files
229%defattr(644,root,root,755)
230%doc README
231%attr(755,root,root) %{_bindir}/sqlite3
1c91d9d5
JR
232%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
233%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
c743401f 234%{_mandir}/man1/sqlite3.1*
17b8c9f1 235
236%files devel
237%defattr(644,root,root,755)
7e92c022
JB
238%attr(755,root,root) %{_libdir}/libsqlite3.so
239%{_libdir}/libsqlite3.la
17b8c9f1 240%{_includedir}/sqlite3.h
ef88c71c 241%{_includedir}/sqlite3ext.h
7e92c022 242%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 243
244%files static
245%defattr(644,root,root,755)
7e92c022 246%{_libdir}/libsqlite3.a
c743401f 247
1a6aae8d 248%if %{with tcl}
c743401f
AM
249%files -n tcl-%{name}
250%defattr(644,root,root,755)
80deaf18 251%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
252%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
253%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 254%endif
This page took 0.086886 seconds and 4 git commands to generate.