]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- up to 3.8.8.3
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
17b8c9f1 4#
5# Conditional build:
d12e8042 6%bcond_with tests # run tests
dd55e3fd 7%bcond_without tcl # Tcl extension
d12e8042
JB
8%bcond_without doc # disable documentation building
9%bcond_without unlock_notify # disable unlock notify API
60f66380 10%bcond_without load_extension # enable load extension API
e0fdf246 11%bcond_with icu # ICU tokenizer support
5df4522e 12
f1015391
JR
13%ifarch alpha sparc %{x8664}
14%undefine with_tests
15%endif
16
17# disabling tcl currently breaks making test target,
18# some hack in Makefile needs to be done
5df4522e 19%if %{without tcl}
f1015391
JR
20%undefine with_tests
21%endif
22
83befcd8
AO
23%define version_year 2015
24%define version_num %(echo %{version} | awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
65cfa56f 25%define _ulibdir /usr/lib
a8925d97 26%define tclver 8.6
f1015391 27
17b8c9f1 28Summary: SQLite library
e882a99f 29Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 30Name: sqlite3
83befcd8 31Version: 3.8.8.3
f11168e1 32Release: 3
dd55e3fd 33License: Public Domain
17b8c9f1 34Group: Libraries
65cfa56f 35# Source0Download: http://www.sqlite.org/download.html
83befcd8
AO
36Source0: http://www.sqlite.org/%{version_year}/sqlite-src-%{version_num}.zip
37# Source0-md5: 7aed8084e18c2677c71345cbd8ca0b76
a3d8a32d 38Patch0: %{name}-sign-function.patch
65cfa56f 39URL: http://www.sqlite.org/
d70f95dc 40%{?with_load_extension:Provides: %{name}(load_extension)}
41%{?with_unlock_notify:Provides: %{name}(unlock_notify)}
e0fdf246 42%{?with_icu:Provides: %{name}(icu)}
dd55e3fd 43BuildRequires: autoconf >= 2.50
17b8c9f1 44BuildRequires: automake
45BuildRequires: libtool
46BuildRequires: readline-devel
6ca4ac16 47%{?with_load_extension:BuildRequires: sed >= 4.0}
0e44e992 48BuildRequires: tcl
a8925d97 49%{?with_tcl:BuildRequires: tcl-devel >= %{tclver}}
086e11d9 50BuildRequires: unzip
17b8c9f1 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54SQLite is a C library that implements an SQL database engine. A large
55subset of SQL92 is supported. A complete database is stored in a
56single disk file. The API is designed for convenience and ease of use.
57Applications that link against SQLite can enjoy the power and
58flexiblity of an SQL database without the administrative hassles of
59supporting a separate database server. Because it omits the
60client-server interaction overhead and writes directly to disk, SQLite
61is also faster than the big database servers for most operations. In
62addition to the C library, the SQLite distribution includes a
63command-line tool for interacting with SQLite databases and SQLite
64bindings for Tcl/Tk.
65
b7c0e1f2
JR
66%description -l pl.UTF-8
67SQLite jest biblioteką języka C, która implementuje silnik baz danych
68SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
69przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
70bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
71danych bez konieczności utrzymywania osobnego serwera baz danych.
72Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
73bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
74bazodanowych przy większości operacji na bazie danych. Dodatkowo
75oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 76bazami danych.
77
78%package devel
79Summary: Header files for SQLite development
e882a99f 80Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
d70f95dc 83%if %{with unlock_notify}
d70f95dc 84Provides: %{name}-devel(unlock_notify)
85%endif
86%if %{with load_extension}
d70f95dc 87Provides: %{name}-devel(load_extension)
88%endif
e0fdf246
ER
89%if %{with icu}
90Provides: %{name}-devel(icu)
91%endif
17b8c9f1 92
93%description devel
94SQLite is a C library that implements an SQL database engine. A large
95subset of SQL92 is supported. A complete database is stored in a
96single disk file. The API is designed for convenience and ease of use.
97Applications that link against SQLite can enjoy the power and
98flexiblity of an SQL database without the administrative hassles of
99supporting a separate database server. Because it omits the
100client-server interaction overhead and writes directly to disk, SQLite
101is also faster than the big database servers for most operations. In
102addition to the C library, the SQLite distribution includes a
103command-line tool for interacting with SQLite databases and SQLite
104bindings for Tcl/Tk.
105
106This package contains the header files needed to develop programs that
107use these SQLite.
108
b7c0e1f2
JR
109%description devel -l pl.UTF-8
110SQLite jest biblioteką języka C, która implementuje silnik baz danych
111SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
112przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
113bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
114danych bez konieczności utrzymywania osobnego serwera baz danych.
115Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
116bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
117bazodanowych przy większości operacji na bazie danych. Dodatkowo
118oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 119bazami danych.
120
b7c0e1f2
JR
121Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
122używających biblioteki SQLite.
17b8c9f1 123
124%package static
125Summary: Static libraries for SQLite development
e882a99f 126Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 127Group: Development/Libraries
128Requires: %{name}-devel = %{version}-%{release}
d70f95dc 129%if %{with unclock_notify}
d70f95dc 130Provides: %{name}-static(unlock_notify)
131%endif
132%if %{with load_extension}
d70f95dc 133Provides: %{name}-static(load_extension)
134%endif
17b8c9f1 135
136%description static
137SQLite is a C library that implements an SQL database engine. A large
138subset of SQL92 is supported. A complete database is stored in a
139single disk file. The API is designed for convenience and ease of use.
140Applications that link against SQLite can enjoy the power and
141flexiblity of an SQL database without the administrative hassles of
142supporting a separate database server. Because it omits the
143client-server interaction overhead and writes directly to disk, SQLite
144is also faster than the big database servers for most operations. In
145addition to the C library, the SQLite distribution includes a
146command-line tool for interacting with SQLite databases and SQLite
147bindings for Tcl/Tk.
148
149This package contains the static SQLite libraries.
150
b7c0e1f2
JR
151%description static -l pl.UTF-8
152SQLite jest biblioteką języka C, która implementuje silnik baz danych
153SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
154przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
155bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
156danych bez konieczności utrzymywania osobnego serwera baz danych.
157Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
158bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
159bazodanowych przy większości operacji na bazie danych. Dodatkowo
160oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 161bazami danych.
162
163Pakiet zawiera statyczne biblioteki SQLite.
164
c743401f 165%package -n tcl-%{name}
8e66772b 166Summary: sqlite3 tcl extension
e882a99f 167Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 168Group: Development/Languages/Tcl
c743401f
AM
169
170%description -n tcl-%{name}
171sqlite3 tcl extension.
172
b7c0e1f2 173%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
174Rozszerzenie sqlite3 dla Tcl.
175
17b8c9f1 176%prep
c883dce2 177%setup -q -n sqlite-src-%{version_num}
30682d5a 178%patch0 -p1
1cd2f537 179
fc29cfbe 180%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
faed6cf7 181
78ed83ff
AM
182if [ "$(cat VERSION)" != "%{version}" ]; then
183 echo "Tarball content doesn't match version %{version}." >&2
184 exit 1
185fi
186
17b8c9f1 187%build
188%{__libtoolize}
189cp -f /usr/share/automake/config.sub .
190%{__aclocal}
191%{__autoconf}
fc29cfbe
ER
192append-cppflags() {
193 CPPFLAGS="$CPPFLAGS $*"
194}
195append-libs() {
196 LIBS="$LIBS $*"
197}
198export CPPFLAGS="%{rpmcflags}"
199export LIBS
87af9815
MB
200%if %{with tcl}
201export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
202%endif
e0fdf246 203
fc29cfbe
ER
204append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
205
206# Support column metadata functions.
207# http://sqlite.org/c3ref/column_database_name.html
208# http://sqlite.org/c3ref/table_column_metadata.html
209append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
210
211# Support Full-Text Search versions 3 and 4.
212# http://sqlite.org/fts3.html
213#append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
214append-cppflags -DSQLITE_ENABLE_FTS3
215
216# Support R*Trees.
217# http://sqlite.org/rtree.html
218append-cppflags -DSQLITE_ENABLE_RTREE
219
220# Support soundex() function.
221# http://sqlite.org/lang_corefunc.html#soundex
222#append-cppflags -DSQLITE_SOUNDEX
223
224%if %{with unlock_notify}
225# Support unlock notification.
226# http://sqlite.org/unlock_notify.html
227append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
228%endif
229
230%if %{with icu}
231append-cppflags -DSQLITE_ENABLE_ICU
232append-libs "-licui18n -licuuc"
233%endif
234
235%if %{with load_extension}
236append-libs "-ldl"
237%endif
238
17b8c9f1 239%configure \
e0fdf246 240 %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
60f66380 241 %{__enable_disable load_extension load-extension} \
17b8c9f1 242 --enable-threadsafe
60f66380 243
5df4522e 244%{__make}
1a6aae8d 245
e16bc4b1 246%if %{with doc}
17b8c9f1 247%{__make} doc
1a6aae8d 248%endif
17b8c9f1 249
3e5df83c 250%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 251
252%install
253rm -rf $RPM_BUILD_ROOT
1c91d9d5 254install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
17b8c9f1 255%{__make} install \
dd55e3fd 256 DESTDIR=$RPM_BUILD_ROOT
ec30f86a 257
1c91d9d5 258mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
dd55e3fd 259%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
1c91d9d5
JR
260ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
261 $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
262
e0fdf246 263cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 264
265%clean
266rm -rf $RPM_BUILD_ROOT
267
268%post -p /sbin/ldconfig
269%postun -p /sbin/ldconfig
270
271%files
272%defattr(644,root,root,755)
a8925d97 273%doc README.md
17b8c9f1 274%attr(755,root,root) %{_bindir}/sqlite3
1c91d9d5
JR
275%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
276%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
c743401f 277%{_mandir}/man1/sqlite3.1*
17b8c9f1 278
279%files devel
280%defattr(644,root,root,755)
7e92c022
JB
281%attr(755,root,root) %{_libdir}/libsqlite3.so
282%{_libdir}/libsqlite3.la
17b8c9f1 283%{_includedir}/sqlite3.h
ef88c71c 284%{_includedir}/sqlite3ext.h
7e92c022 285%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 286
287%files static
288%defattr(644,root,root,755)
7e92c022 289%{_libdir}/libsqlite3.a
c743401f 290
1a6aae8d 291%if %{with tcl}
c743401f
AM
292%files -n tcl-%{name}
293%defattr(644,root,root,755)
80deaf18 294%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
295%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
296%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 297%endif
This page took 0.431725 seconds and 4 git commands to generate.