]> git.pld-linux.org Git - packages/sqlite3.git/blame - sqlite3.spec
- updated to 3.6.20
[packages/sqlite3.git] / sqlite3.spec
CommitLineData
c743401f 1# TODO:
f1015391
JR
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
65cfa56f
ER
4# - alpha build fail:
5# tclsh ./tool/mksqlite3c.tcl
6# tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
7# make: *** [sqlite3.c] Aborted
8ef92c1a 8# - enable --enable-load-extension?
17b8c9f1 9#
10# Conditional build:
f1015391 11%bcond_with tests # run tests
158e8e57 12%bcond_with tcl # enable tcl extension
f1015391 13%bcond_without doc # disable documentation building
17b8c9f1 14#
f1015391
JR
15%ifarch alpha sparc %{x8664}
16%undefine with_tests
17%endif
18
19# disabling tcl currently breaks making test target,
20# some hack in Makefile needs to be done
21%if !%{with tcl}
22%undefine with_tests
23%endif
24
65cfa56f 25%define _ulibdir /usr/lib
539069d8 26%define tclver 8.5
f1015391 27
17b8c9f1 28Summary: SQLite library
e882a99f 29Summary(pl.UTF-8): Biblioteka SQLite
22ef5ab8 30Name: sqlite3
23e9b9f0 31Version: 3.6.20
1fafea49 32Release: 1
17b8c9f1 33License: LGPL
34Group: Libraries
65cfa56f
ER
35# Source0Download: http://www.sqlite.org/download.html
36Source0: http://www.sqlite.org/sqlite-%{version}.tar.gz
23e9b9f0 37# Source0-md5: 0faf8fc8ccff5297513c6532b2b4ce23
a3d8a32d 38Patch0: %{name}-sign-function.patch
65cfa56f 39URL: http://www.sqlite.org/
17b8c9f1 40BuildRequires: autoconf
41BuildRequires: automake
42BuildRequires: libtool
43BuildRequires: readline-devel
0e44e992 44BuildRequires: tcl
1a6aae8d 45%{?with_tcl:BuildRequires: tcl-devel}
17b8c9f1 46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49SQLite is a C library that implements an SQL database engine. A large
50subset of SQL92 is supported. A complete database is stored in a
51single disk file. The API is designed for convenience and ease of use.
52Applications that link against SQLite can enjoy the power and
53flexiblity of an SQL database without the administrative hassles of
54supporting a separate database server. Because it omits the
55client-server interaction overhead and writes directly to disk, SQLite
56is also faster than the big database servers for most operations. In
57addition to the C library, the SQLite distribution includes a
58command-line tool for interacting with SQLite databases and SQLite
59bindings for Tcl/Tk.
60
b7c0e1f2
JR
61%description -l pl.UTF-8
62SQLite jest biblioteką języka C, która implementuje silnik baz danych
63SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
64przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
65bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
66danych bez konieczności utrzymywania osobnego serwera baz danych.
67Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
68bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
69bazodanowych przy większości operacji na bazie danych. Dodatkowo
70oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 71bazami danych.
72
73%package devel
74Summary: Header files for SQLite development
e882a99f 75Summary(pl.UTF-8): Pliki nagłówkowe SQLite
17b8c9f1 76Group: Development/Libraries
77Requires: %{name} = %{version}-%{release}
78
79%description devel
80SQLite is a C library that implements an SQL database engine. A large
81subset of SQL92 is supported. A complete database is stored in a
82single disk file. The API is designed for convenience and ease of use.
83Applications that link against SQLite can enjoy the power and
84flexiblity of an SQL database without the administrative hassles of
85supporting a separate database server. Because it omits the
86client-server interaction overhead and writes directly to disk, SQLite
87is also faster than the big database servers for most operations. In
88addition to the C library, the SQLite distribution includes a
89command-line tool for interacting with SQLite databases and SQLite
90bindings for Tcl/Tk.
91
92This package contains the header files needed to develop programs that
93use these SQLite.
94
b7c0e1f2
JR
95%description devel -l pl.UTF-8
96SQLite jest biblioteką języka C, która implementuje silnik baz danych
97SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
98przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
99bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
100danych bez konieczności utrzymywania osobnego serwera baz danych.
101Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
102bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
103bazodanowych przy większości operacji na bazie danych. Dodatkowo
104oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 105bazami danych.
106
b7c0e1f2
JR
107Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
108używających biblioteki SQLite.
17b8c9f1 109
110%package static
111Summary: Static libraries for SQLite development
e882a99f 112Summary(pl.UTF-8): Statyczne biblioteki SQLite
17b8c9f1 113Group: Development/Libraries
114Requires: %{name}-devel = %{version}-%{release}
115
116%description static
117SQLite is a C library that implements an SQL database engine. A large
118subset of SQL92 is supported. A complete database is stored in a
119single disk file. The API is designed for convenience and ease of use.
120Applications that link against SQLite can enjoy the power and
121flexiblity of an SQL database without the administrative hassles of
122supporting a separate database server. Because it omits the
123client-server interaction overhead and writes directly to disk, SQLite
124is also faster than the big database servers for most operations. In
125addition to the C library, the SQLite distribution includes a
126command-line tool for interacting with SQLite databases and SQLite
127bindings for Tcl/Tk.
128
129This package contains the static SQLite libraries.
130
b7c0e1f2
JR
131%description static -l pl.UTF-8
132SQLite jest biblioteką języka C, która implementuje silnik baz danych
133SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
134przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
135bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
136danych bez konieczności utrzymywania osobnego serwera baz danych.
137Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
138bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
139bazodanowych przy większości operacji na bazie danych. Dodatkowo
140oprócz biblioteki języka C, dostarczany jest program do zarządzania
17b8c9f1 141bazami danych.
142
143Pakiet zawiera statyczne biblioteki SQLite.
144
c743401f 145%package -n tcl-%{name}
8e66772b 146Summary: sqlite3 tcl extension
e882a99f 147Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
8e66772b 148Group: Development/Languages/Tcl
c743401f
AM
149
150%description -n tcl-%{name}
151sqlite3 tcl extension.
152
b7c0e1f2 153%description -n tcl-%{name} -l pl.UTF-8
c743401f
AM
154Rozszerzenie sqlite3 dla Tcl.
155
17b8c9f1 156%prep
c743401f 157%setup -q -n sqlite-%{version}
30682d5a 158%patch0 -p1
1cd2f537 159
faed6cf7
ER
160%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
161
162%ifarch alpha
163# See also LP#276821
164# wrapper script to reset stack to 8192 as if ran from make it's insanely huge!:
165# stack(kbytes) 18014398509481983
166cat <<'EOF' > tclsh.sh
167#!/bin/sh
168ulimit -s 8192
169exec tclsh "$@"
170EOF
171chmod +x tclsh.sh
172%endif
17b8c9f1 173
174%build
175%{__libtoolize}
176cp -f /usr/share/automake/config.sub .
177%{__aclocal}
178%{__autoconf}
f1015391
JR
179CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
180export CFLAGS
17b8c9f1 181%configure \
1a6aae8d 182 %{?with_tcl:--with-tcl=%{_ulibdir}} \
183 %{!?with_tcl:--disable-tcl} \
17b8c9f1 184 --enable-threadsafe
faed6cf7
ER
185%{__make} \
186%ifarch alpha
187 TCLSH_CMD=./tclsh.sh
188%endif
1a6aae8d 189
e16bc4b1 190%if %{with doc}
17b8c9f1 191%{__make} doc
1a6aae8d 192%endif
17b8c9f1 193
3e5df83c 194%{?with_tests:LC_ALL=C %{__make} test}
17b8c9f1 195
196%install
197rm -rf $RPM_BUILD_ROOT
198install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
199
200%{__make} install \
faed6cf7
ER
201%ifarch alpha
202 TCLSH_CMD=./tclsh.sh \
203%endif
80deaf18
JR
204 DESTDIR=$RPM_BUILD_ROOT \
205 TCLLIBDIR=%{_libdir}/tcl%{tclver}
17b8c9f1 206
22de4c1c 207%if %{with tcl}
7e92c022 208sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
22de4c1c 209%endif
ec30f86a 210
c743401f 211install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
17b8c9f1 212
213%clean
214rm -rf $RPM_BUILD_ROOT
215
216%post -p /sbin/ldconfig
217%postun -p /sbin/ldconfig
218
219%files
220%defattr(644,root,root,755)
221%doc README
222%attr(755,root,root) %{_bindir}/sqlite3
7e92c022
JB
223%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
224%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
c743401f 225%{_mandir}/man1/sqlite3.1*
17b8c9f1 226
227%files devel
228%defattr(644,root,root,755)
7e92c022
JB
229%attr(755,root,root) %{_libdir}/libsqlite3.so
230%{_libdir}/libsqlite3.la
17b8c9f1 231%{_includedir}/sqlite3.h
ef88c71c 232%{_includedir}/sqlite3ext.h
7e92c022 233%{_pkgconfigdir}/sqlite3.pc
17b8c9f1 234
235%files static
236%defattr(644,root,root,755)
7e92c022 237%{_libdir}/libsqlite3.a
c743401f 238
1a6aae8d 239%if %{with tcl}
c743401f
AM
240%files -n tcl-%{name}
241%defattr(644,root,root,755)
80deaf18 242%dir %{_libdir}/tcl*/sqlite3
7e92c022
JB
243%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
244%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
1a6aae8d 245%endif
This page took 0.060704 seconds and 4 git commands to generate.