]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- support for db4.5
[packages/python.git] / python.spec
CommitLineData
30baa9fb 1#
55c63f85
ER
2# TODO
3# - test_distutils fails for unknown reason: (does it still do with new lib64 patch?)
4# AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
5# - change searchpath order so /usr/lib* is before /usr/share
6# - kill lib-tk from searchpath
7# - kill BR: file requirement from lib64 patch
390a4bf0 8#
9ef7b464 9# Conditional build:
b9a3d728 10%bcond_with info # don't build info pages (requires emacs, fails in python-2.5.0)
d6b7073f 11%bcond_without tkinter # disables tkinter module building
12%bcond_without tests # disables Python testing
26f84c7d 13%bcond_with verbose_tests # runs tests in verbose mode
390a4bf0 14#
ca0308fd
JK
15# tests which will not work on 64-bit platforms
16%define no64bit_tests test_audioop test_rgbimg test_imageop
17# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
0070b9d1 18%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
390a4bf0 19# tests which fail because of some unknown/unresolved reason (this list should be empty)
72dcf1e0 20%define broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
72dcf1e0 21
1c82c104 22%define beta %{nil}
30baa9fb 23
24%define py_ver 2.5
72dcf1e0 25%define py_prefix %{_prefix}
26%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
27%define py_incdir %{_includedir}/python%{py_ver}
28%define py_sitedir %{py_libdir}/site-packages
29%define py_dyndir %{py_libdir}/lib-dynload
a9ce5112 30
5b13880d 31Summary: Very high level scripting language with X interface
57ffb4c2 32Summary(es): Lenguaje script de alto nivel con interfaz X
fb6664e1 33